Community Forum

Author Topic: auto placement of blue-flag markers  (Read 273 times)

weissspice

  • Newbie
  • *
  • Posts: 15
    • View Profile
auto placement of blue-flag markers
« on: December 05, 2017, 12:51:59 AM »
Hi all,
Is there a way to permanently disable the auto placement of blue-flagged markers?  I only want markers where I hand place them.  Or is there a way to select multiple photos and clear all their markers at once?  I haven't found a way for either one.  The auto placed markers are really screwing things up.
-c

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 7779
    • View Profile
Re: auto placement of blue-flag markers
« Reply #1 on: December 05, 2017, 12:59:43 AM »
Hello weissspice,

If you wish to place markers' projections only manually, you need to use Place Marker option instead of Create Marker from the context menu of the Photo view.

Blue flags (unpinned projections) may be removed for all markers using Python. If necessary, I can post a code here.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

weissspice

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: auto placement of blue-flag markers
« Reply #2 on: December 05, 2017, 01:07:43 AM »
Great!  No need for the coding at the moment, thanks!  Knowing how to have only manually placed markers will help immensely.

weissspice

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: auto placement of blue-flag markers
« Reply #3 on: December 05, 2017, 01:16:06 AM »
It's still autopopulating, albeit less aggressively.  There's really no way to disable unpinned markers altogether?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 7779
    • View Profile
Re: auto placement of blue-flag markers
« Reply #4 on: December 05, 2017, 08:55:05 AM »
Hello weissspice,

Maybe you have "refine marker projections" option turned on in the Advanced preferences tab? If so, then you should disable it.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

weissspice

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: auto placement of blue-flag markers
« Reply #5 on: December 07, 2017, 01:43:05 AM »
That worked!  Thanks!