Community Forum

Author Topic: My photos never seem to calibrate (always NC) lately  (Read 439 times)

Brit

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
My photos never seem to calibrate (always NC) lately
« on: December 07, 2017, 09:37:20 AM »
My photos never seem to calibrate lately. In the last year or so my photos rarely seem to calibrate. I upgraded my drone from a P3 to a Mavic, and my camera from a Sony RX100 I, to a RX 100 IV.

I did find the specs for the calibration on this forum for the Mavic, but it’s a mystery on why the Sony images often come up “NC” after aligning.

I usually use the lens at the default wide angle, but I sometimes mix it with a shorter focal length for detailed shots, Photoscan almost always used to catch the calibration. (Albeit, it stills seems to scan ok with NC alignments.) Any suggestions?

Smallpoly

  • Newbie
  • *
  • Posts: 24
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #1 on: December 07, 2017, 11:04:27 PM »
Can you share the photo set you're using for calibration?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 7775
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #2 on: December 07, 2017, 11:11:25 PM »
NC - not calibrated - means that the EXIF information is not sufficient to get focal length in mm and sensor pixel size, so one or both values are missing in the Camera Calibration window.

Even aligned cameras would remain "Not Calibrated", if one or both values mentioned above are missing.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

Brit

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #3 on: December 08, 2017, 12:20:48 AM »
What in lay terms does this mean? And what can I do about it? It has happened either with my new cameras (both are new and working very well) or it's the new software versions.
I'll upload the images when I have a chance. ...Do they need to be calibrated?  It seems to more or less work with nc images.
« Last Edit: December 08, 2017, 12:26:02 AM by Brit »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 7775
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #4 on: December 08, 2017, 12:49:14 AM »
Hello Brit,

You can open the Camera Calibration dialog and check which values are missing: focal length in mm or sensor pixel size in mm.
Either value can be input manually prior to the camera alignment.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

pap1956@gmail.com

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #5 on: December 08, 2017, 01:15:33 AM »
Hello Brit,

from Imaging resource web site your Sony camera has following sensor:

Image Sensor
Sensor Type:CMOS
Sensor Manufacturer:Sony Exmor RS
Effective Megapixels:20.1
Sensor Format:1 inch
Sensor size:116.16mm2 (13.20mm x 8.80mm)
Approximate Pixel Pitch: 2.41 microns or 0.00241 mm

So you should input in Camera Calibration dialog 0.00241 mm for sensor pixel size




Best Regards,

Paul Pelletier

Brit

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #6 on: December 09, 2017, 05:03:24 AM »
Thanks for the info on the sensor pixel size! But of course since I used 2 focal lengths on the zoom lens I cannot add that to the calibration.

How important is the calibration? It still more or less works without it.

"Smallpoly", I placed 2 small sets with different focal lengths of images on this download link: https://mega.nz/#F!F9IVXRpQ!-epXlm7QRy5DC1RbRYal6Q

pap1956@gmail.com

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #7 on: December 09, 2017, 05:19:29 AM »
Brit,

using 2 different focal distances does not change the pixel size, so you can just enter them in both calibration sensor groups...

Best Regards,

Paul Pelletier

Brit

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #8 on: December 09, 2017, 11:23:47 PM »
Thanks.

So the pixels size is the most important? I can leave the focal length out of the calibration tool without much of a problem in the final result?  It seemed to work OK.

pap1956@gmail.com

  • Full Member
  • ***
  • Posts: 170
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #9 on: December 10, 2017, 01:56:10 AM »
Yes, one or the other should be sufficient to define calibration...

But with your sample photos, I still have NC after entering pixel sensor size in Calibration window....and optimizing

Maybe Alexey can clear this up?

Best Regards,

Paul Pelletier

Brit

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #10 on: December 11, 2017, 03:08:57 AM »
"Approximate Pixel Pitch: 2.41 microns or 0.00241 mm"

Photoscan calculated one set - calibrated at the pixel size 0.00157777, with the focal length at 0.00157777 at 4.73 for the Sony RX100 IV on its default wide angle setting
« Last Edit: December 11, 2017, 12:00:02 PM by Brit »

Brit

  • Jr. Member
  • **
  • Posts: 51
    • View Profile
Re: My photos never seem to calibrate (always NC) lately
« Reply #11 on: January 15, 2018, 09:27:20 AM »
I see my mistake now! When I converted the RAW images on my laptop into Tiff images, I lost my EXIF Data that contained the calibration information. I now fixed it in Photoshop, so that the RAW converter saves all metadata when converting from RAW to Tiff. The correct focal length at its widest (24mm) is 8.8 and the pixel size is (as above): .00241.