# Table of Contents

Overview .......................................................................................................................... v
  How it works ...................................................................................................................... v
  About the manual ............................................................................................................. v

1. Installation ....................................................................................................................... 1
   System requirements ........................................................................................................ 1
   OpenCL acceleration ......................................................................................................... 1
   Installation procedure ..................................................................................................... 2
   Restrictions of the Demo mode ..................................................................................... 2

2. Capturing photos ........................................................................................................... 4
   Equipment ....................................................................................................................... 4
   Camera settings ............................................................................................................. 4
   Object / scene requirements .......................................................................................... 4
   Image preprocessing ........................................................................................................ 4
   Capturing scenarios ......................................................................................................... 5
   Restrictions ..................................................................................................................... 6

3. General workflow ......................................................................................................... 8
   Preferences settings ........................................................................................................ 8
   Loading photos .............................................................................................................. 8
   Aligning photos ............................................................................................................. 10
   Building dense point cloud ......................................................................................... 13
   Building mesh ............................................................................................................... 14
   Building model texture .................................................................................................. 15
   Saving intermediate results ......................................................................................... 17
   Exporting results ............................................................................................................ 18

4. Referencing and measurements .................................................................................... 27
   Camera calibration ......................................................................................................... 27
   Setting coordinate system ............................................................................................ 29
   Optimization of camera alignment ............................................................................... 34
   Working with coded and non-coded targets ................................................................. 37
   Performing measurements ............................................................................................. 38

5. Editing ........................................................................................................................... 41
   Using masks .................................................................................................................... 41
   Editing point cloud ........................................................................................................ 45
   Classifying dense cloud points ..................................................................................... 47
   Editing model geometry ................................................................................................. 48

6. Automation ..................................................................................................................... 53
   Using chunks .................................................................................................................. 53
   4D processing ................................................................................................................ 57
   Python scripting ............................................................................................................ 59

7. Network processing ....................................................................................................... 60
   Overview ......................................................................................................................... 60
   Cluster components ....................................................................................................... 60
   Cluster setup .................................................................................................................. 61
   Cluster administration .................................................................................................. 63

A. Graphical user interface ................................................................................................. 64
   Application window ....................................................................................................... 64
   Menu commands ............................................................................................................ 67
   Toolbar buttons ............................................................................................................. 71
   Hot keys ........................................................................................................................ 73

B. Supported formats ........................................................................................................ 75
   Images ........................................................................................................................... 75
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camera calibration</td>
<td>75</td>
</tr>
<tr>
<td>Camera flight log</td>
<td>75</td>
</tr>
<tr>
<td>GCP locations</td>
<td>75</td>
</tr>
<tr>
<td>Intrinsic and extrinsic camera parameters</td>
<td>75</td>
</tr>
<tr>
<td>Tie points</td>
<td>76</td>
</tr>
<tr>
<td>Sparse/dense point cloud</td>
<td>76</td>
</tr>
<tr>
<td>Mesh model</td>
<td>76</td>
</tr>
<tr>
<td>Texture</td>
<td>77</td>
</tr>
<tr>
<td>Orthophoto</td>
<td>77</td>
</tr>
<tr>
<td>Digital elevation model (DSM/DTM)</td>
<td>77</td>
</tr>
<tr>
<td>Tiled models</td>
<td>77</td>
</tr>
<tr>
<td>C. Camera models</td>
<td>78</td>
</tr>
<tr>
<td>Frame cameras</td>
<td>78</td>
</tr>
<tr>
<td>Fisheye cameras</td>
<td>79</td>
</tr>
<tr>
<td>Spherical cameras (equirectangular projection)</td>
<td>79</td>
</tr>
</tbody>
</table>
Overview

Agisoft PhotoScan is an advanced image-based 3D modeling solution aimed at creating professional quality 3D content from still images. Based on the latest multi-view 3D reconstruction technology, it operates with arbitrary images and is efficient in both controlled and uncontrolled conditions. Photos can be taken from any position, providing that the object to be reconstructed is visible on at least two photos. Both image alignment and 3D model reconstruction are fully automated.

How it works

Generally the final goal of photographs processing with PhotoScan is to build a textured 3D model. The procedure of photographs processing and 3D model construction comprises four main stages.

1. The first stage is camera alignment. At this stage PhotoScan searches for common points on photographs and matches them, as well as it finds the position of the camera for each picture and refines camera calibration parameters. As a result a sparse point cloud and a set of camera positions are formed.

   The sparse point cloud represents the results of photo alignment and will not be directly used in the further 3D model construction procedure (except for the sparse point cloud based reconstruction method). However it can be exported for further usage in external programs. For instance, the sparse point cloud model can be used in a 3D editor as a reference.

   On the contrary, the set of camera positions is required for further 3D model construction by PhotoScan.

2. The next stage is building dense point cloud. Based on the estimated camera positions and pictures themselves a dense point cloud is built by PhotoScan. Dense point cloud may be edited and classified prior to export or proceeding to 3D mesh model generation.

3. Another stage is building mesh. PhotoScan reconstructs a 3D polygonal mesh representing the object surface based on the dense point cloud. Additionally there is a Point Cloud based method for fast geometry generation based on the sparse point cloud alone. Generally there are two algorithmic methods available in PhotoScan that can be applied to 3D mesh generation: Height Field - for planar type surfaces, Arbitrary - for any kind of object.

   Having built the mesh, it may be necessary to edit it. Some corrections, such as mesh decimation, removal of detached components, closing of holes in the mesh, etc. can be performed by PhotoScan. For more complex editing you have to engage external 3D editor tools. PhotoScan allows to export mesh, edit it by another software and import it back.

4. After geometry (i.e. mesh) is reconstructed, it can be textured and / or used for orthophoto generation. Several texturing modes are available in PhotoScan, they are described in the corresponding section of this manual.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these operations are carried out automatically according to the parameters set by user. Instructions on how to get through these operations and descriptions of the parameters controlling each step are explained in the corresponding sections of the Chapter 3, General workflow.

In some cases, however, additional actions may be required to get the desired results. In some capturing scenarios masking of certain regions of the photos may be required to exclude them from the calculations. Application of masks in PhotoScan processing workflow as well as editing options available are
described in Chapter 5, Editing. Camera calibration issues are discussed in Chapter 4, Referencing and measurements, that also describes functionality to reference the results and carry out measurements on the model. While Chapter 6, Automation describes opportunities to save up on manual intervention to the processing workflow, Chapter 7, Network processing presents guidelines on how to organize distributed processing of the imagery data on several nodes.

It can take up quite a long time to reconstruct a 3D model. PhotoScan allows to export obtained results and save intermediate data in a form of project files at any stage of the process. If you are not familiar with the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can also find instructions on the PhotoScan installation procedure and basic rules for taking “good” photographs, i.e. pictures that provide most necessary information for 3D reconstruction. For the information refer to Chapter 2, Capturing photos and Chapter 1, Installation.
Chapter 1. Installation

System requirements

Minimal configuration

• Windows XP or later (32 or 64 bit), Mac OS X Snow Leopard or later, Debian / Ubuntu (64 bit)
• Intel Core 2 Duo processor or equivalent
• 2GB of RAM

Recommended configuration

• Windows XP or later (64 bit), Mac OS X Snow Leopard or later, Debian / Ubuntu (64 bit)
• Intel Core i7 processor
• 12GB of RAM

The number of photos that can be processed by PhotoScan depends on the available RAM and reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPx, 2GB RAM is sufficient to make a model based on 20 to 30 photos. 12GB RAM will allow to process up to 200-300 photographs.

OpenCL acceleration

PhotoScan supports accelerated depth maps reconstruction due to the graphics hardware (GPU) exploiting.

NVidia
  GeForce 8xxx series and later.

ATI
  Radeon HD 5xxx series and later.

PhotoScan is likely to be able to utilize processing power of any OpenCL enabled device during Dense Point Cloud generation stage, provided that OpenCL drivers for the device are properly installed. However, because of the large number of various combinations of video chips, driver versions and operating systems, Agisoft is unable to test and guarantee PhotoScan's compatibility with every device and on every platform.

The table below lists currently supported devices (on Windows platform only). We will pay particular attention to possible problems with PhotoScan running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

<table>
<thead>
<tr>
<th>NVIDIA</th>
<th>AMD</th>
</tr>
</thead>
<tbody>
<tr>
<td>GeForce GTX Titan</td>
<td>Radeon R9 290x</td>
</tr>
<tr>
<td>GeForce GTX 980</td>
<td>Radeon HD 7970</td>
</tr>
<tr>
<td>GeForce GTX 780</td>
<td>Radeon HD 6970</td>
</tr>
<tr>
<td>GeForce GTX 680</td>
<td>Radeon HD 6950</td>
</tr>
<tr>
<td>GeForce GTX 580</td>
<td>Radeon HD 6870</td>
</tr>
</tbody>
</table>
**Installation**

**NVIDIA**
- GeForce GTX 570
- GeForce GTX 560
- GeForce GTX 480
- GeForce GTX 470
- GeForce GTX 465
- GeForce GTX 285
- GeForce GTX 280

**AMD**
- Radeon HD 5870
- Radeon HD 5850
- Radeon HD 5830

Although PhotoScan is supposed to be able to utilize other GPU models and being run under a different operating system, Agisoft does not guarantee that it will work correctly.

**Note**

- OpenCL acceleration can be enabled using OpenCL tab in the Preferences dialog box. For each OpenCL device used one physical CPU core should be disabled for optimal performance.

- Using OpenCL acceleration with mobile or integrated graphics video chips is not recommended because of the low performance of such GPUs.

**Installation procedure**

**Installing PhotoScan on Microsoft Windows**

To install PhotoScan on Microsoft Windows simply run the downloaded msi file and follow the instructions.

**Installing PhotoScan on Mac OS X**

Open the downloaded dmg image and drag PhotoScan application to the desired location on your hard drive.

**Installing PhotoScan on Debian/Ubuntu**

Unpack the downloaded archive with a program distribution kit to the desired location on your hard drive. Start PhotoScan by running photoscan.sh script from the program folder.

**Restrictions of the Demo mode**

Once PhotoScan is downloaded and installed on your computer you can run it either in the Demo mode or in the full function mode. On every start until you enter a serial number it will show a registration box offering two options: (1) use PhotoScan in the Demo mode or (2) enter a serial number to confirm the purchase. The first choice is set by default, so if you are still exploring PhotoScan click the Continue button and PhotoScan will start in the Demo mode.

The employment of PhotoScan in the Demo mode is not time limited. Several functions, however, are not available in the Demo mode. These functions are the following:

- saving the project;
• exporting reconstruction results (you can only view a 3D model on the screen);

• some Python commands.

To use PhotoScan in the full function mode you have to purchase it. On purchasing you will get the serial number to enter into the registration box on starting PhotoScan. Once the serial number is entered the registration box will not appear again and you will get full access to all functions of the program.
Chapter 2. Capturing photos

Before loading your photographs into PhotoScan you need to take them and select those suitable for 3D model reconstruction.

Photographs can be taken by any digital camera (both metric and non-metric), as long as you follow some specific capturing guidelines. This section explains general principles of taking and selecting pictures that provide the most appropriate data for 3D model generation.

IMPORTANT! Make sure you have studied the following rules and read the list of restrictions before you get out for shooting photographs.

Equipment

• Use a digital camera with reasonably high resolution (5 MPix or more).
• Avoid ultra-wide angle and fish-eye lenses. The best choice is 50 mm focal length (35 mm film equivalent) lenses. It is recommended to use focal length from 20 to 80 mm interval in 35mm equivalent. If a data set was captured with fish-eye lens, appropriate camera sensor type should be selected in PhotoScan Camera Calibration settings prior to processing.
• Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to minimal value during the entire shooting session for more stable results.

Camera settings

• Using RAW data losslessly converted to the TIFF files is preferred, since JPG compression induces unwanted noise to the images.
• Take images at maximal possible resolution.
• ISO should be set to the lowest value, otherwise high ISO values will induce additional noise to images.
• Aperture value should be high enough to result in sufficient focal depth: it is important to capture sharp, not blurred photos.
• Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Object / scene requirements

• Avoid not textured, shiny, mirror or transparent objects.
• If still have to, shoot shiny objects under a cloudy sky.
• Avoid unwanted foregrounds.
• Avoid moving objects within the scene to be reconstructed.
• Avoid absolutely flat objects or scenes.

Image preprocessing

• PhotoScan operates with the original images. So do not crop or geometrically transform, i.e. resize or rotate, the images.
Capturing scenarios

Generally, spending some time planning your shot session might be very useful.

- Number of photos: more than required is better than not enough.

- Number of "blind-zones" should be minimized since PhotoScan is able to reconstruct only geometry visible from at least two cameras. In case of aerial photography the overlap requirement can be put in the following figures: 60% of side overlap + 80% of forward overlap.

- Each photo should effectively use the frame size: object of interest should take up the maximum area. In some cases portrait camera orientation should be used.

- Do not try to place full object in the image frame, if some parts are missing it is not a problem providing that these parts appear on other images.

- Good lighting is required to achieve better quality of the results, yet blinks should be avoided. It is recommended to remove sources of light from camera fields of view. Avoid using flash.

- If you are planning to carry out any measurements based on the reconstructed model, do not forget to locate at least two markers with a known distance between them on the object. Alternatively, you could place a ruler within the shooting area.

- In case of aerial photography and demand to fulfill georeferencing task, even spread of ground control points (GCPs) (at least 10 across the area to be reconstructed) is required to achieve results of highest quality, both in terms of the geometrical precision and georeferencing accuracy. Yet, Agisoft PhotoScan is able to complete the reconstruction and georeferencing tasks without GCPs, too.

The following figures represent advice on appropriate capturing scenarios:

Facade (Incorrect)  Facade (Correct)
Restrictions

In some cases it might be very difficult or even impossible to build a correct 3D model from a set of pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

PhotoScan can process only unmodified photos as they were taken by a digital photo camera. Processing the photos which were manually cropped or geometrically warped is likely to fail or to produce highly inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

To estimate the field of view for each photo PhotoScan uses the information saved in the EXIF part of each picture. If EXIF data are available you can expect to get the best possible 3D reconstruction. However 3D scene can also be reconstructed in the absence of EXIF data. In this case PhotoScan assumes that focal length in 35 mm equivalent equals to 50 mm and tries to align the photos in accordance with this assumption. If the correct focal length value differs significantly from 50 mm, the alignment can give incorrect results or even fail. In such cases it is required to specify initial camera calibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are given in the Camera calibration section.
**Lens distortion**

The distortion of the lenses being used to capture the photos should be well simulated with the Brown's distortion model. Otherwise it is most unlikely that processing results will be accurate. Fisheye and ultra-wide angle lenses are poorly modeled by the common distortion model implemented in PhotoScan software, so it is required to choose proper camera type in Camera Calibration dialog prior to processing.
Chapter 3. General workflow

Processing of images with PhotoScan includes the following main steps:

- loading photos into PhotoScan;
- inspecting loaded images, removing unnecessary images;
- aligning photos;
- building dense point cloud;
- building mesh (3D polygonal model);
- generating texture;
- exporting results.

If you are using PhotoScan in the full function (not the Demo) mode, intermediate results of the image processing can be saved at any stage in the form of project files and can be used later. The concept of projects and project files is briefly explained in the Saving intermediate results section.

The list above represents all the necessary steps involved in the construction of a textured 3D model from your photos. Some additional tools, which you may find to be useful, are described in the successive chapters.

Preferences settings

Before starting a project with PhotoScan it is recommended to adjust the program settings for your needs. In Preferences dialog (General Tab) available through the Tools menu you can indicate the path to the PhotoScan log file to be shared with the Agisoft support team in case you face any problems during the processing. Here you can also change GUI language to the one that is most convenient for you. The options are: English, Chinese, French, German, Portuguese, Russian, Spanish.

On the OpenCL Tab you need to make sure that all OpenCL devices detected by the program are checked. PhotoScan exploits GPU processing power that speeds up the process significantly. If you have decided to switch on GPUs for photogrammetric data processing with PhotoScan, it is recommended to free one physical CPU core per each active GPU for overall control and resource managing tasks.

Loading photos

Before starting any operation it is necessary to point out what photos will be used as a source for 3D reconstruction. In fact, photographs themselves are not loaded into PhotoScan until they are needed. So, when you "load photos" you only indicate photographs that will be used for further processing.

To load a set of photos

1. Select Add Photos... command from the Workflow menu or click Add Photos toolbar button on the Workspace pane.

2. In the Add Photos dialog box browse to the folder containing the images and select files to be processed. Then click Open button.

Note

- PhotoScan accepts the following image formats: JPEG, TIFF, PNG, BMP, PPM, OpenEXR and JPEG Multi-Picture Format (MPO). Photos in any other format will not be shown in the Add Photos dialog box. To work with such photos you will need to convert them in one of the supported formats.

If you have loaded some unwanted photos, you can easily remove them at any moment.

To remove unwanted photos

1. On the Workspace pane select the photos to be removed.
2. Right-click on the selected photos and choose Remove Items command from the opened context menu, or click Remove Items toolbar button on the Workspace pane. The selected photos will be removed from the working set.

Camera groups

If all the photos or a subset of photos were captured from one camera position - camera station, for PhotoScan to process them correctly it is obligatory to move those photos to a camera group and mark the group as Camera Station. It is important that for all the photos in a Camera Station group distances between camera centers were negligibly small compared to the camera-object minimal distance. 3D model reconstruction will require at least two camera stations with overlapping photos to be present in a chunk. However, it is possible to export panoramic picture for the data captured from only one camera station. Refer to Exporting results section for guidance on panorama export.

Alternatively, camera group structure can be used to manipulate the image data in a chunk easily, like applying Disable / Enable functions to the whole cameras in a group at once.

To move photos to a camera group

1. On the Workspace pane (or Photos pane) select the photos to be moved.
2. Right-click on the selected photos and choose Move Cameras - New Camera Group command from the opened context menu.
3. A new group will be added to the active chunk structure and selected photos will be moved to that group.
4. Alternatively selected photos can be moved to a camera group created earlier using Move Cameras - Camera Group - Group_name command from the context menu.

To mark group as camera station right click on the camera group name and select Set Group Type command from the context menu.

Inspecting loaded photos

Loaded photos are displayed on the Workspace pane along with flags reflecting their status.

The following flags can appear next to the photo name:

NC (Not calibrated)

Notifies that the EXIF data available is not sufficient to estimate the camera focal length. In this case PhotoScan assumes that the corresponding photo was taken using 50mm lens (35mm film equivalent).
General workflow

If the actual focal length differs significantly from this value, manual calibration may be required. More details on manual camera calibration can be found in the Camera calibration section.

NA (Not aligned)
Notifies that external camera orientation parameters were not estimated for the current photo yet. Images loaded to PhotoScan will not be aligned until you perform the next step - photos alignment.

Notifies that Camera Station type was assigned to the group.

Multispectral imagery

PhotoScan supports processing of multispectral images saved as multichannel (single page) TIFF files. The main processing stages for multispectral images are performed based on the master channel, which can be selected by the user. During orthophoto export, all spectral bands are processed together to form a multispectral orthophoto with the same bands as in source images.

The overall procedure for multispectral imagery processing does not differ from the usual procedure for normal photos, except the additional master channel selection step performed after adding images to the project. For the best results it is recommended to select the spectral band which is sharp and as much detailed as possible.

To select master channel

1. Add multispectral images to the project using Add Photos... command from the Workflow menu or Add Photos toolbar button.
2. Select Set Master Channel... command from the chunk context menu in the Workspace pane.
3. In the Set Master Channel dialog select the channel to be used as master and click OK button. Display of images in PhotoScan window will be updated according to the master channel selection.

Note
- Set Master Channel... command is available for RGB images as well. You can either indicate only one channel to be used as the basis for photogrammetric processing or leave the parameter value as Default for all three channels to be used in processing.

Multispectral orthophoto export is supported in GeoTIFF format only. When exporting in other formats, only master channel will be saved.

Aligning photos

Once photos are loaded into PhotoScan, they need to be aligned. At this stage PhotoScan finds the camera position and orientation for each photo and builds a sparse point cloud model.

To align a set of photos

1. Select Align Photos... command from the Workflow menu.
2. In the Align Photos dialog box select the desired alignment options. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.
General workflow

Alignment having been completed, computed camera positions and a sparse point cloud will be displayed. You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches between any two photos use View Matches... command from a photo context menu in the Photos pane.

Incorrectly positioned photos can be realigned.

To realign a subset of photos

1. Reset alignment for incorrectly positioned cameras using Reset Camera Alignment command from the photo context menu.
2. Set markers (at least 4 per photo) on these photos and indicate their projections on at least two photos from the already aligned subset. PhotoScan will consider these points to be true matches. (For information on markers placement refer to the Setting coordinate system section).
3. Select photos to be realigned and use Align Selected Cameras command from the photo context menu.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

When the alignment step is completed, the point cloud and estimated camera positions can be exported for processing with another software if needed.

Image quality

Poor input, e.g. vague photos can influence alignment results badly. To help you to exclude poorly focused images from processing PhotoScan suggests automatic image quality estimation feature. Images with quality value of less than 0.5 units are recommended to be disabled and thus excluded from photogrammetric processing, providing that the rest of the photos cover the whole scene to be reconstructed. To disable a photo use Disable button from the Photos pane toolbar.

PhotoScan estimates image quality for each input image. The value of the parameter is calculated based on the sharpness level of the most focused part of the picture.

To estimate image quality

1. Switch to the detailed view in the Photos pane using Details command from the Change menu on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.
3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the context menu.
4. Once the analysis procedure is over, a figure indicating estimated image quality value will be displayed in the Quality column on the Photos pane.

Alignment parameters

The following parameters control the photo alignment procedure and can be modified in the Align Photos dialog box:

Accuracy
Higher accuracy setting helps to obtain more accurate camera position estimates. Lower accuracy setting can be used to get the rough camera positions in a shorter period of time. While at High
accuracy setting the software works with the photos of the original size, Medium setting cause image downscaling by factor of 4 (2 times by each side), and at Low accuracy source files are downscaled by further 4 times.

**Pair preselection**

The alignment process of large photo sets can take a long time. A significant portion of this time period is spent on matching of detected features across the photos. Image pair preselection option may speed up this process due to selection of a subset of image pairs to be matched. In the Generic preselection mode the overlapping pairs of photos are selected by matching photos using lower accuracy setting first. In the Reference preselection mode the overlapping pairs of photos are selected basing on the measured camera locations (if present). For oblique imagery it is recommended to set Ground altitude value in the Settings dialog of the Reference pane to make the preselection procedure more efficient. Ground altitude information must be accompanied with yaw, pitch, roll data for cameras to be input in the Reference pane as well.

Additionally the following advanced parameters can be adjusted.

**Key point limit**

The number indicates upper limit of feature points on every image to be taken into account during current processing stage. Using zero value allows PhotoScan to find as many key points as possible, but it may result in a big number of less reliable points.

**Tie point limit**

The number indicates upper limit of matching points for every image. Using zero value doesn't apply any tie point filtering.

**Constrain features by mask**

When this option is enabled, features detected in the masked image regions are discarded. For additional information on the usage of masks please refer to the Using masks section.

**Note**

- Tie point limit parameter allows to optimize performance for the task and does not generally effect the quality of the further model. Recommended value is 1000. Too high tie-point limit value may cause some parts of the dense point cloud model to be missed. The reason is that PhotoScan generates depth maps only for pairs of photos for which number of matching points is above certain limit. This limit equals to 100 matching points, unless moved up by the figure "10% of the maximum number of matching points between the photo in question and other photos, only matching points corresponding to the area within the bounding box being considered."

- The number of tie points can be reduced after the alignment process with Tie Points - Thin Point Cloud command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment will be kept unchanged.

**Point cloud generation based on imported camera data**

PhotoScan supports import of external and internal camera orientation parameters. Thus, if for the project precise camera data is available, it is possible to load them into PhotoScan along with the photos, to be used as initial information for 3D reconstruction job.

**To import external and internal camera parameters**

1. Select Import Cameras command from the Tools menu.

2. Select the format of the file to be imported.
3. Browse to the file and click Open button.

4. The data will be loaded into the software. Camera calibration data can be inspected in the Camera Calibration dialog, Adjusted tab, available from Tools menu. If the input file contains some reference data (camera position data in some coordinate system), the data will be shown on the Reference pane, View Estimated tab.

Camera data can be loaded in one of the following formats: PhotoScan *.xml, BINGO *.dat, Bundler *.out, VisionMap Detailed Report *.txt.

Once the data is loaded, PhotoScan will offer to build point cloud. This step involves feature points detection and matching procedures. As a result, a sparse point cloud - 3D representation of the tie-points data - will be generated. Build Point Cloud command is available from Tools - Tie Points menu. Parameters controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

### Building dense point cloud

PhotoScan allows to generate and visualize a dense point cloud model. Based on the estimated camera positions the program calculates depth information for each camera to be combined into a single dense point cloud. PhotoScan tends to produce extra dense point clouds, which are of almost the same density, if not denser, as LIDAR point clouds. A dense point cloud can be edited and classified within PhotoScan environment or exported to an external tool for further analysis.

**To build a dense point cloud**

1. Check the reconstruction volume bounding box. To adjust the bounding box use the Resize Region and Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions.

2. Select the Build Dense Cloud... command from the Workflow menu.

3. In the Build Dense Cloud dialog box select the desired reconstruction parameters. Click OK button when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

### Reconstruction parameters

**Quality**

Specifies the desired reconstruction quality. Higher quality settings can be used to obtain more detailed and accurate geometry, but require longer time for processing. Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The only difference is that in this case Ultra High quality setting means processing of original photos, while each following step implies preprocessing image size downscaling by factor of 4 (2 times by each side).

Additionally the following advanced parameters can be adjusted.

**Depth Filtering modes**

At the stage of dense point cloud generation reconstruction PhotoScan calculates depth maps for every image. Due to some factors, like poor texture of some elements of the scene, noisy or badly focused images, there can be some outliers among the points. To sort out the outliers PhotoScan has several built-in filtering algorithms that answer the challenges of different projects.
If the geometry of the scene to be reconstructed is complex with numerous small details on the foreground, then it is recommended to set Mild depth filtering mode, for important features not to be sorted out.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable to chose Aggressive depth filtering mode to sort out most of the outliers.

Moderate depth filtering mode brings results that are in between the Mild and Aggressive approaches. You can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Disabled. But this option is not recommended as the resulting dense cloud could be extremely noisy.

### Building mesh

To build a mesh

1. Check the reconstruction volume bounding box. To adjust the bounding box use the \(\text{Resize Region}\) and \(\text{Rotate Region}\) toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired positions. If the Height field reconstruction method is to be applied, it is important to control the position of the red side of the bounding box: it defines reconstruction plane. In this case make sure that the bounding box is correctly oriented.

2. Select the Build Mesh... command from the Workflow menu.

3. In the Build Mesh dialog box select the desired reconstruction parameters. Click OK button when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

### Reconstruction parameters

PhotoScan supports several reconstruction methods and settings, which help to produce optimal reconstructions for a given data set.

**Surface type**

Arbitrary surface type can be used for modeling of any kind of object. It should be selected for closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the object modeled, which comes at a cost of higher memory consumption.

Height field surface type is optimized for modeling of planar surfaces, such as terrains or bas-reliefs. It should be selected for aerial photography processing as it requires lower amount of memory and allows for larger data sets processing.

**Source data**

Specifies the source for the mesh generation procedure. Sparse cloud can be used for fast 3D model generation based solely on the sparse point cloud. Dense cloud setting will result in longer processing time but will generate high quality output based on the previously reconstructed dense point cloud.

**Polygon count**

Specifies the maximum number of polygons in the final mesh. Suggested values (High, Medium, Low) are calculated based on the number of points in the previously generated dense point cloud: the
General workflow

... ration is 1/5, 1/15, and 1/45 respectively. They present optimal number of polygons for a mesh of a corresponding level of detail. It is still possible for a user to indicate the target number of polygons in the final mesh according to his choice. It could be done through the Custom value of the Polygon count parameter. Please note that while too small number of polygons is likely to result in too rough mesh, too huge custom number (over 10 million polygons) is likely to cause model visualization problems in external software.

Additionally the following advanced parameters can be adjusted.

**Interpolation**

If interpolation mode is Disabled it leads to accurate reconstruction results since only areas corresponding to dense point cloud points are reconstructed. Manual hole filling is usually required at the post processing step.

With Enabled (default) interpolation mode PhotoScan will interpolate some surface areas within a circle of a certain radius around every dense cloud point. As a result some holes can be automatically covered. Yet some holes can still be present on the model and are to be filled at the post processing step. Enabled (default) setting is recommended for orthophoto generation.

In Extrapolated mode the program generates holeless model with extrapolated geometry. Large areas of extra geometry might be generated with this method, but they could be easily removed later using selection and cropping tools.

**Point classes**

Specifies the classes of the dense point cloud to be used for mesh generation. For example, select only "Ground Points" to produce a DTM as opposed to a DSM. Preliminary dense cloud classification should be performed for this option of mesh generation to be active.

**Note**

- PhotoScan tends to produce 3D models with excessive geometry resolution, so it is recommended to perform mesh decimation after geometry computation. More information on mesh decimation and other 3D model geometry editing tools is given in the Editing model geometry section.

**Building model texture**

**To generate 3D model texture**

1. Select Build Texture... command from the Workflow menu.

2. Select the desired texture generation parameters in the Build Texture dialog box. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

**Texture mapping modes**

The texture mapping mode determines how the object texture will be packed in the texture atlas. Proper texture mapping mode selection helps to obtain optimal texture packing and, consequently, better visual quality of the final model.
General workflow

**Generic**
The default mode is the Generic mapping mode; it allows to parametrize texture atlas for arbitrary geometry. No assumptions regarding the type of the scene to be processed are made; program tries to create as uniform texture as possible.

**Adaptive orthophoto**
In the Adaptive orthophoto mapping mode the object surface is split into the flat part and vertical regions. The flat part of the surface is textured using the orthographic projection, while vertical regions are textured separately to maintain accurate texture representation in such regions. When in the Adaptive orthophoto mapping mode, program tends to produce more compact texture representation for nearly planar scenes, while maintaining good texture quality for vertical surfaces, such as walls of the buildings.

**Orthophoto**
In the Orthophoto mapping mode the whole object surface is textured in the orthographic projection. The Orthophoto mapping mode produces even more compact texture representation than the Adaptive orthophoto mode at the expense of texture quality in vertical regions.

**Spherical**
Spherical mapping mode is appropriate only to a certain class of objects that have a ball-like form. It allows for continuous texture atlas being exported for this type of objects, so that it is much easier to edit it later. When generating texture in Spherical mapping mode it is crucial to set the Bounding box properly. The whole model should be within the Bounding box. The red side of the Bounding box should be under the model; it defines the axis of the spherical projection. The marks on the front side determine the 0 meridian.

**Single photo**
The Single photo mapping mode allows to generate texture from a single photo. The photo to be used for texturing can be selected from 'Texture from' list.

**Keep uv**
The Keep uv mapping mode generates texture atlas using current texture parametrization. It can be used to rebuild texture atlas using different resolution or to generate the atlas for the model parametrized in the external software.

## Texture generation parameters

The following parameters control various aspects of texture atlas generation:

**Texture from (Single photo mapping mode only)**
Specifies the photo to be used for texturing. Available only in the Single photo mapping mode.

**Blending mode (not used in Single photo mode)**
Selects the way how pixel values from different photos will be combined in the final texture.

- **Mosaic** - gives more quality for orthophoto and texture atlas than Average mode, since it does not mix image details of overlapping photos but uses most appropriate photo (i.e., the one where the pixel in question is located within the shortest distance from the image center). Mosaic texture blending mode is especially useful for orthophoto generation based on approximate geometric model.

- **Average** - uses the average value of all pixels from individual photos.

- **Max Intensity** - the photo which has maximum intensity of the corresponding pixel is selected.

- **Min Intensity** - the photo which has minimum intensity of the corresponding pixel is selected.
General workflow

**Texture size / count**

Specifies the size (width & height) of the texture atlas in pixels and determines the number of files for texture to be exported to. Exporting texture to several files allows to archive greater resolution of the final model texture, while export of high resolution texture to a single file can fail due to RAM limitations.

Additionally the following advanced parameters can be adjusted.

**Enable color correction**

The feature is useful for processing of data sets with extreme brightness variation. However, please note that color correction process takes up quite a long time, so it is recommended to enable the setting only for the data sets that proved to present results of poor quality.

**Note**

- HDR texture generation requires HDR photos on input.

To improve result texture quality it may be reasonable to exclude poorly focused images from processing at this step. PhotoScan suggests automatic image quality estimation feature. Images with quality value of less than 0.5 units are recommended to be disabled and thus excluded from texture generation procedure.

To disable a photo use ![Disable button](image) from the Photos pane toolbar.

PhotoScan estimates image quality as a relative sharpness of the photo with respect to other images in the data set. The value of the parameter is calculated based on the sharpness level of the most focused part of the picture.

**To estimate image quality**

1. Switch to the detailed view in the Photos pane using ![Details command](image) from the Change menu on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.
3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the context menu.
4. Once the analysis procedure is over, a figure indicating estimated image quality value will be displayed in the Quality column on the Photos pane.

**Saving intermediate results**

Certain stages of 3D model reconstruction can take a long time. The full chain of operations could easily last for 4-6 hours when building a model from hundreds of photos. It is not always possible to finish all the operations in one run. PhotoScan allows to save intermediate results in a project file.

PhotoScan project files may contain the following information:

- List of loaded photographs with reference paths to the image files.
- Photo alignment data such as information on camera positions, sparse point cloud model and set of refined camera calibration parameters for each calibration group.
- Masks applied to the photos in project.
General workflow

- Depth maps for cameras.
- Dense point cloud model with information on points classification.
- Reconstructed 3D polygonal model with any changes made by user. This includes mesh and texture if it was built.
- List of added markers as well as of scale-bars and information on their positions.
- Structure of the project, i.e. number of chunks in the project and their content.

You can save the project at the end of any processing stage and return to it later. To restart work simply load the corresponding file into PhotoScan. Project files can also serve as backup files or be used to save different versions of the same model.

Note that since PhotoScan tends to generate extra dense point clouds and highly detailed polygonal models, project saving procedure can take up quite a long time. You can decrease compression level to speed up the saving process. However, please note that it will result in a larger project file. Compression level setting can be found on the Advanced tab of the Preferences dialog available from Tools menu.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file to another location do not forget to move or copy photographs with all the folder structure involved as well. Otherwise, PhotoScan will fail to run any operation requiring source images, although the project file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store absolute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

PhotoScan supports export of processing results in various representations: sparse and dense point clouds, camera calibration and camera orientation data, mesh, etc. Orthophotos and digital elevation models (both DSM and DTM) can be generated according to the user requirements.

Point clouds and camera calibration data can be exported right after photo alignment is completed. All other export options are available after the 3D model is built.

If you are going to export the results (point cloud / mesh / DEM / orthophoto) for the model that is not referenced, please note that the resulting file will be oriented according to a default coordinate system (see axes in the bottom left corner of the Model view), i.e. the model can be shown differently from what you see in PhotoScan window. To align the model orientation with the default coordinate system use Rotate object button from the Toolbar.

In some cases editing model geometry in the external software may be required. PhotoScan supports model export for editing in external software and then allows to import it back, as it is described in the Editing model geometry section of the manual.

Main export commands are available from the File menu and the rest from the Export submenu of the Tools menu.

Point cloud export

To export sparse or dense point cloud

1. Select Export Points... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. In the Export Points dialog box select desired Type of point cloud - Sparse or Dense.

4. Specify the coordinate system and indicate export parameters applicable to the selected file type, including the dense cloud classes to be saved.

5. Click OK button to start export.

6. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Split in blocks option in the Export Points dialog can be useful for exporting large projects. It is available for referenced models only. You can indicate the size of the section in xy plane (in meters) for the point cloud to be divided into respective rectangular blocks. The total volume of the 3D scene is limited with the Bounding Box. The whole volume will be split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will not be saved.

In some cases it may be reasonable to edit point cloud before exporting it. To read about point cloud editing refer to the Editing point cloud section of the manual.

PhotoScan supports point cloud export in the following formats:

- Wavefront OBJ
- Stanford PLY
- XYZ text file format
- ASPRS LAS
- ASTM E57
- U3D
- potree
- PhotoScan OC3
- PDF

**Note**

- Saving color information of the point cloud is supported by the PLY, E57, LAS and TXT file formats.
- Saving point normals information is supported by the OBJ, PLY and TXT file formats.

**Tie points data export**

**To export matching points**

1. Select Export Matches... command from the Tools menu.

2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.

3. In the Export Matches dialog box set export parameters. Precision value sets the limit to the number of decimal digits in the tie points coordinates to be saved.
4. Click OK button to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

PhotoScan supports matching points data export in the following formats:

- **BINGO (*.dat)** - saves original intrinsic and extrinsic camera data along with matching points coordinates.
- **ORIMA (*.txt)**
- **PATB (*.ptb)**

Matching points exported from PhotoScan can be used as a basis for AT procedure to be performed in some external software. Later on estimated camera data can be imported back to PhotoScan (using Import Cameras command from the Tools menu) to proceed with 3D model reconstruction procedure.

### Camera calibration and orientation data export

To export camera calibration and camera orientation data select Export Cameras... command from the Tools menu.

To export / import only camera calibration data select Camera Calibration... command from the Tools menu.

PhotoScan supports camera data export in the following formats:

- PhotoScan structure file format (XML based)
- Bundler OUT file format
- CHAN file format
- Boujou TXT file format
- Omega Phi Kappa text file format
- PATB Exterior orientation
- BINGO Exterior orientation
- AeroSys Exterior orientation
- Inpho project file

**Note**

- Camera data export in Bundler and Boujou file formats will save sparse point cloud data in the same file.
- Camera data export in Bundler file format would not save distortion coefficients k3, k4.

### Panorama export

PhotoScan is capable of panorama stitching for images taken from the same camera position - camera station. To indicate for the software that loaded images have been taken from one camera station one
should move those photos to a camera group and assign Camera Station type to it. For information on camera group refer to Loading photos section.

**To export panorama**

1. Select Export - Export Panorama... command from the Tools menu.
2. Select camera group which panorama should be previewed for.
3. Choose panorama orientation in the file with the help of navigation buttons to the right of the preview window in the Export Panorama dialog.
4. Set exporting parameters: select camera groups which panorama should be exported for and indicate export file name mask.
5. Click OK button
6. Browse the destination folder and click Save button.

### 3D model export

**To export 3D model**

1. Select Export Model... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. In the Export Model dialog specify the coordinate system and indicate export parameters applicable to the selected file type.
4. Click OK button to start export.
5. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

#### Note

- If the model is exported in local coordinates, PhotoScan can write a KML file for the exported model to be correctly located on Google Earth.

If a model generated with PhotoScan is to be imported in a 3D editor program for inspection or further editing, it might be helpful to use Shift function while exporting the model. It allows to set the value to be subtracted from the respective coordinate value for every vertex in the mesh. Essentially, this means translation of the model coordinate system origin, which may be useful since some 3D editors, for example, truncate the coordinates values up to 8 or so digits, while in some projects they are decimals that make sense with respect to model positioning task. So it can be recommended to subtract a value equal to the whole part of a certain coordinate value (see Reference pane, Camera coordinates values) before exporting the model, thus providing for a reasonable scale for the model to be processed in a 3D editor program.

PhotoScan supports model export in the following formats:

- Wavefront OBJ
- 3DS file format
- VRML
Orthophoto export

Orthophoto export is normally used for generation of high resolution imagery based on the source photos and reconstructed geometry. The most common application is aerial photographic survey processing, but it may be also useful when a detailed view of the object is required. Orthophoto is often accompanied by the digital elevation model (see the next section).

In order to export orthophoto in the correct orientation it is necessary to set the coordinate system for the model first. Since PhotoScan uses original images to build an orthophoto, there is no need to build a texture atlas.

To export Orthophoto

1. Select Export Orthophoto... command from the File menu.
2. In the Export Orthophoto dialog box specify coordinate system to georeference the Orthophoto.
3. Select Blending mode to be used for texture mapping (for details please see the Building model texture section).
4. Check Write KML file and / or Write World file options to create files needed to georeference the orthophoto in the Google Earth and / or a GIS.
5. Click Export button to start export.
6. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
7. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

Note

- Write KML file option is available only if the model is georeferenced in WGS84 coordinate system due to the fact that Google Earth supports only this coordinate system.
- World file specifies coordinates of the four angle vertices of the exporting orthophoto. This information is already included in GeoTIFF file, however, you could duplicate it for some
reason. If you need to export orthophoto in JPEG or PNG file formats and would like to have georeferencing data this informations could be useful.

PhotoScan allows to export Orthophoto in different planar projections as well. To export Orthophoto in a planar projection choose Planar Projection Type in Export Orthophoto dialog. You can select projection plane and orientation of the Orthophoto. PhotoScan provides an option to project the model to a plane determined by a set of markers (if there are no 3 markers in a desired projection plane it can be specified with 2 vectors, i.e. 4 markers).

If the export file of a fixed size is needed, it is possible to set the length of the longer side of the export file in Max. dimension (pix) parameter. The length should be indicated in pixels.

Split in blocks option in the Export Orthophoto dialog can be useful for exporting large projects. You can indicate the size of the blocks (in pix) for the orthophoto to be divided into. The whole area will be split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will not be saved.

To export a particular part of the project use Region section of the Export Orthophoto dialog. Indicate coordinates of the bottom left and top right corners of the region to be exported in the left and right columns of the textboxes respectively. Estimate button allows you to see the coordinates of the bottom left and top right corners of the whole area.

Default value for pixel size in Export Orthophoto dialog refers to ground sampling resolution, thus, it is useless to set a smaller value: the number of pixels would increase, but the effective resolution would not. If you have chosen to export orthophoto with a certain pixel size (not using Max. dimension (pix) option), it is recommended to check estimated Total size (pix) of the resulting file to be sure that it is not too large to be correctly saved to the targeted file format.

Note

• Colour correction feature is useful for processing of data sets with extreme brightness variation. However, please note that color correction process takes up quite a long time, so it is recommended to enable the setting only for the data sets that proved to present results of poor quality before.

The following formats are supported for orthophoto export:

• JPEG
• PNG
• TIFF
• GeoTIFF
• Multiresolution Google Earth KML mosaic.

Note

• Multispectral orthophoto export is supported in GeoTIFF format only. When exporting in other formats, only master channel will be saved.

Note

• While exporting (Geo)TIFF file LZW compression is applied. If you need an original file or, on the contrary, more compressed file, you should use external software to do the transformation.
However, one should be careful with the selected tool not to lose georeferencing information (in case of GeoTIFF file) during compression/decompression procedure.

**DEM (DSM / DTM) export**

Digital elevation models (DEMs) represent the model surface as a regular grid of height values, and are often used for aerial photographic survey data. Digital elevation model can be combined with orthophoto to produce a 3D model of the area.

PhotoScan allows to export both a digital surface model (DSM) and a digital terrain model (DTM). A DSM can be exported if you have previously built mesh based on all point classes (default DEM export). A DTM can be exported for a mesh based on ground points only.

**Note**

- DEM export is available only for referenced models. So make sure that you have set a coordinate system for your model before going to DEM export operation.

**To export DSM**

1. Select Export DEM... command from the File menu.
2. In the Export DEM dialog box specify coordinate system to georeference the DEM.
3. Check Write KML file and / or Write World file options to create files needed to georeference the DEM in the Google Earth and / or a GIS.
4. Click Export button to start export.
5. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
6. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

**To export DTM**

1. Reference dense point cloud model. For guidance on Setting coordinate system please go to Setting coordinate system.
2. Classify Ground Points using the command available from the Dense Cloud submenu of the Tools menu.
3. Build mesh based on Ground Points class only. See Advanced settings in the Build Mesh dialog.
4. Select Export DEM... command from the File menu.
5. In the Export DEM dialog box specify coordinate system to georeference the DEM.
6. Check Write KML file and / or Write World file options to create files needed to georeference the DEM in the Google Earth and / or a GIS.
7. Click Export button to start export.
8. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
9. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.
General workflow

**Note**

- Write KML file option is available only if the model is georeferenced in WGS84 coordinate system due to the fact that Google Earth supports only this coordinate system.

- World file specifies coordinates of the four angle vertices of the exporting DEM. This information is already included in GeoTIFF elevation data as well as in other supported file formats for DEM export, however, you could duplicate it for some reason.

PhotoScan allows to export DEM in different planar projections in the same way as it is done for orthophoto export. (See Orthophoto export section.)

If the export file of a fixed size is needed, it is possible to to set the length of the longer side of the export file in Max. dimension (pix) parameter. The length should be indicated in pixels.

Unlike orthophoto export, it is sensible to set smaller pixel size compared to the default value in DEM export dialog; the effective resolution will increase. If you have chosen to export DEM with a certain pixel size (not using Max. dimension (pix) option), it is recommended to check estimated Total size (pix) of the resulting file to be sure that it is not too large to be correctly saved to the targeted file format.

**Note**

- Export DEM dialog allows to crop invalid DEM (i.e., DEM parts corresponding to the areas visible on less than 2 source photos). The values for the points of the grid that couldn't be calculated will be set to the value indicated in no-data value box.

- Split in blocks option in the Export DEM dialog can be useful for exporting large projects or meeting special DEM requirements. (See Orthophoto export section for details.)

- To export a particular part of the project use Region section of the Export DEM dialog. (See Orthophoto export section for details.)

The following formats are supported for DEM export:

- GeoTIFF elevation data
- Arc/Info ASCII Grid (ASC)
- Band interleaved file format (BIL)
- XYZ file format
- Sputnik KMZ

**Extra products to export**

In addition to main targeted products PhotoScan allows to export several other processing results, like

- Undistort photos, i.e., photos free of lens distortions (Undistort Photos... command available from Export submenu of the Tools menu).

- Depth map for any image (Export Depth... command available from photo context menu).

- Model in tiles, i.e., mesh split in blocks of a certain size (Export Tiles... command available from Export Model submenu of the File menu).
PhotoScan supports direct uploading of the models to the Sketchfab and Verold resources. To publish your model online use Upload Model... command from the File menu.

**Processing report generation**

PhotoScan supports automatic processing report generation in PDF format, which contains the basic parameters of the project, processing results and accuracy estimates.

**To generate processing report**

1. Select Generate Report... command from the File menu.
2. Browse the destination folder, choose the file type, and print in the file name. Click Save button.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

PhotoScan processing report represents the following data:

- Orthophoto and digital elevation model sketch.
- Camera parameters and survey scheme.
- Image overlap statistics.
- Camera positioning error estimates.
- Ground control point error estimates.

**Note**

- Complete processing report can be exported only after geometry is reconstructed and georeferenced. However, Report with information on the alignment procedure results is available for export right after the corresponding processing step.

- For comments on types of errors indicated in the processing report please refer to Optimization of camera alignment.
Chapter 4. Referencing and measurements

Camera calibration

Calibration groups

While carrying out photo alignment PhotoScan estimates both internal and external camera orientation parameters, including nonlinear radial distortions. For the estimation to be successful it is crucial to apply the estimation procedure separately to photos taken with different cameras. Once photos have been loaded in the program, PhotoScan automatically divides them into calibration groups according to the image resolution and/or EXIF metadata like camera type and focal length. All the actions described below could and should be applied (or not applied) to each calibration group individually.

Calibration groups can be rearranged manually.

To create a new calibration group

1. Select Camera Calibration... command from the Tools menu.
2. In the Camera Calibration dialog box, select photos to be arranged in a new group.
3. In the right-click context menu choose Create Group command.
4. A new group will be created and depicted on the left-hand part of the Camera Calibration dialog box.

To move photos from one group to another

1. Select Camera Calibration... command from the Tools menu.
2. In the Camera Calibration dialog box choose the source group on the left-hand part of the dialog.
3. Select photos to be moved and drag them to the target group on the left-hand part of the Camera Calibration dialog box.

To place each photo into a separate group you can use Split Groups command available at the right button click on a calibration group name in the left-hand part of the Camera Calibration dialog

Camera types

PhotoScan supports three major types of camera: frame camera, spherical camera, and fisheye camera. Camera type can be set in Camera Calibration dialog box available from Tools menu.

Frame camera. If the source data within a calibration group was shot with a frame camera, for successful estimation of camera orientation parameters the information on approximate focal length (pix) is required. Obviously, to calculate focal length value in pixel it is enough to know focal length in mm along with the sensor pixel size in mm. Normally this data is extracted automatically from the EXIF metadata.

Fisheye camera. If extra wide lenses were used to get the source data, standard PhotoScan camera model will not allow to estimate camera parameters successfully. Fish Eye camera type setting will initialize implementation of a different camera model to fit ultra-wide lens distortions.
Spherical camera. In case the source data within a calibration group was shot with a spherical camera, camera type setting will be enough for the program to calculate camera orientation parameters. No additional information is required except the image in equirectangular representation.

In case source images lack EXIF data or the EXIF data is insufficient to calculate focal length in pixels, PhotoScan will assume that focal length equals to 50 mm (35 mm film equivalent). However, if the initial guess values differ significantly from the actual focal length, it is likely to lead to failure of the alignment process. So, if photos do not contain EXIF metadata, it is preferable to specify focal length (mm) and sensor pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools menu. Generally, this data is indicated in camera specification or can be received from some online source. To indicate to the program that camera orientation parameters should be estimated based on the focal length and pixel size information, it is necessary to set the Type parameter on the Initial tab to Auto value.

**Camera calibration parameters**

Once you have tried to run the estimation procedure and got poor results, you can improve them thanks to the additional data on calibration parameters.

**To specify camera calibration parameters**

1. Select Camera Calibration... command from the Tools menu.
2. Select calibration group, which needs reestimation of camera orientation parameters on the left side of the Camera Calibration dialog box.
3. In the Camera Calibration dialog box, select **Initial** tab.
4. Modify the calibration parameters displayed in the corresponding edit boxes.
5. Set the Type to the Precalibrated value.
6. Repeat to every calibration group where applicable.
7. Click OK button to set the calibration.

**Note**

- Alternatively, initial calibration data can be imported from file using Load button on the Initial tab of the Camera Calibration dialog box. In addition to PhotoScan calibration file format it is possible to import data from Australis, PhotoModeler, 3DM CalibCam, CalCam.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera Calibration dialog box.

If very precise calibration data is available, to protect it from recalculation one should check Fix calibration box. In this case initial calibration data will not be changed during Align Photos process.

Adjusted camera calibration data can be saved to file using Save button on the Adjusted tab of the Camera Calibration dialog box.

**Calibration parameters list**

\[ f_x, f_y \]

Focal length in x- and y-dimensions measured in pixels.
Referencing and measurements

**cx, cy**
Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane.

**skew**
Skew transformation coefficient.

**k1, k2, k3, k4**
Radial distortion coefficients.

**p1, p2**
Tangential distortion coefficients.

### Setting coordinate system

Many applications require data with a defined coordinate system. Setting the coordinate system also provides a correct scaling of the model allowing for surface area and volume measurements and makes model loading in geoviewers and geoinformatics software much easier. Some functionality like digital elevation model export is available only after the coordinate system is defined.

PhotoScan supports setting a coordinate system based on either ground control point (marker) coordinates or camera coordinates. In both cases the coordinates are specified in the Reference pane and can be either loaded from the external file or typed in manually.

Setting coordinate system based on recorded camera positions is often used in aerial photography processing. However it may be also useful for processing photos captured with GPS enabled cameras. Placing markers is not required if recorded camera coordinates are used to initialize the coordinate system.

In the case when ground control points are used to set up the coordinate system the markers should be placed in the corresponding locations of the scene.

Using camera positioning data for georeferencing the model is faster since manual marker placement is not required. On the other hand, ground control point coordinates are usually more accurate than telemetry data, allowing for more precise georeferencing.

### Placing markers

PhotoScan uses markers to specify locations within the scene. Markers are used for setting up a coordinate system, photo alignment optimization, measuring distances and volumes within the scene as well as for marker based chunk alignment. Marker positions are defined by their projections on the source photos. The more photos are used to specify marker position the higher is accuracy of marker placement. To define marker location within a scene it should be placed on at least 2 photos.

**Note**

- Marker placement is not required for setting the coordinate system based on recorded camera coordinates. This section can be safely skipped if the coordinate system is to be defined based on recorded camera locations.

PhotoScan supports two approaches to marker placement: manual marker placement and guided marker placement. Manual approach implies that the marker projections should be indicated manually on each photo where the marker is visible. Manual marker placement does not require 3D model and can be performed even before photo alignment.
In the guided approach marker projection is specified for a single photo only. PhotoScan automatically projects the corresponding ray onto the model surface and calculates marker projections on the rest of the photos where marker is visible. Marker projections defined automatically on individual photos can be further refined manually. Reconstructed 3D model surface is required for the guided approach.

Guided marker placement usually speeds up the procedure of marker placement significantly and also reduces the chance of incorrect marker placement. It is recommended in most cases unless there are any specific reasons preventing this operation.

**To place a marker using guided approach**

1. Open a photo where the marker is visible by double clicking on its name.

2. Switch to the marker editing mode using Edit Markers toolbar button.

3. Right click on the photo at the point corresponding to the marker location.

4. Select Create Marker command from the context menu. New marker will be created and its projections on the other photos will be automatically defined.

**Note**

- If the 3D model is not available or the ray at the selected point does not intersect with the model surface, the marker projection will be defined on the current photo only.

- Guided marker placement can be performed in the same way from the 3D view by right clicking on the corresponding point on the model surface and using Create Marker command from the context menu. While the accuracy of marker placement in the 3D view is usually much lower, it may be still useful for quickly locating the photos observing the specified location on the model.

   To view the corresponding photos use Filter by Markers command again from the 3D view context menu. If the command is inactive, please make sure that the marker in question is selected on the Reference pane.

**To place a marker using manual approach**

1. Create marker instance using Add marker button on the Workspace pane or by Add Marker command from the Chunk context menu (available by right clicking on the chunk title on the Workspace pane).

2. Open the photo where the marker projection needs to be added by double clicking on the photos name.

3. Switch to the marker editing mode using Edit Markers toolbar button.

4. Right click at the point on the photo where the marker projection needs to be placed. From the context menu open Place Marker submenu and select the marker instance previously created. The marker projection will be added to the current photo.

5. Repeat the previous step to place marker projections on other photos if needed.

To save up time on manual marker placement procedure PhotoScan offers guiding lines feature. When a marker is placed on an aligned photo, PhotoScan highlights lines, which the marker is expected to lie on, on the rest of the aligned photos.
Note

• If a marker has been placed on at least two aligned images PhotoScan will find the marker projections on the rest of the photos. The calculated marker positions will be indicated with icon on the corresponding aligned photos in Photo View mode.

Automatically defined marker locations can be later refined manually by dragging their projections on the corresponding photos.

To refine marker location

1. Open the photo where the marker is visible by double clicking on the photo's name. Automatically placed marker will be indicated with icon.

2. Switch to the marker editing mode using Edit Markers toolbar button.

3. Move the marker projection to the desired location by dragging it using left mouse button. Once the marker location is refined by user, the marker icon will change to

Note

• To list photos where the marker locations are defined, select the corresponding marker on the Workspace pane. The photos where the marker is placed will be marked with a icon on the Photos pane. To filter photos by marker use Filter by Markers command from the 3D view context menu.

In those cases when there are hesitations about the features depicted on the photo, comparative inspection of two photos can prove to be useful. To open two photos in PhotoScan window simultaneously Move to Other Tab Group command is available from photo tab header context menu.

To open two photos simultaneously

1. In the Photos pane double click on one photo to be opened. The photo will be opened in a new tab of the main program window.

2. Right click on the tab header and choose Move to Other Tab Group command from the context menu. The main program window will be divided into two parts and the photo will be moved to the second part.

3. The next photo you will choose to be opened with a double click will be visualized in the active tab group.

PhotoScan automatically assigns default labels for each newly created marker. These labels can be changed using the Rename... command from the marker context menu in the Workspace / Reference pane.

Assigning reference coordinates

To reference the model the real world coordinates of at least 3 points of the scene should be specified. Depending on the requirements, the model can be referenced using marker coordinates, camera coordinates, or both. Real world coordinates used for referencing the model along with the type of coordinate system used are specified using the Reference pane.
Referencing and measurements

The model can be located in either local Euclidean coordinates or in georeferenced coordinates. For model georeferencing a wide range of various geographic and projected coordinate systems are supported, including widely used WGS84 coordinate system. Besides, almost all coordinate systems from the EPSG registry are supported as well.

Reference coordinates can be specified in one of the following ways:

- Loaded from a separate text file (using character separated values format).
- Entered manually in the Reference pane.
- Loaded from GPS EXIF tags (if present).

**To load reference coordinates from a text file**

1. Click the Import toolbar button on the Reference pane. (To open Reference pane use Reference command from the View menu.) Browse to the file containing recorded reference coordinates and click Open button.

2. In the Import CSV dialog set the coordinate system if the data presents geographical coordinates.

3. Select the delimiter and indicate the number of the data column for each coordinate. Indicate columns for the orientation data if present.

4. Click OK button. The reference coordinates data will be loaded onto the Reference pane.

**Note**

- In the data file columns and rows are numbered starting from 0.
- If reference coordinates of a marker / camera position for a photo are not specified in the loading file the current value will be kept for them.
- An example of a coordinates data file in the CSV format is given in the next section.

**To assign reference coordinates manually**

1. Switch to the View Source mode using View Source button from the Reference pane toolbar. (To open Reference pane use Reference command from the View menu.)

2. On the Reference pane double click on x/y/z cells to assign values to corresponding coordinates.

3. Repeat for every marker / camera position needed to be specified.

4. To remove unnecessary reference coordinates select corresponding items from the list and press Del key.

5. Click Update toolbar button to apply changes and set coordinates.

**To load reference coordinates from GPS EXIF tags**

- Click Import EXIF button on the Reference pane. (To open Reference pane use Reference command from the View menu.) The reference coordinates data will be loaded into the Reference pane.
After reference coordinates have been assigned, PhotoScan automatically estimates coordinates in a local Euclidean system and calculates the referencing errors. To see the results, switch to the View Estimated or View Errors modes respectively using the View Estimated and View Errors toolbar buttons. The largest error will be highlighted.

To set a georeferenced coordinate system

1. Assign reference coordinates using one of the options described above.
2. Click the Settings button on the Reference pane toolbar.
3. In the Reference Settings dialog box, select the Coordinate System used to compile reference coordinates data if it has not been set at the previous step.
4. Specify the assumed measurement accuracy.
5. Indicate relative camera to GPS system coordinates if present in the Camera Correction section of the Reference Settings dialog box.
6. Click OK button to initialize the coordinate system and estimate geographic coordinates.

Rotation angles in PhotoScan are defined around the following axes: yaw axis runs from top to bottom, pitch axis runs from left to right wing of the drone, roll axis runs from tail to nose of the drone. Zero values of the rotation angle triple define the following camera position aboard: camera looks down to the ground, frames are taken in landscape orientation, and horizontal axis of the frame is perpendicular to the central (tail-nose) axis of the drone. If the camera is fixed in a different position, respective yaw, pitch, roll values should be input in the camera correction section of the Settings dialog. The senses of the angles are defined according to the right-hand rule.

Note

- Step 5 can be safely skipped if you are using standard GPS system (not that of superhigh precision).

In Select Coordinate System dialog, it is possible to ease searching for the required georeferencing system using the Filter option. Enter respective EPSG code (e.g., EPSG::4302) to filter the systems.

To view the estimated geographic coordinates and reference errors, switch between the View Estimated and View Errors modes respectively using the View Estimated and View Errors toolbar buttons. The largest error will be highlighted. A click on the column name on the Reference pane sorts the markers and photos by the data in the column. At this point, you can review the errors and decide whether additional refinement of marker locations is required (in case of marker-based referencing), or if certain reference points should be excluded.

To save the errors and / or estimated coordinates, use the Export toolbar button on the Reference pane.

To reset a chunk georeferencing use the Reset Transform command from the chunk context menu on the Workspace pane. [R] indicator of a chunk being georeferenced will be removed from the chunk name.

Note

- Unchecked reference points on the Reference pane are not used for georeferencing. Use context menu to check / uncheck selected items.
• After adjusting marker locations on the photos, the coordinate system will not be updated automatically. It should be updated manually using Update toolbar button on the Reference pane.

• PhotoScan allows to convert the estimated geographic coordinates into a different coordinate system. To calculate the coordinates of the camera positions and / or markers in a different coordinate system use Convert toolbar button on the Reference pane.

Example of a reference coordinates file in CSV format (*.txt)

The reference coordinates can be loaded onto the Reference pane using character separated text file format. Each reference point is specified in this file on a separate line. Sample reference coordinates file is provided below:

```
# <label> <x> <y> <z>
IMG_0159.JPG 40.165011 48.103654 433.549477
IMG_0160.JPG 40.165551 48.103654 434.724281
IMG_0161.JPG 40.166096 48.103640 435.630558
```

Individual entries on each line should be separated with a tab (space, semicolon, comma, etc) character. All lines starting with # character are treated as comments.

Records from the coordinate file are matched to the corresponding photos or markers basing on the label field. Camera coordinates labels should match the file name of the corresponding photo including extension. Marker coordinates labels should match the labels of the corresponding markers in the project file. All labels are case insensitive.

Note

• Character separated reference coordinates format does not include specification of the type of coordinate system used. The kind of coordinate system used should be selected separately.

• PhotoScan requires z value to indicate height above the ellipsoid.

Optimization of camera alignment

PhotoScan estimates internal and external camera orientation parameters during photo alignment. This estimation is performed using image data alone, and there may be some errors in the final estimates. The accuracy of the final estimates depends on many factors, like overlap between the neighboring photos, as well as on the shape of the object surface. These errors can lead to non-linear deformations of the final model.

During georeferencing the model is linearly transformed using 7 parameter similarity transformation (3 parameters for translation, 3 for rotation and 1 for scaling). Such transformation can compensate only a linear model misalignment. The non-linear component can not be removed with this approach. This is usually the main reason for georeferencing errors.
Possible non-linear deformations of the model can be removed by optimizing the estimated point cloud and camera parameters based on the known reference coordinates. During this optimization PhotoScan adjusts estimated point coordinates and camera parameters minimizing the sum of reprojection error and reference coordinate misalignment error.

To achieve greater optimizing results it may be useful to edit sparse point cloud deleting obviously mislocated points beforehand. To read about point cloud editing refer to the Editing point cloud section of the manual.

Georeferencing accuracy can be improved significantly after optimization. It is recommended to perform optimization if the final model is to be used for any kind of measurements.

**To optimize camera alignment**

1. Set the marker and / or camera coordinates to be used for optimization (if not done yet).

2. Click Settings toolbar button on the Reference pane and set the coordinate system (if not done yet).

3. In the Reference pane Settings dialog box specify the assumed accuracy of ground control measurements, as well as the assumed accuracy of marker projections on the source photos.

4. Indicate relative camera to GPS device coordinates if present in Camera Correction section of the Reference pane Settings dialog box.

5. Click OK button.

6. Click Optimize toolbar button. In Optimize Camera Alignment dialog box check additional camera parameters to be optimized if needed. Click OK button to start optimization.

7. After the optimization is complete, the georeferencing errors will be updated.

**Note**

- Step 4 can be safely skipped if you are using standard GPS (not that of superhigh precision).

- The model data (if any) is cleared by the optimization procedure. You will have to rebuild the model geometry after optimization.

Generally it is reasonable to run optimization procedure based on markers data only. It is due to the fact that GCPs coordinates are measured with significantly higher accuracy compared to GPS data that indicates camera positions. Thus, markers data are sure to give more precise optimization results. Moreover, rather often GCP and camera coordinates are measured in different coordinate systems, that also prevents from using both cameras and markers data in optimization simultaneously.

In case optimization results does not seem to be satisfactory, you can try recalculating with lower values of parameters, i.e. assuming ground control measurements to be more accurate.

**Scale bar based optimization**

Scale bar is program representation of any known distance within the scene. It can be a standard ruler or a specially prepared bar of a known length. Scale bar is a handy tool to add supportive reference data to your project. They can prove to be useful when there is no way to locate ground control points all over the scene. Scale bars allow to save field work time, since it is significantly easier to place several scale bars with precisely known length, then to measure coordinates of a few markers using special equipment. In addition, PhotoScan allows to place scale bar instances between cameras, thus making it possible to...
avoid not only marker but ruler placement within the scene as well. Surely, scale bar based information will not be enough to set a coordinate system, however, the information can be successfully used while optimizing the results of photo alignment. It will also be enough to perform measurements in PhotoScan software. See Performing measurements.

To add a scale bar

1. Place markers at the start and end points of the bar. For information on marker placement please refer to the Setting coordinate system section of the manual.
2. Select both markers on the Reference pane using Ctrl button.
3. Select Create Scale Bar command form the Model view context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.
4. Switch to the View Source mode using the Reference pane toolbar button.
5. Double click on the Distance (m) box next to the newly created scale bar name and enter the known length of the bar in meters.

To add a scale bar between cameras

1. Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the cameras can be selected in the Model view window using selecting tools from the Toolbar.
2. Select Create Scale Bar command form the context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.
3. Switch to the View Source mode using the Reference pane toolbar button.
4. Double click on the Distance (m) box next to the newly created scale bar name and enter the known length of the bar in meters.

To run scale bar based optimization

1. On the Reference pane check all scale bars to be used in optimization procedure.
2. Click Settings toolbar button on the Reference pane. In the Reference pane Settings dialog box specify the assumed accuracy of scale bars measurements.
3. Click OK button.
4. Click Optimize toolbar button. In Optimize Camera Alignment dialog box check additional camera parameters to be optimized if needed. Click OK button to start optimization.

After the optimization is complete, cameras and markers estimated coordinates will be updated as well as all the georeferencing errors. To analyze optimization results switch to the View Estimated mode using the Reference pane toolbar button. In scale bar section of the Reference pane estimated scale bar distance will be displayed.

To delete a scale bar

1. Select the scale bar to be deleted on the Reference pane.
2. Right-click on it and chose Remove Scale Bars command from the context menu.
3. Click OK for the selected scale bar to be deleted.

**What does the errors in the Reference pane mean?**

**Cameras section**
1. Error (m) - distance between the input (source) and estimated positions of the camera.
2. Error (deg) - root mean square error calculated over all three orientation angles.
3. Error (pix) - root mean square reprojection error calculated over all feature points detected on the photo.

**Markers section**
1. Error (m) - distance between the input (source) and estimated positions of the marker.
2. Error (pix) - root mean square reprojection error for the marker calculated over all photos where marker is visible.

**Scale Bars section**
- Error (m) - difference between the input (source) scale bar length and the measured distance between two cameras or markers representing start and end points of the scale bar.

If the total reprojection error for some marker seems to be too large, it is recommended to inspect reprojection errors for the marker on individual photos. The information is available with Show Info command from the marker context menu on the Reference pane.

**Working with coded and non-coded targets**

**Overview**
Coded and non-coded targets are specially prepared, yet quite simple, real world markers that can add up to successful 3D model reconstruction of a scene. The difference between coded and non-coded targets is that while a non-coded target looks like an ordinary full circle or a figure (circle / rectangular) with 4 segments, the coded target has a ring parted in black and white segments around the central full circle.

**Coded targets advantages and limitations**
Coded targets (CTs) can be used as markers to define local coordinate system and scale of the model or as true matches to improve photo alignment procedure. PhotoScan functionality includes automatic detection and matching of CTs on source photos, which allows to benefit from marker implementation in the project while saving time on manual marker placement. Moreover, automatic CTs detection and marker placement is more precise than manual marker placement.

PhotoScan supports three types of circle CTs: 12 bit, 16 bit and 20 bit. While 12 bit pattern is considered to be decoded more precisely, 16 bit and 20 bit patterns allow for a greater number of CTs to be used within the same project.

To be detected successfully CTs must take up a significant number of pixels on the original photos. This leads to a natural limitation of CTs implementation: while they generally prove to be useful in close-range
imagery projects, aerial photography projects will demand too huge CTs to be placed on the ground, for the CTs to be detected correctly.

**Coded targets in workflow**

Sets of all patterns of CTs supported by PhotoScan can be generated by the program itself.

**To create a printable PDF with coded targets**

1. Select Print Markers... command from the Tools menu.
2. Specify the CTs type and desired print parameters in Print Markers dialog.
3. Click OK.

Once generated, the pattern set can be printed and the CTs can be placed over the scene to be shot and reconstructed.

When the images with CTs seen on them are uploaded to the program, PhotoScan can detect and match the CTs automatically.

**To detect coded targets on source images**

1. Select Detect Markers... command from the Tools menu.
2. Specify parameters of detector in Detect Markers dialog according to the CTs type.
3. Click OK.

PhotoScan will detect and match CTs and add corresponding markers to the Reference pane.

CTs generated with PhotoScan software contain even number of sectors. However, previous versions of PhotoScan software had no restriction of the kind. Thus, if the project to be processed contains CTs from previous versions of PhotoScan software, it is required to disable parity check in order to make the detector work.

**Non-coded targets implementation**

Non-coded targets can also be automatically detected by PhotoScan (see Detect Markers dialog). However, for non-coded targets to be matched automatically, it is necessary to run align photos procedure first.

Non-coded targets are more appropriate for aerial surveying projects due to the simplicity of the pattern to be printed on a large scale. But, looking alike, they do not allow for automatic identification, so manual assignment of an identifier is required if some referencing coordinates are to be imported from a file correctly.

**Performing measurements**

PhotoScan supports measuring of distances between control points, as well as of surface area and volume of the reconstructed 3D model.

**Distance measurement**

PhotoScan enables measurements of direct distances between the points of the reconstructed 3D scene. The points used for distance measurement must be defined by placing markers in the corresponding locations.
Referencing and measurements

Model coordinate system must be also initialized before the distance measurements can be performed. Alternatively, the model can be scaled based on known distance (scale bar) information to become suitable for measurements.

For instructions on placing markers, refining their positions and setting coordinate system please refer to the Setting coordinate system section of the manual. Scale bar concept is described in the Optimization of camera alignment section.

To measure distance

1. Place the markers in the scene at the locations to be used for distance measurement. For information on marker placement please refer to the Setting coordinate system section of the manual.

2. Select both markers to be used for distance measurements on the Reference pane using Ctrl button.

3. Select Create Scale Bar command from the 3D view context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.

4. Switch to the estimated values mode using View Estimated button from the Reference pane toolbar.

5. The estimated distance for the newly created scale bar equals to the distance that should have been measured.

To measure distance between cameras

1. Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the cameras can be selected in the Model view window using selecting tools from the Toolbar.

2. Select Create Scale Bar command from the context menu. The scale bar will be created and an instant added to the Scale Bar list on the Reference pane.

3. Switch to the estimated values mode using View Estimated button from the Reference pane toolbar.

4. The estimated distance for the newly created scale bar equals to the distance that should have been measured.

Note

- Please note that the scale bar used for distance measurements must be unchecked on the Reference pane.

Note

- The distance values measured by PhotoScan are displayed in meters.

Surface area and volume measurement

Surface area or volume measurements of the reconstructed 3D model can be performed only after the scale or coordinate system of the scene is defined. For instructions on setting coordinate system please refer to the Setting coordinate system section of the manual.
To measure surface area and volume

1. Select Measure Area and Volume... command from the Tools menu.

2. The whole model surface area and volume will be displayed in the Measure Area and Volume dialog box. Surface area is measured in square meters, while mesh volume is measured in cubic meters.

Volume measurement can be performed only for the models with closed geometry. If there are any holes in the model surface PhotoScan will report zero volume. Existing holes in the mesh surface can be filled in before performing volume measurements using Close Holes... command from the Tools menu.
Chapter 5. Editing

Using masks

Overview

Masks are used in PhotoScan to specify the areas on the photos which can otherwise be confusing to the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of processing:

- Alignment of the photos
- Building dense point cloud
- Building 3D model texture
- Exporting Orthophoto

Alignment of the photos

Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts of the photos are not taken into account while estimating camera positions. This is important in the setups, where the object of interest is not static with respect to the scene, like when using a turn table to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In this case a small number of useful matches can be filtered out mistakenly as a noise among a much greater number of matches between background objects.

Building dense point cloud

While building dense point cloud, masked areas are not used in the depth maps computation process. Masking can be used to reduce the resulting dense cloud complexity, by eliminating the areas on the photos that are not of interest.

Masked areas are always excluded from processing during dense point cloud and texture generation stages.

Let's take for instance a set of photos of some object. Along with an object itself on each photo some background areas are present. These areas may be useful for more precise camera positioning, so it is better to use them while aligning the photos. However, impact of these areas at the building dense point cloud is exactly opposite: the resulting model will contain object of interest and its background. Background geometry will "consume" some part of mesh polygons that could be otherwise used for modeling the main object.
Setting the masks for such background areas allows to avoid this problem and increases the precision and quality of geometry reconstruction.

**Building texture atlas**
During texture atlas generation, masked areas on the photos are not used for texturing. Masking areas on the photos that are occluded by outliers or obstacles helps to prevent the "ghosting" effect on the resulting texture atlas.

**Loading masks**
Masks can be loaded from external sources, as well as generated automatically from background images if such data is available. PhotoScan supports loading masks from the following sources:

- From alpha channel of the source photos.
- From separate images.
- Generated from background photos based on background differencing technique.
- Based on reconstructed 3D model.

**To import masks**
1. Select Import Masks... command from the Tools menu.
2. In the Import Mask dialog select suitable parameters. Click OK button when done.
3. When generating masks from separate or background images, the folder selection dialog will appear. Browse to the folder containing corresponding images and select it.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

The following parameters can be specified during mask import:

**Import masks for**
- Specifies whether masks should be imported for the currently opened photo, active chunk or entire Workspace.
  - Current photo - load mask for the currently opened photo (if any).
  - Active chunk - load masks for active chunk.
  - Entire workspace - load masks for all chunks in the project.

**Method**
- Specifies the source of the mask data.
  - From Alpha - load masks from alpha channel of the source photos.
  - From File - load masks from separate images.
  - From Background - generate masks from background photos.
  - From Model - generate masks based on reconstructed model.

**Mask file names (not used in From alpha mode)**
- Specifies the file name template used to generate mask file names. This template can contain special tokens, that will be substituted by corresponding data for each photo being processed. The following tokens are supported:
Editing

{filename} - file name of the source photo without extension.

{fileext} - extension of the source photo.

{camera} - camera label.

{frame} - frame number.

{filenum} - sequential number of the mask being imported.

For example, {filename}_mask.png template can be used if masks are available in PNG format and have a _mask suffix.

**Tolerance (From Background method only)**
Specifies the tolerance threshold used for background differencing. Tolerance value should be set according to the color separation between foreground and background pixels. For larger separation higher tolerance values can be used.

**Editing masks**

Modification of the current mask is performed by adding or subtracting selections. A selection is created with one of the supported selection tools and is not incorporated in the current mask until it is merged with a mask using Add Selection or Subtract Selection operations.

**To edit the mask**

1. Open the photo to be masked by double clicking on its name on the Workspace / Photo pane. The photo will be opened in the main window. The existing mask will be displayed as a shaded region on the photo.

2. Select the desired selection tool and generate a selection.

3. Click on ![Add Selection toolbar button to add current selection to the mask, or ![Subtract Selection to subtract the selection from the mask. ![Invert Selection button allows to invert current selection prior to adding or subtracting it from the mask.

The following tools can be used for creating selections:

- **Rectangle selection tool**
  Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools were applied.

- **Intelligent scissors tool**
  Intelligent scissors is used to generate a selection by specifying its boundary. The boundary is formed by selecting a sequence of vertices with a mouse, which are automatically connected with segments. The segments can be formed either by straight lines, or by curved contours snapped to the object boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the selection, the boundary should be closed by clicking on the first boundary vertex.

- **Intelligent paint tool**
  Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image regions, bounded by object boundaries.
**Magic wand tool**

Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic Wand tool, click inside the region to be selected.

The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower tolerance values the tool selects fewer colors similar to the pixel you click with the Magic Wand tool. Higher value broadens the range of colors selected.

**Note**

- To add new area to the current selection hold the **Ctrl** key during selection of additional area.
- To reset mask selection on the current photo press **Esc** key.

A mask can be inverted using Invert Mask command from the Photo menu. The command is active in Photo View only. Alternatively, you can invert masks either for selected cameras or for all cameras in a chunk using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be masked out on all photos, where that object appears.

**Saving masks**

Created masks can be also saved for external editing or storage.

**To export masks**

1. Select Export Masks... command from the Tools menu.
2. In the Export Mask dialog select suitable parameters. Click OK button when done.
3. Browse to the folder where the masks should be saved and select it.
4. The progress dialog box will appear displaying the current processing status. To cancel processing click Cancel button.

The following parameters can be specified during mask export:

**Export masks for**

- Specifies whether masks should be exported for the currently opened photo, active chunk or entire Workspace.
  - **Current photo** - save mask for the currently opened photo (if any).
  - **Active chunk** - save masks for active chunk.
  - **Entire workspace** - save masks for all chunks in the project.

**File type**

- Specifies the type of generated files.
  - **Single channel mask image** - generates single channel black and white mask images.
  - **Image with alpha channel** - generates color images from source photos combined with mask data in alpha channel.
Mask file names
Specifies the file name template used to generate mask file names. This template can contain special tokens, that will be substituted by corresponding data for each photo being processed. The following tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.
{camera} - camera label.
{frame} - frame number.
{filenum} - sequential number of the mask being exported.

For example, {filename}_mask.png template can be used to export masks in PNG format with _mask suffix.

Note
• When importing/exporting mask for the current photo only, PhotoScan will prompt for the actual image instead of image folder. Mask file names parameter will not be used in this case.

Editing point cloud
The following point cloud editing tools are available in PhotoScan:

• Automatic filtering based on specified criterion (sparse cloud only)
• Automatic filtering based on applied masks (dense cloud only)
• Reducing number of points in cloud by setting tie point per photo limit (sparse cloud only)
• Manual points removal

Note
• Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit menu.

Filtering points based on specified criterion
In some cases it may be useful to find out where the points with high reprojection error are located within the sparse cloud, or remove points representing high amount of noise. Point cloud filtering helps to select such points, which usually are supposed to be removed.

PhotoScan supports the following criteria for point cloud filtering:

Reprojection error
High reprojection error usually indicates poor localization accuracy of the corresponding point projections at the point matching step. It is also typical for false matches. Removing such points can improve accuracy of the subsequent optimization step.

Reconstruction uncertainty
High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small baseline. Such points can noticeably deviate from the object surface, introducing noise in the point cloud. While removal of such points should not affect the accuracy of optimization, it may be useful
to remove them before building geometry in Point Cloud mode or for better visual appearance of the point cloud.

**Image count**

PhotoScan reconstruct all the points that are visible at least on two photos. However, points that are visible only on two photos are likely to be located with poor accuracy. Image count filtering enables to remove such unreliable points from the cloud.

**To remove points based on specified criterion**

1. Switch to Point Cloud view mode using Point Cloud toolbar button.
2. Select Gradual Selection... command from the Edit menu.
3. In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold level using the slider. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. To remove selected points use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

**Filtering points based on applied masks**

**To remove points based on applied masks**

1. Switch to Dense Cloud view mode using Dense Cloud toolbar button.
2. Choose Select Masked Points... command from the Dense Cloud submenu of the Tools menu.
3. In the Select Masked Points dialog box indicate the photos whose masks to be taken into account. Adjust the edge softness level using the slider. Click OK button to run the selection procedure.
4. To remove selected points use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

**Tie point per photo limit**

Tie point limit parameter could be adjusted before Align photos procedure. The number indicates upper limit of matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment process with Tie Points - Thin Point Cloud command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment will be kept unchanged.

**Manual points removal**

Incorrect points can be also removed manually.

**To remove points from a point cloud manually**

1. Switch to Sparse Cloud view mode using Point Cloud toolbar button or to Dense Cloud view mode using Dense Cloud toolbar button.
2. Select points to be removed using (Rectangle Selection),  (Circle Selection) or  (Free-Form Selection) tools. To add new points to the current selection hold the Ctrl key during selection of additional points. To remove some points from the current selection hold the Shift key during selection of points to be removed.

3. To delete selected points click the Delete Selection toolbar button or select Delete Selection command from the Edit menu. To crop selection to the selected points click the Crop Selection toolbar button or select Crop Selection command from the Edit menu.

Classifying dense cloud points

PhotoScan allows not only to generate and visualize dense point cloud but also to classify the points within it. There are two options: automatic division of all the points into two classes - ground points and the rest, and manual selection of a group of points to be placed in a certain class from the standard list known for LIDAR data. Dense cloud points classification opens way to customize Build Mesh step: you can choose what type of objects within the scene you would like to be reconstructed and indicate the corresponding point class as a source data for mesh generation. For example, if you build mesh based on ground points only, it will be possible to export DTM (as opposed to DSM) at the next step.

Automatic classification of ground points

For the user to avoid extra manual work PhotoScan offers feature for automatic detection of ground points.

To classify ground points automatically

1. Select Classify Ground Points... command from the Dense Cloud submenu of the Tools menu.

2. In the Classify Ground Points dialog box select the source point data for the classification procedure. Click OK button to run the classification procedure.

Automatic classification procedure consists of two steps. At the first step the dense cloud is divided into cells of a certain size. In each cell the lowest point is detected. Triangulation of these points gives the first approximation of the terrain model.

At the second step new point is added to the ground class, providing that it satisfies two conditions: it lies within a certain distance from the terrain model and that the angle between terrain model and the line to connect this new point with a point from a ground class is less than a certain angle. The second step is repeated while there still are points to be checked.

The following parameters control automatic ground points classification procedure

Max angle (deg)
Determines one of the conditions to be checked while testing a point as a ground one, i.e. sets limitation for an angle between terrain model and the line to connect the point in question with a point from a ground class. For nearly flat terrain it is recommended to use default value of 15 deg for the parameter. It is reasonable to set a higher value, if the terrain contains steep slopes.

Max distance (m)
Determines one of the conditions to be checked while testing a point as a ground one, i.e. sets limitation for a distance between the point in question and terrain model. In fact, this parameter determines the assumption for the maximum variation of the ground elevation at a time.
Cell size (m)
Determines the size of the cells for point cloud to be divided into as a preparatory step in ground
points classification procedure. Cell size should be indicated with respect to the size of the largest
area within the scene that does not contain any ground points, e. g. building or close forest.

Manual classification of dense cloud points

PhotoScan allows to associate all the points within the dense cloud with a certain standard class (see
LIDAR data classification). This provides possibility to diversify export of the processing results with
respect to different types of objects within the scene, e. g. DTM for ground, mesh for buildings and point
cloud for vegetation.

To assign a class to a group of points

1. Switch to Dense Cloud view mode using using Dense Cloud toolbar button.

2. Select points to be placed to a certain class using Rectangle Selection, Circle Selection or
   Free-Form Selection tools. To add new points to the current selection hold the Ctrl key during
   selection of additional points. To remove some points from the current selection hold the Shift key
during selection of points to be removed.

3. Select Assign Class... command from the Dense Cloud submenu of the Tools menu.

4. In the Assign Class dialog box select the source point data for the classification procedure and the
   targeted class to be assigned to the selected points. Click OK button to run classification procedure.

Dense point cloud classification can be reset with Reset Classification command from Tools - Dense Cloud
menu.

Editing model geometry

The following mesh editing tools are available in PhotoScan:

• Decimation tool
• Close Holes tool
• Automatic filtering based on specified criterion
• Manual polygon removal
• Fixing mesh topology

More complex editing can be done in the external 3D editing tools. PhotoScan allows to export mesh and
then import it back for this purpose.

Note

• For polygon removal operations such as manual removal and connected component filtering it
   is possible to undo the last mesh editing operation. There are Undo/Redo commands in the Edit
   menu.

Please note that undo/redo commands are not supported for mesh decimation and this operation
cannot be undone.
Decimation tool

Decimation is a tool used to decrease the geometric resolution of the model by replacing high resolution mesh with a lower resolution one, which is still capable of representing the object geometry with high accuracy. PhotoScan tends to produce 3D models with excessive geometry resolution, so mesh decimation is usually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands polygons. While it is acceptable to work with such a complex models in 3D editor tools, in most conventional tools like Adobe Reader or Google Earth high complexity of 3D models may noticeably decrease application performance. High complexity also results in longer time required to build texture and to export model in pdf file format.

In some cases it is desirable to keep as much geometry details as possible like it is needed for scientific and archive purposes. However, if there are no special requirements it is recommended to decimate the model down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in Google Earth and alike tools.

To decimate 3D model

1. Select Decimate Mesh... command from the Tools menu.
2. In the Decimate Mesh dialog box specify the target number of polygons, which should remain in the final model. Click on the OK button to start decimation.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

Note

- Texture atlas is discarded during decimation process. You will have to rebuild texture atlas after decimation is complete.

Close Holes tool

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a mesh with several holes, due to insufficient image overlap for example.

Some tasks require a continuous surface disregarding the fact of information shortage. It is necessary to generate a close model, for instance, to fulfill volume measurement task with PhotoScan.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum size of a hole to be covered with extrapolated data.

To close holes in a 3D model

1. Select Close Holes... command from the Tools menu.
2. In the Close Holes dialog box indicate the maximum size of a hole to be covered with the slider. Click on the OK button to start the procedure.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.
Note

- The slider allows to set the size of a hole in relation to the size of the whole model surface.

**Polygon filtering on specified criterion**

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select polygons, which usually are supposed to be removed.

PhotoScan supports the following criteria for face filtering:

**Connected component size**

This filtering criteria allows to select isolated fragments with a certain number of polygons. The number of polygons in all isolated components to be selected is set with a slider and is indicated in relation to the number of polygons in the whole model. The components are ranged in size, so that the selection proceeds from the smallest component to the largest one.

**Polygon size**

This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be selected is set with a slider and is indicated in relation to the size of the whole model. This function can be useful, for example, in case the geometry was reconstructed in Smooth type and there is a need to remove extra polygons automatically added by PhotoScan to fill the gaps; these polygons are often of a larger size that the rest.

**To remove small isolated mesh fragments**

1. Select Gradual Selection... command from the Edit menu.
2. In the Gradual Selection dialog box select Connected component size criterion.
3. Select the size of isolated components to be removed using the slider. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. To remove the selected components use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

**To remove large polygons**

1. Select Gradual Selection... command from the Edit menu.
2. In the Gradual Selection dialog box select Polygon size criterion.
3. Select the size of polygons to be removed using the slider. You can observe how the selection changes while dragging the slider. Click OK button to finalize the selection.
4. To remove the selected components use Delete Selection command from the Edit menu or click Delete Selection toolbar button (or simply press Del button on the keyboard).

Note that PhotoScan always selects the fragments starting from the smallest ones. If the model contains only one component the selection will be empty.

**Manual face removal**

Unnecessary and excessive sections of model geometry can be also removed manually.
To remove part of the mesh polygons manually

1. Select rectangle, circle or free-form selection tool using Rectangle Selection, Circle Selection or Free-Form Selection toolbar buttons.

2. Make the selection using the mouse. To add new polygons to the current selection hold the **Ctrl** key during selection of additional polygons. To remove some polygons from the current selection hold the **Shift** key during selection of polygons to be excluded.

3. To delete selected polygons click the Delete Selection toolbar button or use Delete Selection command from the Edit menu. To crop selection to the selected polygons click the Crop Selection toolbar button or use Crop Selection command from the Edit menu.

To grow or shrink current selection

1. To grow current selection press **PageUp** key in the selection mode. To grow selection by even a larger amount, press **PageUp** while holding **Shift** key pressed.

2. To shrink current selection press **PageDown** key in the selection mode. To shrink selection by even a larger amount, press **PageDown** while holding **Shift** key pressed.

**Fixing mesh topology**

PhotoScan is capable of basic mesh topology fixing.

To fix mesh topology

1. Select View Mesh Statistics... command from the Tools menu.

2. In the Mesh Statistics dialog box you can inspect mesh parameters. If there are any topological problems, Fix Topology button will be active and can be clicked to solve the problems.

3. The progress dialog box will appear displaying the current processing status. To cancel processing click on the Cancel button.

**Editing mesh in the external program**

To export mesh for editing in the external program

1. Select Export Model... command from the File menu.

2. In the Save As dialog box, specify the desired mesh format in the Save as type combo box. Select the file name to be used for the model and click Save button.

3. In the opened dialog box specify additional parameters specific to the selected file format. Click OK button when done.

To import edited mesh

1. Select Import Mesh... command from the Tools menu.

2. In the Open dialog box, browse to the file with the edited model and click Open.
Note

- PhotoScan supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY, Autodesk FBX, Autodesk DXF, OpenCTM and U3D file formats only. Please make sure to select one of these file formats when exporting model from the external 3D editor.

- Please be aware that it is important to keep reference information for the model if any.
Chapter 6. Automation

Using chunks

When working with typical data sets, automation of general processing workflow allows to perform routine operations efficiently. PhotoScan allows to assign several processing steps to be run one by one without user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even further due to 'multiple chunk project' concept, each chunk to include one typical data set. For a project with several chunks of the same nature, common operations available in Batch Processing dialog are applied to each selected chunk individually, thus allowing to set several data sets for automatic processing following predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount of photographs is too large to be processed at a time. To overcome this difficulty PhotoScan offers a possibility to split the set of photos into several separate chunks within the same project. Alignment of photos, building dense point cloud, building mesh, and forming texture atlas operations can be performed for each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using PhotoScan following the general workflow. In fact, in PhotoScan always exists at least one active chunk and all the 3D model processing workflow operations are applied to this chunk.

To work with several chunks you need to know how to create chunks and how to combine resulting 3D models from separate chunks into one model.

Creating a chunk

To create new chunk click on the Add Chunk toolbar button on the Workspace pane or select Add Chunk command from the Workspace context menu (available by right-clicking on the root element on the Workspace pane).

After the chunk is created you may load photos in it, align them, generate dense point cloud, generate mesh surface model, build texture atlas, export the models at any stage and so on. The models in the chunks are not linked with each other.

The list of all the chunks created in the current project is displayed in the Workspace pane along with flags reflecting their status.

The following flags can appear next to the chunk name:

**R (Referenced)**

Notifies that 3D model in the chunk was referenced. Also will appear when two or more chunks are aligned with each other. See information on how to reference the model in Setting coordinate system.

**S (Scaled)**

Notifies that 3D model in the chunk was scaled based on scale bars information only, with no reference coordinates data being present. See information on scale bar placement in Optimization of camera alignment section.

To move photos from one chunk to another simply select them in the list of photos on the Workspace pane, and then drag and drop to the target chunk.
Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs, aligning them, generating dense point cloud, building mesh, building texture atlas, exporting 3D model and so on.

Note that all these operations are applied to the active chunk. When a new chunk is created it is activated automatically. Save project operation saves the content of all chunks. To save selected chunks as a separate project use Save Chunks command from the chunk context menu.

To set another chunk as active

1. Right-click on the chunk title on the Workspace pane.
2. Select Set Active command from the context menu.

To remove chunk

1. Right-click on the chunk title on the Workspace pane.
2. Select Remove Items command from the context menu.

Aligning chunks

After the "partial" 3D models are built in several chunks they can be merged together. Before merging chunks they need to be aligned.

To align separate chunks

1. Select Align Chunks command from the Workflow menu.
2. In the Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-click. Set desired alignment options. Click OK button when done.
3. The progress dialog box will appear displaying the current processing status. To cancel processing click the Cancel button.

Aligning chunks parameters

The following parameters control the chunks alignment procedure and can be modified in the Align Chunks dialog box:

Method

Defines the chunks alignment method. Point based method aligns chunks by matching photos across all the chunks. Marker based method uses markers as common points for different chunks. The details on using markers are available in the Setting coordinate system section. Camera based method is used to align chunks based on estimated camera locations. Corresponding cameras should have the same label.

Accuracy (Point based alignment only)

Higher accuracy setting helps to obtain more accurate chunk alignment results. Lower accuracy setting can be used to get the rough chunk alignment in the shorter time.

Point limit (Point based alignment only)

The number indicates upper limit of feature points on every image to be taken into account during Point based chunks alignment.
Fix scale
Option is to be enabled in case the scales of the models in different chunks were set precisely and should be left unchanged during chunks alignment process.

Preselect image pairs (Point based alignment only)
The alignment process of many chunks may take a long time. A significant portion of this time is spent for matching of detected features across the photos. Image pair preselection option can speed up this process by selection of a subset of image pairs to be matched.

Constrain features by mask (Point based alignment only)
When this option is enabled, features detected in the masked image regions are discarded. For additional information on the usage of masks refer to the Using masks section.

Note
- Chunk alignment can be performed only for chunks containing aligned photos.
- There is no need to perform chunk alignment for georeferenced chunks, as they are already in the same coordinate frame.

Merging chunks
After alignment is complete the separate chunks can be merged into a single chunk.

To merge chunks
1. Select Merge Chunks command from the Workflow menu.
2. In the Merge Chunks dialog box select chunks to be merged and the desired merging options. Click OK button when done.
3. PhotoScan will merge the separate chunks into one. The merged chunk will be displayed in the project content list on Workspace pane.

The following parameters control the chunks merging procedure and can be modified in the Merge Chunks dialog box:

Merge dense clouds
Defines if dense clouds from the selected chunks are combined.

Merge models
Defines if models from the selected chunks are combined.

Merge markers
Defines if markers from the selected chunks are merged (only markers with the same labels would be merged).

Chunks merging result (i.e. photos, point clouds and geometry) will be stored in the new chunk and it may be treated as an ordinary chunk (e.g. the model can be textured and/or exported).

Batch processing
PhotoScan allows to perform general workflow operations with multiple chunks automatically. It is useful when dealing with a large number of chunks to be processed.
Batch processing can be applied to all chunks in the Workspace, to unprocessed chunks only, or to the chunks selected by the user. Each operation chosen in the Batch processing dialog will be applied to every selected chunk before processing will move on to the next step.

Batch processing can perform the following operations:

- Align Photos
- Optimize Alignment
- Build Dense Cloud
- Build Mesh
- Build Texture
- Decimate Mesh
- Import Cameras
- Import Masks
- Export Points
- Export Model
- Export Texture
- Export Orthophoto
- Export DEM
- Align Chunks
- Merge Chunks
- Save Project
- Save project after every completed operation

**To start batch processing**

1. Select Batch Process... command from the Workflow menu.
2. Click Add to add the desired processing stages.
3. In the Add Job dialog select the kind of operation to be performed, the list of chunks it should be applied to, and desired processing parameters. Click OK button when done.
4. Repeat the previous steps to add other processing steps as required.
5. Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.
6. Click OK button to start processing.
7. The progress dialog box will appear displaying the list and status of batch jobs and current operation progress. To cancel processing click the Cancel button.
4D processing

Overview

PhotoScan supports reconstruction of dynamic scenes captured by a set of statically mounted synchronized cameras. For this purpose multiple image frames captured at different time moments can be loaded for each camera location, forming a multiframe chunk. In fact normal chunks capturing a static scene are multiframe chunks with only a single frame loaded. Navigation through the frame sequence is performed using Timeline pane.

Although a separate static chunk can be used to process photos for each time moment, aggregate multiframe chunks implementation has several advantages:

• Coordinate systems for individual frames are guaranteed to match. There is no need to align chunks to each other after processing.

• Each processing step can be applied to the entire sequence, with a user selectable frame range. There is no need to use batch processing, which simplifies the workflow.

• Accuracy of photo alignment is better due to the joint processing of photos from the entire sequence.

• Markers can be tracked automatically through the sequence.

• Intuitive interface makes navigation through the sequence pretty simple and fast.

Multiframe chunks can be also efficient (with some limitations) for processing of disordered photo sets of the same object or even different objects, provided that cameras remain static throughout the sequence.

Managing multiframe chunks

Multiframe layout is formed at the moment of adding photos to the chunk. It will reflect the data layout used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance. The following data layouts can be used with PhotoScan:

a. All frames from corresponding camera are contained in a separate subfolder. The number of subfolders is equal to the number of cameras.

b. Corresponding frames from all cameras are contained in a separate subfolder. The number of subfolders is equal to the number of frames.

c. All frames from corresponding camera are contained in a separate multilayer image. The number of multilayer images is equal to the number of cameras.

d. Corresponding frames from all cameras are contained in a separate multilayer image. The number of multilayer images is equal to the number of frames.

Once the data is properly organized, it can be loaded into PhotoScan to form a multiframe chunk. The exact procedure will depend on whether the multifolder layout (variants a and b) or multilayer (variants c and d) layout is used.

To create a chunk from multifolder layout

1. Select Add Folder... command from the Workflow menu.
2. In the Add Folder dialog box browse to the parent folder containing subfolders with images. Then click Select Folder button.

3. In the Add Photos dialog select the suitable data layout. For layout a) above select "Create multiframe cameras from folders as cameras". For layout b) select "Create multiframe cameras from folders as frames".

4. Created multiframe chunk will appear on the Workspace pane.

**To create a chunk from multilayer images**

1. Select Add Photos... command from the Workflow menu or click Add Photos toolbar button.

2. In the Add Photos dialog box browse to the folder containing multilayer images and select files to be processed. Then click Open button.

3. In the Add Photos dialog select the suitable data layout. For layout c) above select "Create multiframe cameras from files as cameras". For layout d) select "Create multiframe cameras from files as frames".

4. Created multiframe chunk will appear on the Workspace pane.

It is recommended to inspect the loaded frame sequence for errors. This can be done by scrolling the frame selector in the Timeline pane and inspecting thumbnails in the Photos pane during scrolling.

After multiframe chunk is created, it can be processed in the same way as normal chunks. For multiframe chunks additional processing parameters allowing to select the range of frames to be processed will be provided where appropriate.

**Tracking markers**

PhotoScan allows to automatically track marker projections through the frames sequence, provided that object position doesn't change significantly between frames. This greatly simplifies the task of labeling of a moving point if the number of frames is large.

**To track markers through the frame sequence**

1. Scroll frame selector in the Timeline pane to the 1st frame. Add markers for the 1st frame as described in the Setting coordinate system section.

2. Select Track Markers... command from the Tools menu.

3. Adjust the starting and ending frame indices if necessary. Default values correspond to tracking from the current frame to the end of sequence. Click OK button to start tracking.

4. Check tracked marker locations. Automatically tracked markers will be indicated with icons. In case of a placement error at some frame, adjust the wrong marker location within the frame where the failure occurred. Once the marker location is refined by user, the marker icon will change to .

5. Restart tracking from that frame using Track Markers... command again.

**Note**

- If the ending frame index is smaller than the starting index, tracking will be performed in the backwards direction.
• Automatic marker tracking is likely to fail in case when structured light is used to add texture details to the object surface, as the light pattern will not be static with respect to the moving object surface.

**Python scripting**

PhotoScan supports Python API, using Python 3.3 as a scripting engine.

Python commands and scripts can be executed in PhotoScan through one of the following options:

• PhotoScan Console pane can serve as standard Python console;

• Click Run Script button on Console pane toolbar or use Run Script... command from the Tools menu to run a Python script.

For details on PhotoScan functionality accessible through Python scripts please refer to Python API Reference document available on AgiSoft official website (http://www.agisoft.com/downloads/user-manuals/).
Chapter 7. Network processing

Overview

Agisoft PhotoScan can be configured to run on a computer cluster where processing is distributed on several computer nodes connected to a local network. In such configuration multiple PhotoScan instances running on different processing nodes can work on the same task in parallel, effectively reducing the total processing time needed.

By default processing is divided between the nodes on a chunk by chunk, frame by frame basis (with the exception of camera alignment and optimization, where each chunk is processed as a whole on a single node). In addition a more fine grained distribution can be enabled for photo alignment and dense cloud generation, in which case processing of individual chunks/frames is further subdivided between several processing nodes.

Communication between processing nodes, server and clients is performed using TCP connections. In addition, shared network storage accessible for all processing nodes and clients is used for storing the source data and intermediate processing results.

Cluster components

Server

The server node coordinates operation of all processing nodes, maintaining a task queue for all projects scheduled for processing. A separate interface is provided for clients, which can connect to the server to start new processing tasks or monitor progress of existing ones.

The server itself doesn't perform any processing and can easily run on slow hardware. The server component is critical for operation of the cluster, and is not fault tolerant. Measures should be taken to ensure continuous operation of the server node.

The server node accepts TCP connections from processing nodes and clients on 2 separate interfaces, which can be attached to different physical network interfaces if necessary. The server node doesn't initiate any TCP connections itself.
Processing nodes

Processing nodes perform actual calculations, and thus need to be run on fast hardware. Each processing node connects to the server on startup and waits for a task to be assigned. Once the task is available, the node starts processing, informing the server about the progress. When processing is finished, the results are stored on shared network storage, and the server is informed about completion. Then a node switches to the next task when it becomes available.

Processing nodes can be added or removed from the cluster as needed. Abnormal shutdown of processing node doesn't cause cluster failure in most cases. Nevertheless, it is highly recommended to stop particular nodes using Agisoft Network Monitor before disconnecting them from the cluster.

Clients

Clients can connect to the server node to control cluster operation or to monitor its status. New tasks can be submitted for processing using Agisoft PhotoScan software configured as a network client, while cluster monitoring is performed using Agisoft Network Monitor. Multiple clients can be connected to the server node simultaneously.

Cluster setup

Before proceeding to the following steps please make sure that shared network storage is accessible from all processing and client nodes using the same absolute path. It should be either mounted to the same folder on all nodes (Linux), or should have the same UNC network path (Windows). In case such configuration is not possible (for example in mixed Windows/Linux cluster), a path prefix can be specified on each node to compensate for the differences.

Starting server

It is recommended to configure server with a static IP address, not dynamically assigned one. This IP address will be needed for each processing node and client.

The server process can be started by executing PhotoScan with the following command line arguments:

```
photoscan --server --control <ip>[:port] --dispatch <ip>[:port] [--root prefix]
```

--server parameter specifies that PhotoScan should be started in a server mode.

--control parameter specifies the network interface to be used for communication with clients. In case port value is omitted, the default port 5840 is used.

--dispatch parameter specifies the network interface to be used for communication with processing nodes. In case port value is omitted, the default port 5841 is used.

--root parameter can be used to specify network storage mount point or prefix path in case it is not the same across network.

Example:

```
photoscan --server --control 10.0.1.1 --dispatch 10.0.1.1
```

In this case PhotoScan will use the same interface for both clients and processing nodes with default port values.

Starting network nodes

The processing node can be started by executing PhotoScan with the following command line arguments:
photoscan --node --dispatch <ip>[:port] [--root prefix]

--node parameter specifies that PhotoScan should be started as a processing node.

--dispatch parameter specifies IP of the server to connect. In case port value is omitted, the default port 5841 is used.

--root parameter can be used to specify network storage mount point or prefix path in case it is not the same across network.

Example:
photoscan --node --dispatch 10.0.1.1

This command will start processing node using 10.0.1.1 as a server IP with default port 5841.

Checking cluster status

Start Agisoft Network Monitor application. In the host name field enter server IP used for client connections (10.0.1.1 in our example). Modify port values in case non-default port was specified. Click Connect button when done.

A list of available network nodes currently connected to the server will be displayed in the bottom part of the window. Please make sure that all started processing nodes are listed.

The top part lists tasks currently being processed (finished tasks are removed from the list as soon as they are completed). The task list will be empty if no processing was started yet.

Starting network processing

1. Configure Agisoft PhotoScan for network processing.

   Start Agisoft PhotoScan on any computer connected to the cluster network.

   Open Preferences dialog using Preferences... command from the Tools menu. On the Network tab make sure Enable network processing option is turned on, and specify the server IP used for client connection in the Host name field. In case non-default port was configured on a server, modify the port value accordingly.

   In case you are going to process a few single-frame chunks with large number of photos, we recommend to enable fine-level task distribution for all supported operations (Match Photos, Align Cameras, Build Dense Cloud). In case you are going to process a large number of small chunks, or chunks with large number of frames, fine-level task distribution can be left in disabled state.

   Press OK button when done.

2. Prepare project for network processing.

   Open the project file to be processed. Click Save As... command from the File menu and resave project to a folder on a shared network storage in PhotoScan Unpacked Project (*.psx) format. Alternatively you can save only particular chunks using Save Chunks... command from the Chunk context menu in the Workspace pane.

   Important! Please make sure that source images are located on shared network storage and not on a local hard drive. Otherwise processing nodes will be unable to load them.

3. Start processing.
Network processing

Start processing using corresponding command from the Workflow menu, or using Batch Process command to execute a command sequence. A network progress dialog should appear displaying current progress.

4. Wait for processing to complete.

You can disconnect from the server at any time using Disconnect button in the Network Progress dialog in case you need to work on other projects. Processing will continue in the background.

To see processing status after you have disconnected from the server simply open corresponding .psx project on the network storage. Alternatively you can use Agisoft Network Monitor to see processing status for all projects being processed.

5. Save processing results as normal .psz project.

Once processing is finished, you can resave the project in normal .psz format. In case you have disconnected from the server, you need to open .psx project first using Open... command from the File menu. Then save it to a desired location using Save As... command from the File menu, and selecting PhotoScan Project Files (*.psz) file type.

Cluster administration

Adding processing nodes

New processing nodes can be added by starting Agisoft PhotoScan on additional computers in the network node mode, as outlined in the Starting network nodes section above.

Removing processing nodes

Aborting or disconnecting processing node during cluster operation is not absolutely safe, and can lead to project corruption if performed during final project update at the end of processing. Although the chances of this situation are relatively low, we strongly recommend against such approach. To safely disconnect processing node from the cluster you need to stop processing on this node using Agisoft Network Monitor first.

1. Start Agisoft Network Monitor. Make sure the server IP is properly configured in the host name field and click Connect button.

2. In the bottom list of network nodes identify the node to be removed. From the node menu select Pause command to stop the node after it finishes current job, or Stop command to abort processing immediately.

3. Wait until the Batch # and Progress items for a selected node become empty. This indicates that the node has finished processing. The status of the node should be Paused.

4. Now you can safely disconnect the node by aborting PhotoScan process.
Appendix A. Graphical user interface

Application window

General view

General view of application window.

Model view

Model view tab is used for displaying 3D data as well as for mesh and point cloud editing. The view of the model depends on the current processing stage and is also controlled by mode selection buttons on the PhotoScan toolbar.

Model can be shown as a dense cloud, with class indication or without, or as a mesh in shaded, solid, wireframe or textured mode. Along with the model the results of photo alignment can be displayed. These include sparse point cloud and camera positions visualised data.
Graphical user interface

PhotoScan supports the following tools for navigation in the 3D view:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Keyboard modifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotation Tool</td>
<td>Default</td>
</tr>
<tr>
<td>Pan Tool</td>
<td>Ctrl key pressed</td>
</tr>
<tr>
<td>Zooming Tool</td>
<td>Shift key pressed</td>
</tr>
</tbody>
</table>

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the Navigation toolbar button.

**Note**
- Zooming into the model can be also controlled by the mouse wheel.

**Photo view**

Photo view tab is used for displaying individual photos as well as markers and masks on them.

Photo view is visible only if any photo is opened. To open a photo double-click on its name on the Workspace, Reference or Photos pane.

**Workspace pane**

On the Workspace pane all elements comprising the current project are displayed. These elements can include:

- List of chunks in the project
- List of cameras and camera groups in each chunk
- List of markers in each chunk
- List of scale bars in each chunk
- Tie points in separate chunks
- Depth maps in separate chunks
- Dense point clouds in separate chunks
- 3D models in separate chunks

Buttons located on the Workspace pane toolbar allow to:

- Add chunk
- Add photos
- Add marker
- Enable or disable certain cameras or chunks for processing at further stages.
- Remove items
Each element in the list is linked with the context menu providing quick access to some common operations.

**Photos pane**

Photos pane displays the list of photos / masks in the active chunk in the form of thumbnails.

Buttons located on the Photos pane toolbar allow to:

- Enable / disable certain cameras
- Remove cameras
- Rotate selected photos clockwise / counterclockwise
- Reset current photo filtering option
- Switch between images and masks thumbnails
- Increase / decrease icons' size or display detailed information on photos including EXIF data

**Console pane**

Console pane is used for:

- Displaying auxiliary information
- Displaying error messages
- Python commands input

Buttons located on the pane toolbar allow:

- Save log
- Clear log
- Execute Python script

**Reference pane**

Reference pane is designed for:

- Displaying camera and / or marker coordinates
- Displaying scale bars lengths
- Displaying camera orientations
- Displaying estimation errors

Buttons located on the pane toolbar allow:

- Import / export reference coordinates
- Convert reference coordinates from one system to the other
- Optimize camera alignment and update data
Graphical user interface

- Switch between source coordinates, estimated coordinates and errors views
- Indicate coordinate system and measurement accuracy to be assumed through Settings dialog

**Timeline pane**

Timeline pane is designed for:
- Working with multi-frame chunks

Buttons located on the pane toolbar allow:
- Add / remove frames from chunk
- Play / stop frame sequence
- Adjust frame rate through Settings dialog

**Note**

- To open any pane select a corresponding command from the View menu.

**Menu commands**

**File Menu**

- **New**
  Creates an empty PhotoScan project.
- **Open...**
  Opens PhotoScan project file.
- **Append...**
  Appends existing PhotoScan project file to the current one.
- **Save**
  Saves PhotoScan project file.
- **Save As...**
  Saves PhotoScan project file with a new name.
- **Export Model...**
  Saves 3D model.
- **Export Points...**
  Saves sparse / dense point cloud.
- **Export Orthophoto...**
  Generates orthophoto based on the reconstructed geometry.
- **Export DEM...**
  Generates digital elevation model based on the reconstructed geometry.
- **Generate Report...**
  Generates PhotoScan processing report in pdf format.
- **Upload Model...**
  Uploads reconstructed model to one of the supported web-sites.
- **Exit**
  Quits the application. Prompts to save any unsave changes applied to the current project.

**Edit Menu**

- **Undo**
  Undo the last editing operation.
Graphical user interface

Edit Menu

- Redo
- Delete Selection
- Crop Selection
  - Invert Selection
  - Grow Selection
  - Shrink Selection
  - Gradual selection...

Redo the previously undone editing operation.
Removes selected faces from the mesh or selected points from the point cloud.
Crops selected faces / points.
Inverts current selection.
Grows current selection.
Shrinks current selection.
Selects faces / points based on the specified criterion.

View Menu

- Point Cloud
- Dense Cloud
- Dense Cloud Classes
- Shaded
- Solid
- Wireframe
- Textured
- Full Screen
- Show Cameras
- Show Markers
- Show Region
- Show Trackball
- Show Info
  - Predefined views
  - Perspective/Orthographic
  - Stereo Mode
- Workspace
- Timeline

Displays sparse point cloud reconstructed during photo alignment.
Displays dense point cloud.
Displays dense point cloud colored by point classes.
Displays 3D model in the shaded mode.
Displays 3D model in the solid mode.
Displays 3D model in the wireframe mode.
Displays 3D model in the textured mode.
Switches to / from Full Screen mode.
Shows or hides camera positions estimated during image alignment.
Shows or hides marker positions.
Shows or hides region selector.
Shows or hides the trackball.
Shows or hides the mesh information on-screen display.
Switches viewport to one of the predefined views.
Switches visualisation view between Perspective and Orthographic.
Enable/disable stereo view mode according to the parameters specified in Preferences dialog.
Shows or hides Workspace pane.
Shows or hides Timeline pane.
Graphical user interface

**View Menu**
- Reference
  - Shows or hides Reference pane.
- Photos
  - Shows or hides Photos pane.
- Console
  - Shows or hides Console pane.
- Toolbar
  - Shows or hides Toolbar.

**Workflow Menu**
- Add Photos...
  - Loads additional photos to be processed by PhotoScan.
- Add Folder...
  - Loads additional photos from folders to be processed by PhotoScan.
- Align Photos...
  - Generates camera positions and sparse point cloud.
- Build Dense Cloud...
  - Generates dense point cloud.
- Build Mesh...
  - Generates polygonal model.
- Build Texture...
  - Generates 3D model texture.
- Align Chunks...
  - Aligns multiple chunks.
- Merge Chunks...
  - Merges multiple chunks into the single chunk.
- Batch Process...
  - Opens Batch Process dialog box.

**Tools Menu**
- Decimate Mesh...
  - Decimates mesh to the target face count.
- Close Holes...
  - Closes holes on the model surface.
- View Mesh Statistics...
  - Collects and displays mesh statistics.
- View Mesh UVs...
  - Displays mesh UV mapping.
- Measure Area and Volume...
  - Displays surface area and volume of the model.
- Classify Ground Points...
  - Classifies dense point cloud based on the user defined settings.
- Assign Class...
  - Assigns class to the selected points.
- Reset Classification...
  - Resets assigned classes.
- Select Masked Points...
  - Selects masked dense cloud points.
- Build Point Cloud...
  - Builds sparse point cloud based on the estimated camera parameters available.
- Thin Point Cloud...
  - Thin point cloud by reducing the number of projections on the individual photos to the given limit.
Graphical user interface

Tools Menu

- Detect Markers... Creates markers from coded targets on photos.
- Track Markers... Tracks marker locations across the frame sequence.
- Print Markers... Generates printable PDF file with coded targets.
- Import Mesh... Imports edited mesh from the external program.
- Import Texture... Imports edited texture from the external program.
- Import Cameras... Imports camera positions and orientation data.
- Import Markers... Imports marker projections.
- Import Masks... Imports masks or creates mask from model or background.
- Export Texture... Exports model texture.
- Export Cameras... Exports camera positions and orientation data.
- Export Markers... Exports marker projections.
- Export Matches... Exports tie point measurements.
- Export Masks... Exports masks.
- Export Panorama... Exports spherical panorama for camera stations.
- Undistort Photos... Removes nonlinear distortions by warping source photos.
- Camera Calibration... Shows camera calibration dialog box.
- Optimize Cameras... Shows camera alignment optimization dialog box.
- Reset Region Resets reconstruction volume selector to default position based on the sparse point cloud.
- Preferences... Shows preferences dialog box.
- Run Script... Opens Python Run Script dialog box.

Photo Menu

- Open Next Photo Opens next photo from the list in the Photos pane.
- Open Previous Photo Opens previous photo from the list in the Photos pane.
- Navigation Switches to navigation mode.
- Rectangle Selection Rectangle selection tool.
- Intelligent Scissors Intelligent Scissors selection tool.
- Intelligent Paint Intelligent Paint selection tool.
Graphical user interface

**Photo Menu**

- Magic Wand
  - Magic Wand selection tool.
- Add Selection
  - Adds current selection to the mask.
- Subtract Selection
  - Subtracts current selection from the mask.
- Invert Selection
  - Inverts current selection.
- Invert Mask
  - Inverts mask for the current photo.
- Reset Mask...
  - Resets mask for the current photo.
- Turn Shading On/Off
  - Turns mask shading on or off.
- Edit Markers
  - Switches to marker editing model.
- View Points
  - Shows detected features used for alignment of the current photo.

**Help Menu**

- Contents
  - Displays help contents.
- Check for Updates...
  - Checks if PhotoScan update is available for download.
- Activate Product...
  - Activates / deactivates the product using the activation key.
- About PhotoScan...
  - Displays program information, version number and copyright.

**Toolbar buttons**

**General commands**

- New
  - Creates a new PhotoScan project file.
- Open
  - Opens a PhotoScan project file.
- Save
  - Saves a PhotoScan project file.

**3D view commands**

- Undo
  - Undo the last editing operation.
- Redo
  - Redo the previously undone editing operation.
- Navigation
  - Navigation tool.
- Rectangle Selection
  - Rectangle selection tool.
- Circle Selection
  - Circle selection tool.
- Free-Form Selection
  - Free-form selection tool.
### Graphical user interface

#### 3D view commands
- **Resize region**: Volume selection tool.
- **Rotate Region**: Volume rotation tool.
- **Rotate Object**: Model rotation tool.
- **Delete Selection**: Removes selected faces / points.
- **Crop Selection**: Crops selected faces / points.

#### 3D view settings
- **Point Cloud**: Displays sparse point cloud reconstructed during image alignment.
- **Dense Cloud**: Displays dense point cloud model.
- **Dense Cloud Classes**: Displays dense point cloud coloured by point classes.
- **Shaded**: Displays 3D model in the shaded mode.
- **Solid**: Displays 3D model in the solid mode.
- **Wireframe**: Displays 3D model in the wireframe mode.
- **Textured**: Displays 3D model in the textured mode.
- **Show Cameras**: Shows / hides camera positions, reconstructed during image alignment.
- **Show Markers**: Shows / hides positions of markers placed on the model.
- **Show Aligned Chunks**: Shows / hides aligned chunks.
- **Reset View**: Resets model view.

#### Photo view commands
- **Undo**: Undo the last mask editing operation.
- **Redo**: Redo the previously undone mask editing operation.
- **Navigation**: Switches to the navigation mode.
- **Rectangle Selection**: Rectangle selection tool.
- **Intelligent Scissors**: Intelligent scissors tool.
- **Intelligent Paint**: Intelligent paint tool.
- **Magic Wand**: Magic wand tool.
- **Add Selection**: Adds current selection to the mask.
- **Subtract Selection**: Subtracts current selection from the mask.
**Photo view commands**

- **Invert Selection**: Inverts current selection.
- **Rotate Right**: Rotates the photo clockwise.
- **Rotate Left**: Rotates the photo counterclockwise.
- **Zoom In**: Increases magnification.
- **Zoom Out**: Decreases magnification.
- **Turn Shading On/Off**: Turns mask shading on or off.
- **Edit Markers**: Switches to marker editing mode.
- **View Points**: Shows / hides feature points used for alignment of the photo.

**Hot keys**

**General**

- **Create new project**: Ctrl + N
- **Save project**: Ctrl + S
- **Load project**: Ctrl + O
- **Full Screen**: F11

**Model View**

- **Undo (only for Delete, Assign Class / Classify Ground Points, Masking and Close Holes operations)**: Ctrl + Z
- **Redo (only for Delete, Assign Class / Classify Ground Points, Masking and Close Holes operations)**: Ctrl + Y
- **Switch between navigation and any other previously selected mode**: Space
- **Switch to stereoview mode**: 9
- **Switch between orthographic and perspective view modes**: 5
- **Change the angle for perspective view**: Ctrl + mouse wheel
- **Assign dense cloud class (only if some points are selected)**: Ctrl + Shift + C

**Predefined Views**

- **Top**: 7
- **Bottom**: Ctrl + 7
- **Right**: 3
## Predefined Views

<table>
<thead>
<tr>
<th>View</th>
<th>Key Combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Front</td>
<td>1</td>
</tr>
<tr>
<td>Back</td>
<td>Ctrl + 1</td>
</tr>
</tbody>
</table>

## Rotate View

<table>
<thead>
<tr>
<th>Rotation</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate Up</td>
<td>8</td>
</tr>
<tr>
<td>Rotate Down</td>
<td>2</td>
</tr>
<tr>
<td>Rotate Left</td>
<td>4</td>
</tr>
<tr>
<td>Rotate Right</td>
<td>6</td>
</tr>
</tbody>
</table>

## Photo View

<table>
<thead>
<tr>
<th>Action</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Next photo (according to Photos pane order)</td>
<td>Page Up</td>
</tr>
<tr>
<td>Previous photo (according to Photos pane order)</td>
<td>Page Down</td>
</tr>
<tr>
<td>Navigation mode</td>
<td>V</td>
</tr>
</tbody>
</table>

## Selection Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle selection</td>
<td>M</td>
</tr>
<tr>
<td>Intelligent scissors</td>
<td>L</td>
</tr>
<tr>
<td>Intelligent paint</td>
<td>P</td>
</tr>
<tr>
<td>Magic wand</td>
<td>W</td>
</tr>
<tr>
<td>Add selection</td>
<td>Ctrl + Shift + A</td>
</tr>
<tr>
<td>Subtract selection</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Invert selection</td>
<td>Ctrl + Shift + I</td>
</tr>
</tbody>
</table>
Appendix B. Supported formats

Images

Input formats
- JPG
- TIFF
- PNG
- BMP
- OpenEXR
- PGM, PPM
- MPO
- SEQ

Undistort formats
- JPG
- TIFF
- PNG
- BMP
- OpenEXR

Camera calibration

Import formats
- PhotoScan/Lens Calibration (*.xml)
- Australis Camera Parameters (*.txt)
- PhotoModeler Camera Calibration (*.ini)
- 3DM CalibCam Camera Parameters (*.txt)
- CalCam Camera Calibration (*.cal)

Export formats
- PhotoScan/Lens Calibration (*.xml)
- Australis Camera Parameters (*.txt)
- PhotoModeler Camera Calibration (*.ini)
- 3DM CalibCam Camera Parameters (*.txt)
- CalCam Camera Calibration (*.cal)

Camera flight log

Input format
- JPG EXIF metadata
- Character-separated values (*.txt)
- MAVinci CSV (*.csv)
- TopoAxis telemetry (*.tel)
- C-Astral Bramor log (*.log)

Estimated positions
- Character-separated values (*.txt)
- PhotoScan structure (*.xml)

GCP locations

Input format
- Character-separated values (*.txt)
- PhotoScan structure (*.xml)

Estimated positions
- Character-separated values (*.txt)
- PhotoScan structure (*.xml)

Intrinsic and extrinsic camera parameters

Import camera positions
- PhotoScan (*.xml)

Export camera positions
- PhotoScan (*.xml)
### Supported formats

<table>
<thead>
<tr>
<th><strong>Import camera positions</strong></th>
<th><strong>Export camera positions</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>BINGO (*.dat)</td>
<td>Bundler (*.out)</td>
</tr>
<tr>
<td>Bundler (*.out)</td>
<td>CHAN files (*.chan)</td>
</tr>
<tr>
<td>VisionMap Detailed Report (*.txt)</td>
<td>Boujou (*.txt)</td>
</tr>
<tr>
<td></td>
<td>Omega Phi Kappa (*.txt)</td>
</tr>
<tr>
<td></td>
<td>PATB Exterior Orientation (*.ptb)</td>
</tr>
<tr>
<td></td>
<td>BINGO Exterior Orientation (*.dat)</td>
</tr>
<tr>
<td></td>
<td>AeroSys Exterior Orientation (*.orn)</td>
</tr>
<tr>
<td></td>
<td>Inpho Project File (*.prj)</td>
</tr>
</tbody>
</table>

### Tie points

**Export matches**

- BINGO (*.dat)
- ORIMA (*.txt)
- PATB (*.ptb)

### Sparse/dense point cloud

<table>
<thead>
<tr>
<th><strong>Export formats</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Wavefront OBJ (*.obj)</td>
</tr>
<tr>
<td>Stanford PLY (*.ply)</td>
</tr>
<tr>
<td>XYZ Point Cloud (*.txt)</td>
</tr>
</tbody>
</table>

**Import not available**

- ASPRS LAS (*.las)
- ASTM E57 (*.e57)
- Universal 3D (*.u3d)
- potree (*.zip)
- PhotoScan OC3 (*.oc3)
- Adobe PDF (*.pdf)

### Mesh model

<table>
<thead>
<tr>
<th><strong>Import mesh</strong></th>
<th><strong>Export mesh</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Wavefront OBJ (*.obj)</td>
<td>Wavefront OBJ (*.obj)</td>
</tr>
<tr>
<td>3DS models (*.3ds)</td>
<td>3DS models (*.3ds)</td>
</tr>
<tr>
<td>COLLADA (*.dae)</td>
<td>COLLADA (*.dae)</td>
</tr>
<tr>
<td>Stanford PLY (*.ply)</td>
<td>Stanford PLY (*.ply)</td>
</tr>
<tr>
<td>STL models (*.stl)</td>
<td>STL models (*.stl)</td>
</tr>
<tr>
<td>Autodesk DXF (*.dxf)</td>
<td>Autodesk DXF (*.dxf)</td>
</tr>
<tr>
<td>Autodesk FBX (*.fbx)</td>
<td>Autodesk FBX (*.fbx)</td>
</tr>
<tr>
<td>Universal 3D models (*.u3d)</td>
<td>Universal 3D models (*.u3d)</td>
</tr>
</tbody>
</table>
## Supported formats

### Import mesh
- OpenCTM models

### Export mesh
- VRML models (*.wrl)
- Adobe PDF (*.pdf)

### Texture

#### Import texture
- JPG
- TIFF
- PNG
- BMP
- OpenEXR
- PGM, PPM

#### Export texture
- JPG
- TIFF
- PNG
- BMP
- OpenEXR
- PGM, PPM

### Orthophoto

#### Export orthophoto
- GeoTIFF
- JPG
- PNG
- Google Earth KML/KMZ

### Digital elevation model (DSM/DTM)

#### Export DEM
- GeoTIFF elevation (*.tif)
- Arc/Info ASCII Grid (*.asc)
- Band interleaved file format (*.bil)
- XYZ (*.xyz)
- Sputnik KMZ (*.kmz)

### Tiled models

#### Export tiles
- PhotoScan Model Tiles (*.tls)
Appendix C. Camera models

Agisoft PhotoScan supports several parametric lens distortion models. Specific model which approximates best a real distortion field must be selected before processing. All models assume a central projection camera. Non-linear distortions are modeled using Brown’s distortion model.

A camera model specifies the transformation from point coordinates in the local camera coordinate system to the pixel coordinates in the image frame.

The local camera coordinate system has origin at the camera projection center. The Z axis points towards the viewing direction, X axis points to the right, Y axis points down.

The image coordinate system has origin at the top left image pixel, with the center of the top left pixel having coordinates (0.5, 0.5). The X axis in the image coordinate system points to the right, Y axis points down. Image coordinates are measured in pixels.

Equations used to project a point in the local camera coordinate system to the image plane are provided below for each supported camera model.

The following definitions are used in the equations:

- \((X, Y, Z)\) - point coordinates in the local camera coordinate system,
- \((u, v)\) - projected point coordinates in the image coordinate system (in pixels),
- \((f_x, f_y)\) - focal lengths,
- \((c_x, c_y)\) - principal point coordinates,
- \(K_1, K_2, K_3, K_4\) - radial distortion coefficients,
- \(P_1, P_2\) - tangential distortion coefficients,
- skew - skew coefficient between the x and the y axis,
- width - image width in pixels,
- height - image height in pixels.

Frame cameras

\[
\begin{align*}
x &= X / Z \\
y &= Y / Z \\
r &= \sqrt{x^2 + y^2} \\
x' &= x(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + P_2 (r^2 + 2x^2) + 2P_1 xy \\
y' &= y(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + P_1 (r^2 + 2y^2) + 2P_2 xy \\
u &= c_x + x' f_x + y' skew \\
v &= c_y + y' f_y
\end{align*}
\]
Fisheye cameras

\[ x_0 = \frac{X}{Z} \]
\[ y_0 = \frac{Y}{Z} \]
\[ r_0 = \sqrt{x_0^2 + y_0^2} \]
\[ x = x_0 \cdot \tan^{-1} r_0 / r_0 \]
\[ y = y_0 \cdot \tan^{-1} r_0 / r_0 \]
\[ r = \sqrt{x^2 + y^2} \]
\[ x' = x(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + P_2 (r^2 + 2x^2) + 2P_1 xy \]
\[ y' = y(1 + K_1 r^2 + K_2 r^4 + K_3 r^6 + K_4 r^8) + P_1 (r^2 + 2y^2) + 2P_2 xy \]
\[ u = c_x + x' f_x + y' \text{skew} \]
\[ v = c_y + y' f_y \]

Spherical cameras (equirectangular projection)

\[ u = c_x + f_x \cdot \tan^{-1} \left( \frac{X}{Z} \right) \]
\[ v = c_y + f_y \cdot \tan^{-1} \left( \frac{Y}{\sqrt{X^2 + Z^2}} \right) \]

where:
\[ c_x = \text{width} \times 0.5 \]
\[ c_y = \text{height} \times 0.5 \]
\[ f_x = \text{width} / (2 \times \pi) \]
\[ f_y = \text{height} / \pi \]

- **Note**

  - Spherical (equirectangular) camera model doesn't support distortions. All distortions should be corrected before loading images in PhotoScan.

  - In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to process original images in PhotoScan using camera station function instead of stitching them in external software.