Agisoft Metashape

Agisoft Metashape => General => Topic started by: ihb on April 04, 2019, 09:30:06 PM

Title: UAV Images Appear Black after Radiometric Calibration
Post by: ihb on April 04, 2019, 09:30:06 PM
Hello everybody,

I have a question about radiometric calibration. I am working with a Micasense RedEdge MX (and the calibration panel that was sent with it). After downloading the reflectance values (CSV file) that Micasense provides for each calibration panel and uploading those values to Agisoft, all of my images appear black. This leads to every other step in the process (point cloud generation, build texture, mesh, and orthomosaic generation) changing to a thick, black color. However, when uploaded for analysis in ArcGIS Pro, the image appears normal, and the multispectral values generated from the ortho are within reason.

My question is this: Is there a way to prevent this "blacking out" from happening in Agisoft?

Initially, we checked both "use reflectance panel values" and "use sun sensor" boxes (as we do have a DLS equipped). We tried unchecking the "use sun sensor" option, but it did the same thing.

I have attached an example of what the image thumbnails look like just before the alignment process.

Note: Working with Agisoft Photoscan Professional 1.5.2 (the latest Photoscan addition).

Any help would be great! Thanks!
Title: Re: UAV Images Appear Black after Radiometric Calibration
Post by: Alexey Pasumansky on April 04, 2019, 09:54:35 PM
Hello ihb,

Can you send a small subset of images (including the calibration panel) to support@agisoft.com?

Maybe it is just darker? Have tried to adjust the brightness via Set Brightness tool?
Title: Re: UAV Images Appear Black after Radiometric Calibration
Post by: ihb on April 04, 2019, 10:16:34 PM
Alexey,

I just sent the email. Thanks for the response. I'm not sure if it is a brightness issue, because before calibration, the thumbnails are nice and clear. After the radiometric calibration procedure, they are black.

Thanks!
Title: Re: UAV Images Appear Black after Radiometric Calibration
Post by: Alexey Pasumansky on April 04, 2019, 10:33:11 PM
Hello ihb,

Please try to switch the Primary Channel via Tools menu to NIR band and then adjust the brightness (it will have only effect for the visualization) to 400-500%.

The reason of the darker images after calibration is related to the following: after the reflectance calibration is applied, the 100% reflectance value for each band corresponds to the middle of 16bit range, i.e. to 32768 value (uncalibrated values are up to 65535).
Title: Re: UAV Images Appear Black after Radiometric Calibration
Post by: ihb on April 04, 2019, 11:33:19 PM
Alexey,

Thanks for the help. That is most appreciated!

Regards,
ihb