Agisoft Metashape

Agisoft Metashape => Bug Reports => Topic started by: Daniele on August 01, 2022, 03:00:15 PM

Title: Texture missing when using GPU
Post by: Daniele on August 01, 2022, 03:00:15 PM
Dear Alexey,
I noticed that after the last update of metashape (1.8.4) the textures are not generated when enabling GPU processing.
 I have the following system:
GPU: NVIDIA GeForce GTX 1080/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 516.59
CPU: Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz

However, by using CPU the textures are ok.
Do you have some suggestions regarding such an issue in order to return to using my GPU correctly?

Many thanks for your time and support as always.

Best regards,
Daniele
Title: Re: Texture missing when using GPU
Post by: Alexey Pasumansky on August 01, 2022, 06:00:16 PM
Hello Daniele,

Can you please provide the log from the Console pane related to Build Texture operation that is started having NVIDIA GPU enabled in the preferences?
Title: Re: Texture missing when using GPU
Post by: Daniele on August 01, 2022, 06:37:11 PM
Of course Yes!
Here it is in attachment the log.

Many thanks, Alexey





Title: Re: Texture missing when using GPU
Post by: Alexey Pasumansky on August 01, 2022, 06:55:36 PM
Hello Daniele,

Thank you for the log. I do not see anything unusual in the log.

Can you please try to build a texture for the same model (for example, from our sample data list: https://www.agisoft.com/downloads/sample-data/) using GPU and using CPU only and send the resulting projects (or a project with two chunks or two mesh models in a single chunk) to support@agisoft.com?

Also please specify, what do you see in Tools Menu -> View Mesh UVs dialog for the texture generated on GPU?
Title: Re: Texture missing when using GPU
Post by: Daniele on August 02, 2022, 12:12:19 AM
Many thanks Alexey for your great help!
I have just sent the test project following your suggestion to support@agisoft.com.

I got the same problem also with your sample imagery.

Regards,
Daniele
Title: Re: Texture missing when using GPU
Post by: Daniele on August 03, 2022, 05:10:45 PM
Dear Alexey,
just to inform you that after getting in touch with your support team, I solved my problem which was not related to the last version of Metashape but to bad NVIDIA drivers.

So I have totally uninstalled the NVIDIA driver with Display Driver Uninstaller and manually installed one old driver from here: https://www.nvidia.com/Download/Find.aspx
Now texture blending works again with GPU enabled. Also works fine with the last version 1.8 of metashape. 

Thanks for your support, and sorry for the trouble.

Best regards,
Daniele