Agisoft Metashape

Agisoft Metashape => Bug Reports => Topic started by: jfalgout on June 02, 2017, 02:49:23 AM

Title: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: jfalgout on June 02, 2017, 02:49:23 AM
Linux ( RHEL 6.8 ) version of Photoscan-pro 1.3.1 and 1.3.2 exhibit this behavior. This bug is not present in 1.2.4.

Not tested on Windows or Mac.


If I open a project, select the photos tab from the photos pane, and then double click a photo to open it in a separate tab behind the model tab, all works fine - I can zoom in on the model, uses scroll bars. When I select that photo tab and then try to zoom in on the photo, move the window scroll bars on any pane, double click a point to edit the name, etc nothing happens. When I then click the model tab, all of the functions work again. If I tried to zoom in or out of the photo with the photo tab open, go to the model tab, then back to the photo tab, the photo is zoomed in or out (and most likely not where I wanted it). This also happens with scroll bar movements.

Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: Alexey Pasumansky on June 06, 2017, 03:37:34 PM
Hello jfalgout,

We have tried to reproduce the problem on CentOS 6.8 but were not able to do it. Can you please specify, if you can reproduce the issue on a different machine or on the different OS?
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: jfalgout on June 06, 2017, 09:02:28 PM
Hi Alexey -

I tried to reproduce the problem on a machine without a GPU and I did not experience the problem. The OS was Scientific Linux 6.7.

I tried it on two different machines with Nvidia Quadro M6000 24GB (Nvidia Driver version 367.27) GPU and experienced the issue on both machines (RHEL 6.8).


Both tests were run with v1.3.2 build 4205 (64bit).

Thanks for looking at this!

Jeff
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: mr.barnadib on September 20, 2017, 10:23:59 PM
same problem here on windows 10 64 bit
currently using 1.3.3
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: Ardu on September 26, 2017, 10:47:17 PM
I also have the same issue. I thought it was Windows 10, reinstalled Windows 10 and running latest version of Agisoft Photoscan Pro. Missing deadlines due to problem.
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: Alexey Pasumansky on September 26, 2017, 10:59:50 PM
For the Windows OS I can suggest to run PhotoScan in ANGLE compatibility mode:
Code: [Select]
photoscan.exe --opengl angle
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: Ardu on September 26, 2017, 11:31:43 PM
Thank you, working again
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: davidpmcg on September 27, 2017, 05:29:28 PM
Hello,

I am having the same problem as when running the updated version off,  windows 10 64 bit.

Apologies in advance, but,  how do I run the programme in ANGLE?

Regards,

DMcG
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: Alexey Pasumansky on September 27, 2017, 10:18:00 PM
Hello davidpmcg,

Please check the following post:
http://www.agisoft.com/forum/index.php?topic=7556.msg36560#msg36560

However, I assume that the issue could be related to some driver issue.
Title: Re: Scroll bars, zoom, etc not working when photo tab active in pro 1.3.1/1.3.2
Post by: davidpmcg on September 28, 2017, 12:12:10 PM
Thanks Alexy,

Working again.