Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Shadow

Pages: [1] 2
1
General / Watertight model/fill holes alongside the bounding box ?
« on: March 05, 2022, 11:18:36 AM »
Hello,

Is there a way to create a watertight model within Metashape, when the scan intersects the bounding box ?

An example is attached : I scanned one side of a sculpture, and the model intersects the bouding box at the top, bottom, back.
Interpolation: extrapolated was used.
I know the Tools:Mesh:Fill Holes tool can be useful, but it gives poor results (see last screenshot) because it doesn't try to follow the sides of the bounding box.

Is there any way, within Metashape, to get clean, flat surfaces in such a case ?

2
Looks like this feature request has been taken into account : as of 1.8.1, progress indication has been added to the taskbar on Windows.

Thanks a lot !

3
Hello Bill,
If I understand correctly you take two panoramas at the same X, Y (horizontal) location and vary the z (vertical) location by 5 to 10 meters. That is a pretty good distance to raise the camera on a stable platform, how is this accomplished?
Bill
Note exactly. Check out Christiane's Youtube channel, there are a couple of making-of videos :
https://www.youtube.com/channel/UCAIY9rkqm8viTedXDvmLUWw/videos
Basically :
- you take two panoramas at the same X, Y, the Z only varies by around 1 meter (depending on your tripod) ;
- you then move the camera to another location by around 5 to 10 meters in the X/Y plane.

4
Very interesting thread !

As mentioned in previous post, we are working with the Agisoft team to upload these dataset for the community to use, they will also publish some tutorials about it.
Wait for the announcement!

Christiane, are there any updates on the dataset & tutorials ?

5
Feature Requests / Improved display of processing status [Solved]
« on: January 09, 2021, 04:25:58 AM »
Hello,

The progress dialog box is of course very helpful, but if you're doing something else while processing a project, you can't see the progress bar any more.
I think there are two ways the current system could be improved :
- some products, such as lightroom, use the software icon in the Windows 10 taskbar to display the current progress of a task. Simple and effective : after shooting 100s of pictures to scan an object, I can export them from Lightroom, do something else, and just by looking at the taskbar, I know if the export process is almost finished or not.
(a screenshot is attached to this post)

- another way to improve the current system could be to display the progress dialog box as "always on top" of other applications. This way we could put it in a corner of the screen while browsing the web, watching a movie, etc, yet still be able to check both the progress status and the estimated remaining time.
Of course, this won't be a feature all user need or want, so this would be an option in the Metashape Preferences and not the default behaviour.

6
General / Re: Agisoft Metashape 1.7.0 pre-release
« on: January 04, 2021, 06:19:28 PM »
Hello Shadow,

Version 1.7.0 has been published on Downloads page:
https://www.agisoft.com/downloads/installer/

Feel free to share your feedback on the latest version.
Thanks !
1.7.0 downloaded and installed, so far I haven't had any issue. Thanks for all your work !

7
General / Re: Agisoft Metashape 1.7.0 pre-release
« on: December 31, 2020, 08:49:29 PM »
Quote
"Exclude stationary tie points" feature allows to suppress the tie points which appear in the exactly same locations of the image frame on multiple images.
Sweet ! This will be quite useful indeed.

Thanks for all the work, can't wait to use the final release !

8
General / Re: Agisoft Metashape 1.6.3 pre-release
« on: May 28, 2020, 04:30:36 PM »
Quote
Hello Shadow,

The reported issues should be fixed in the next update.
Awesome, thanks !

9
General / Re: Agisoft Metashape 1.6.3 pre-release
« on: May 23, 2020, 05:44:59 PM »
Quote
Fixed export of large AVI files (>4GB)
Since I was the one who reported this bug : thanks for taking a look at this issue !

If it's not too late in the development process, any chance you could take a look at this bug and feature request, which are also related to the export of animations ?

- Feature request : UHD-2 / 8K export (7680x4320 pixels) would be awesome : aliasing can cause some flickering issues. Exporting 8K videos, then converting then in 4K-UHD outside Metashape, would be an easy way to avoid most of those artifacts.
This would probably be an easy improvement, since it might only require to add a "7680x4320 (16:9)" option in the "Resolution" drop-down menu (see attachment dropdown.jpg).

- Bug : If I'm not mistaken, when exporting a video, it seems there's one unnecessary frame included. https://www.agisoft.com/forum/index.php?topic=12183.0
Additional info about this issue if you want to check it : export a 24fps, 1 second video, open the file in Virtual Dub. It will show that
a) the number of frames is 25 and the video is 1.042 second long, not 1 second long ;
b) the last frame seems empty (using 1.6.3 : if I'm not mistaken, with 1.6.2, the frame was not empty).
See attached file frame-bug.jpg : on the top, frame 24, on the bottom, frame 25, nothing is shown.

10
Hello,
This will probably sound like a very minor bug, and it is, but :
when you export videos using the animation tool, the resulting file seem to have 1 additional frame.
For example, if the animation is set to 10 seconds, 25 frames per second, the video should have 250 frames. But if you check the file, it has 251 frames.

I assume there might be a loop somewhere in the code with one useless iteration.

11
Bug Reports / Re: "Missing or Broken index" when exporting RAW video
« on: February 21, 2020, 05:28:32 PM »
I don't think so, since the issue is also there using DaVinci Resolve (which even fails to display the files in their folder, or to import them using drag & drop).
I sent a sample to the support (ticket number 134696).

12
Hello,

here are a few suggestions to improve the animation tools.
Providing more export options would be nice :
- UHD-2 (7 680 × 4 320) can be useful to later convert the video in UHD or even 1080p, and therefore reduce aliasing issues ;
- maybe an "export as image sequence" option ?

A HUGE improvement would be for Metashape to remember the last settings used : when tweaking an animation, being forced to set the resolution and framerate each and every time is a little bit annoying.

13
Bug Reports / Re: "Missing or Broken index" when exporting RAW video
« on: February 19, 2020, 12:28:45 AM »
Hello,
Thanks for the fast answer !
I'm using RGB, Metashape 1.6.1 Build 10009 64 bits / Windows 10 (18362).
My screen resolution is 3440x1440.
GPU acceleration is On (GeForce GTX 980 TI with 442.19 drivers)

14
Bug Reports / "Missing or Broken index" when exporting RAW video
« on: February 18, 2020, 10:39:00 PM »
Hello,

I've been playing with the video export tools, but I stumbled upon a weird issue :
- If I export low resolution RAW videos, everything is ok, the video can be played in VLC or imported in a video editing software without any issue ;
- If I export high resolution mjpeg videos, everything is ok as well.

But if I export high resolution (4k or 1920x1080) RAW videos, VLC tells me that the index is "missing or broken", and a software such as DaVinci Resolve is not able to import the file. Allowing VLC to attempt to repair the index doesn't fix anything.

Any idea what could be the issue ? Is this a known issue ?

15
Texture De-Lighter / GPU acceleration ?
« on: July 12, 2019, 10:27:53 PM »
Hello,
First of all, thanks a LOT for making the De-Lighter available. As a long-time Metashape/Photoscan (Standard Edition) user this will be really helpful.

I noticed that De-Lighter seems to rely on the CPU alone : do you think GPU acceleration could be added in a future update ?

Pages: [1] 2