Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Wizyza

Pages: [1] 2
1
Python and Java API / Selectively export textures?
« on: February 21, 2024, 10:33:44 PM »
Hello,

Assuming that I create all of the texture types for my model, is it possible to only have a subset of those textures included when exporting my model?

Thanks!

2
Bug Reports / Error during mesh edit following save after mesh edit
« on: January 22, 2024, 10:11:17 PM »
Hello,

When I'm editing a mesh, such as selecting and deleting faces or closing holes, I save my changes before continuing with further editing. However, following saving, when I attempt to perform additional editing, the mesh disappears from view and the following errors appear in the console:

Error: Bad local file header signature
Error: Can't unpack file

I'm currently running version 2.1.0 build 17532 on Windows 11 22H2.

Fortunately, I'm able to close out of Metashape, discarding the last changes, and I'm able to reopen and continue from before the errors occurred.

Thanks for the help.

3
General / Re: OSError: file used by another process
« on: January 22, 2024, 09:40:37 PM »
Thank you, Alexey.

My images are stored on a network drive,but my project files are stored locally. Would the remote storage of the images be the source of the problem?

Thanks again.

4
General / OSError: file used by another process
« on: January 08, 2024, 07:34:12 PM »
Hello everyone,

I've been running into an issue while running my automated workflow. Occasionally, processing will halt and the following error will show up in the console:

OSError: Can't replace file or directory: The process cannot access the file because it is being used by another process (32): PathToProject/ProjectName.files/99/0/depth_maps/data_unfiltered1.zip

I'm running Windows 11 22H2. I think I started having this issue with Metashape v.2.0.4. Has anyone else run into this problem? I've been using the same computer for some time with the same script and no other applications are running on the computer during processing. Metashape and the project files are local.

Thanks!

5
Python and Java API / Recording logs and console output using Python
« on: October 23, 2023, 07:54:50 PM »
Hello,

I'm running into some unwanted behavior when saving log/console output when running a script from within the GUI.

I have my script set up to enable logging at the start of the script. I then disable logging in the last line of my script so Metashape does not write to the previous log file the next time the application starts up. However, doing this seemingly prevents the last few lines of the console output from being recorded.

I figured a way around this would be to save the entire console text (Metashape.app.console_pane_contents) after the rest of the script has executed. However, I can't figure out how to do this through Python scripting. I want to save the output as a TXT file.

Thanks!

6
Python and Java API / Re: Accessing the number of projections per image
« on: October 23, 2023, 07:39:03 PM »
Thank you for the help Paulo! After the tweaks, it works as needed.

7
Bug Reports / Re: Metashape 2.0.2 and 2.0.3 crash when using scripts
« on: October 03, 2023, 06:03:51 PM »
Hi Alexey,

I made the changes you mentioned. I also was not aware of the "Write log to file" check box, so thank you for mentioning that.

However, the script still crashes Metashape and unfortunately, the log file (which I've attached) does not mention any errors that would help in diagnosing the issue.

Maybe it's just as well. I've already poured much time into the script I'm writing now and it's been a good learning experience.

Thank you again for the help.

PS - I had been running the script through the GUI.

8
Python and Java API / Accessing the number of projections per image
« on: October 02, 2023, 10:46:58 PM »
Hello,

How do I access the number of projections per image such as what is displayed in the Reference panel? I'm using the Python API for Metashape 2.0.3.

I found a past post from a few years ago that asked this same question:

https://www.agisoft.com/forum/index.php?topic=12758.0

I haven't been able to get any of the code to work. I'm guessing because the API has changed since the time of the posting?

Thanks!

9
Bug Reports / Re: Metashape 2.0.2 and 2.0.3 crash when using scripts
« on: October 02, 2023, 10:32:11 PM »
Hi Alexey,

The script can be downloaded from here:

https://code.usgs.gov/pcmsc/AgisoftAlignmentErrorReduction/-/tree/v2.0

I figured I'd post the link along with the actual script so you know where it's coming from.

Where are the log files stored?

10
Bug Reports / Re: Metashape 2.0.2 and 2.0.3 crash when using scripts
« on: September 25, 2023, 05:44:40 PM »
Hi Alexey,

No, the GUI works just fine. I'm writing my own script, which has run with no issue. I was hoping to use the script I referenced, making any changes needed to get it to run under 2.0.3. However, when I try to run the script through the GUI, the GUI crashes immediately. This is unfortunate, because I receive no feedback that would help me figure out where any issues are.

11
Bug Reports / Metashape 2.0.2 and 2.0.3 crash when using scripts
« on: September 19, 2023, 12:12:37 AM »
Hello,

I'm testing out using scripts to automate some of my processing. Currently, I'm trying a script developed by the USGS. Maybe some of you are familiar with the script associated with this publication:

    Over, J.R., A.C. Ritchie, C. Kranenburg, J.A. Brown, D.D. Buscombe,
    T. Noble, C.R. Sherwood, J. Warrick, and P.A. Wernette. (2021) Processing
    coastal imagery with Agisoft Metashape Professional Edition, version
    1.6—Structure from motion workflow documentation: U.S. Geological Survey
    Open-File Report 2021-1039, x p. www.doi.org/10.3133/ofr20211039.

The script contains a workflow for alignment and error reduction.

Unfortunately, using the script causes Metashape (2.0.2 and 2.0.3 running on Windows 11) to crash. When I use the script to perform alignment, the application crashes right as the camera positions are calculated. I've also tried alignment using the GUI and then using the script for error reduction - Metashape crashes immediately.

Has anyone had similar issues when using scripts?

Thanks.

12
General / Re: Blurry Portion on Finished Model
« on: January 12, 2022, 05:47:56 AM »
Hello, I figured I'd chime in here as I've been experiencing the same issue.

I've attached two screenshots: one taken in Metashape and the other in RealityCapture. If you look closely at the scale bar, in Metashape, you can see blurry patches. I've experienced no such issue in RC.

Is there a solution to this?

13
Bug Reports / Re: Version 1.8.0 bizarre textures
« on: January 12, 2022, 05:07:54 AM »
Hello Alexey,

I've also experienced this same issue when creating 4K and 8K textures with the GPU enabled. However, it doesn't seem to occur when creating 16K textures.

14
General / Re: Model Confidence greyed out?
« on: April 08, 2021, 05:19:24 AM »
Hello Alexey,

I don't recall if I had done anything. I went through the process again and this time I was able to get the model confidence. I thought maybe it was because I had scaled the model, but even after scaling the second attempt, the model confidence menu selection was still available.

What kinds of operations would cause the model to lose its confidence values?

15
General / Model Confidence greyed out?
« on: April 05, 2021, 06:11:38 PM »
Hi everyone,

I generated a mesh using depth maps and want to check the confidence of my model to figure out where I may need to take additional photos. However, when I go to the toolbar to select "Model Confidence", it's greyed out.

Am I missing something here? Was there a step I missed? When I generated the mesh, I made sure to select the option for calculating vertex colors.

Thanks!

Pages: [1] 2