Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - pbourke

Pages: [1]
1
General / Masks
« on: March 14, 2019, 05:42:23 AM »
Can I have some suggestions on when one chooses to apply masks to keypoints or tiepoints?

2
Feature Requests / Save chunk views
« on: March 14, 2019, 04:00:55 AM »
It would be most helpful for the last view of a chunk were saved with the chunk.
A time waster at the moment when I switch between chunks and the camera view of the chunk I'm switching from is used instead of the camera view from the last time I viewed the new chunk. I need to continually realign/reposition the camera ... switching between chunks is a fairly common exercise during manual marker placement.

3
General / Problem with camera positions
« on: March 12, 2019, 09:32:55 AM »
I'm a fairly regular used of MetashapePro.
Today I used a 100mm Canon Macro lens on Canon5D MKIII to capture a small nut.
On a tripod, in good light and high aperture, 75% of surfaces closest to the camera is in good focus.
I used a motorised platter, 20 degree steps around 360 degrees and 4 heights.
I created masks, but actually it didn't make any difference to the problem.
What I get can be seen in the attachment showing the sparse point loud and camera positions, part of the capture wedge camera positions are rotated around to overlap with another section of the 360 camera array.
Ideas?
Is a perfect 20 degree capture some sort of pathological case?

4
General / Extension tubes on lens
« on: March 06, 2019, 02:54:32 PM »
I've just reconstructed some small beads using a Canon5D MKIII and 100mm prime macro lens.
However, to maximise the size of the objects on the sensor I would like to use some extension tubes. A quick test seems to suggest this will take me from using about 1/5 of the sensor to over 1/2.
I can't test on the actual objects as they are in storage at the museum, but I wondered if there were any issues I might encounter? For example, the EXIF data won't reflect the presence of the extension tubes.

5
General / Camera positions?
« on: March 06, 2019, 01:31:38 PM »
I've reconstructed a 3D model and used scale bars.
Automatic marker detection worked fine.
I've chosen the two scale bars and entered the distance between them.
Also indicated one marker as the origin and another the axis I want.
I would have thought MetaShapePro could have calculated the camera positions for me ... if so, how? If not, why?

ps: I tried to upload a screen dump, first the system told me the maximum upload was 768KB, so I jpeg compressed it some more, then I got the error the maximum upload limit is 512KB. A bug somewhere. I'm trying a much smaller file now.

6
Face and Body Scanning / Scanning human bodies
« on: February 02, 2019, 01:44:27 PM »
I'm well versed in the use of PhotoScan and PhotoScan Pro.
In my current project I will be assembling a 100-150 (exact number still to be determined) camera rig for capturing full body humans. However, we are not interested in texture and the models will be largely unclothed, just underwear or swin gear. In addition some of the models will have blemish free skin and so I'm concerned about the number (or lack of) feature points that may be found.
My question, does anyone have experience or advice in possible ways to painting, taping, or otherwise preparing human skin for photography. We seek the most accurate reconstructed surface meshes ... again, won't be using the texture maps at all so there are no constraints on the surface preparation except that it doesn't perturb the surface, and of course is safe.

7
General / Spherical images in PhotoScan Pro
« on: October 11, 2017, 02:21:52 PM »
For the last couple of days I've been processing various image sets from a 360 camera roaming around a house. The testing is mostly around trying appropriate frame rate samplings from the 30fps video, every 10th frame, every 5th frame etc.

What seems consistent is that I get a reasonable and consistent number of tie points across all the images in the sequence, BUT only a subset of the images are "green ticked" and go on to contribute to the 3D model.

 The sets that do contribute are all consecutive  ... but then just stop, even though the images and number of tie points don't look any different.

Ideas?

8
Bug Reports / Canon 5D Mk IV
« on: May 16, 2017, 03:14:26 PM »
I normally use the Canon 5D Mk III, but just started using Mk iV.
However the raw images don't appear to work, they have unusual colours in the photo pane and totally fail to reconstruct.
I believe I have the latest raw drivers installed (Mac OSX, latest Sierra), the thumbnails and images look ok Preview so I think the OS level support is installed.
Anyone else reported this?
Suggestions?

9
Bug Reports / Dense point cloud clipping
« on: October 18, 2016, 04:17:34 PM »
I'm a long standing user of PhotoScan but this is the first time I have seen the following, not sure if it's a bug but I still need a solution. See attachments, this is an top view of a cave (the entrance is from the bottom) and the interior has been reconstructed beautifully from 750 photographs. One photo shows the spare point clout, the other the same top view of the dense point cloud. Why is the dense cloud clipped like this. Seems like a clipping rectangle rather than anything to do with the model geometry. Never experienced it before despite doing lots of similar caves.

Pages: [1]