Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Damian

Pages: [1]
1
Bug Reports / Missing 3d lines on Cameras
« on: January 12, 2022, 06:47:42 PM »
Hello

I have a project where I created DEM. I added 3d lines describing borders of parcels (plot). The point is to update the altitudes and to show borders on pitched cameras, taken along the building site.

However, for no reason some of the lines disappear and appear on neighbouring cameras. First I though, that it was due to "hiding under dem", but as I can see it is not a rule.

How to cope with it so that all the lines appear on cameras? What is the reason for them to disappear?

Looking forward to getting any clue :)

2
Bug Reports / Invalid shape - polygonal
« on: February 25, 2021, 10:58:13 AM »
Hello

For every project I create a kml with several polygonal shapes. Each shape has a description - map section's number. With Metashape 1.6. it was not a problem to import it and use for exporting shapes with proper file name. Now with 1.7. when I import a kml (which by the way in QGIS is imported as polygon), I cannot use it for export - just as if it was a poyline, not polygon. I cannot use it as boundary or measure the area.

In attachement two examples of KML.

I do not want to downgrade to 1.6. Is there any way you could make it work?

Best wishes
Damian

3
General / Markers eroors before and after selection
« on: May 28, 2020, 10:40:15 AM »
Hello!
The question is about the error [m] value of markers. We have three situations:
1. All markers are selected and the cameras are optimized on them - error on control points is 0,0014 m. (1st attachement - selected_optimized)
2. I unselect all markers - the error on check points raises to 0,0037 mdespite the fact, that i have not optimised the cameras yet. (2nd attachement - unselected_before_optimization)
3. I optimize the camaeras and the error on check points is 0,187 m. (3rd attachement - unselected_optimized)

I understand the change of value between optimisation on selected and deselected markers. I don't understand why there is a value change after deselection and before the optimisation.

Loking forward to reading some explanation.

4
General / Mouse navigation Agisoft 1.6.2
« on: April 02, 2020, 03:56:21 PM »
Hello
I might have a silly question. I updated my Metahspae to 1.6.2. In previous version I cloud move the view by using mouse wheel/right click (with active slection). Now I notced, that both mouse wheel and right click rotate the view. If I want to move the view I need either change to "navigation" or doule-left click to center the view. 
How can I change it back to have a possibilty to move with active selection?

5
Bug Reports / Height difference when raster transformation
« on: October 07, 2019, 03:45:48 PM »
Hello
I have a project prepared in modern Polish Coordinate System (EPSG 2176), height Kronstad. I would like to export DEM to an old coordinate system (ESPG 2174) with the same height system. Unfortunately the height difference between rasters is around 40m.

In attachements two dems form the same project.
What could be the cause and how can I work it out?

6
Bug Reports / Classify ground points lasts very long
« on: July 12, 2019, 08:52:54 AM »
Hello

I noticed, that ground point classification is taking now much more time than it used to. About 6 months ago classification was less time consuming than dense cloud generation. Later I noticed that both consume the same amount of time.

Now I have a project with dense cloud that contains about 3 900 000 colorized points, 8800 cameras  (42 MPix). It took 8h to generate depth maps and another 11 hours for dense cloud generation. Unfortunately, after the upgrade to version 1.5.3. the ground point classification after 10 hours shows me, that it needs 2 days 13 hours more to complete the task. I split the project into smaller parts (ca. 1 500 000 points), but there is no difference in time estimation.  Earlier it was not a problem to work with so big projects.

What could cause such situation? Before I upgraded to 1.5.3. I was not able to generate dense cloud (what has never happened before) due to "Image size mismatch error."

Looking forward to hearing from you.

7
General / Estimating Camera locations never ends
« on: May 24, 2019, 02:21:27 PM »
Hello

I am aligning 4000 cameras in one chunk and an issue happens: everytime when the alignment reaches "Estimating Camera locations" the process bar stops at some stage, the "time left" slowly goes down to 0 and then dissaperas. After that nothing happens [printscreen in attachement].  When I clikc "pause" or "cancel" buttons grey out and stay like that for ever.
Before that, I aligned 4500 cameras in same project in another chunk with no problem.

Alignment options are 40 000/ 4 000, earlier I tried with 30 000/3 000 - same result.

I attach a log
Thank you for quick answer.

8
Feature Requests / Export multiple Ortho/DEM sections
« on: January 21, 2019, 07:10:37 PM »
Hello!

My company works very often with huge projects (both private and public sector) where I prepare DEM and Ortho for big investments like highways, quarries etc. As I result I am expected to provide a lot of maps' sections which are usually used for projecting process. Currenty I am working on 100km of highway where as a result I will prepare around 400 sections of maps 1:2000 - ortho and DEM just for investment preparation. To do it I need to set a outer boundary separately for every section, check the export options, name it properly (ortho_6_142_25_03, dem..., etc.) and eventually save. It can take up to 2 days of work.

It is not a problem to prepare a shape with name as an attribute. It would be perfect if I just selected multiple boundaries, then used option like: "export multiple", "name after attribute..." and after few minutes/hours I would have all sections automaticly exported. Have you already taken into consideration such feature?

In attachement you can find the example of investment, where I need to export every section separately.

Thank you in advance for reply!

9
General / Out of memory (2) at line 179 after upgrading to Metashape
« on: December 21, 2018, 10:47:15 AM »
Hello

I have a problem with my Agisoft (error: "out of memory (2) at line 179") after upgrading to version Metashape 1.5.0.
Before the upgrade I processed usually 4000-7000 or even more photos in single chunk without any problem. After upgrading to Metashape it turned out that during the alignment of ~2500 photos described error appears. I downgraded back to Agisoft 1.4.4. but it did not solve the issue. In attachement you can find two logs - one is from Metashape where I try to allign around 4500 photos, the other is from downgraded 1.4.4 where I got error during aligment of ~2500 photos.

I am really looking froward to getting an advice as the problem seriously decresed my effectiveness.

Thank you in advance.

10
General / Exporting DEM after color palette change
« on: December 13, 2018, 03:53:17 PM »
Hello
I am having a problem with DEM export. I have one big investment, that I  split into several projects (no need of merging chunks etc.). I checked the lowest and highest elevation value in the area and set the DEM pallete in every project to have the same maximal and minimal absolute values. The color of DEM looks same in every project. So far everything is ok.

However, when I try to export the DEM I notice, that my palette set is being ignored, and exported DEM has the default one. In attached pictures you can see what I mean.

How can I make program export the DEM with the palette set I want?


11
General / Separate chunks or groups in one chunk - your opinion
« on: August 08, 2018, 10:41:33 AM »
Hello

I want to ask you how you organize your work. I have photos taken by one UAV, same camera, but in few separate flights one after another (due to battery change). The number of photos is around 1500. Is it better to create a separate chunk for every flight or just to put photos in "Camera calibration" into groups within one chunk?

In addition, there is an overlap (around one-two rows) between flights.

How do you process such project?

Thank you for answers!

12
General / Filling holes in orthomosaic
« on: August 07, 2018, 03:17:14 PM »
Hello

I have a question that affects the aesthetics rather than accuracy or software problem.
In a project I created a ortomosaic of a whole lake and its coast. As expected - the photos of water were not alligned and the DEM of lake itself was not created - the hole appeared in the middle. The question is - can I somehow import a water texture and fill the hole, so that the investor would get a complete model? Coast is the only important thing, water can be just  plane with texture linking the land.

Thank you for all answers

13
Feature Requests / Orthomosaic/DEM export with watermark
« on: August 07, 2018, 01:10:33 PM »
Hello

Is there a possibillity to export an orthomosaic or DEM with watermark in Agisoft Photoscan professional edition?  Maybe by somehow importing a .png file with company logo on a transparent backgrund? Investor requiers it sometimes.

Thank you for answer

Pages: [1]