Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Reservoirdog

Pages: [1] 2
1
Feature Requests / Re: Tool to decimate dense point cloud
« on: May 14, 2020, 05:23:23 PM »
This is already in Metashape. Right click on your Dense Cloud -> Filter Dense Cloud

Yes, it is possible to reduce with fixed point-distance.
But you can neither select a point-"target" nor can you reduce in a "smart way".

2
Feature Requests / Tool to decimate dense point cloud
« on: May 14, 2020, 04:16:05 PM »
I know there are similar request, but I want to start a new one.
To create really nice Orthophotos, we tend to produce very large dense point clouds. (500 Mio. points and more)
When we have to export points to other companies for planning purposes, we often have the difficult
task to decimate the point cloud.

At the moment, this can only be done using third party software like CloudCompare or FME.
A tool directly in Metshape would be very convenient, even better would be a tool which uses several ways (algorithms)
to achieve the decimation, e.g. total number of points, space between points, and some smart algorithms to decimate points
at planar areas instead of curvy (high altitude changes) areas.

thx for considering this request for future builds, also keep up the great work!
Metashape is a fantastic and capable product!

best regards, Chris.

3
General / Re: Cesium 3d tiles not working in Cesium anymore
« on: March 16, 2020, 01:15:07 PM »
Hey Alexey,

Thanks for your information.
I sent an email with data and report.

In the meantime I could test the cesium output from Photoscan 1.4.2
It works in our cesium environment!

4
General / Re: Cesium 3d tiles not working in Cesium anymore
« on: March 13, 2020, 02:52:12 PM »
Unfortunately, we cannot upgrade to 1.58 very quick, because Cesium has been implemented and modified to work properly in our GIS software.
Is it possible to export the tiled model with an old build of Metashape (Photoscan 1.4.2)?

edit: I did an install of 1.4.2, and realized that I cannot open Metashape-Projects. Also, I am unable to import a tiled model in old Photoscan.
What would be the best way to get my model in old Photoscan?
edit2: Nevermind, got it working (export project as metashape 1.4.X, open in old Photoscan, Recreate TiledModel)

Will get back here and report if the cesium-export works...  :-\

5
General / Re: Cesium 3d tiles not working in Cesium anymore
« on: March 12, 2020, 06:34:11 PM »
Hey Alexey,

We are using Version 1.55

6
General / Re: Cesium 3d tiles not working in Cesium anymore
« on: March 12, 2020, 04:21:38 PM »
Hey Alexey,

When exporting the tiled model to cesium, there are no parameters one could switch (greyed out, see screenshot).
The exported Zip-File has a size of 1.1 Gigabytes.

Should I provide you the export?

7
General / Cesium 3d tiles not working in Cesium anymore
« on: March 12, 2020, 03:36:10 PM »
In the currenct version of metashape, the cesium 3d tiles don't work in cesium anymore.

I have cesium-exports from Photoscan working (from 2018) which were exported the same way,
so I guess the export is broken somehow in the current version of metashape (1.6.2).

I can provide my export if needed, but a collegue gets the same results/problem with a different dataset,
so I guess it's a general problem.

Has anyone else the same problem? Has anyone got it woking with the current version of metashape?

thx for any advice, Chris

8
General / Re: some problems/questions
« on: March 12, 2020, 10:15:19 AM »
for question 2 I think I got an answer here:
https://www.agisoft.com/forum/index.php?topic=10518.0

though I am not completely happy with it.

9
General / some problems/questions
« on: March 10, 2020, 06:01:31 PM »
Hello community!

I got a few problems/questions, I hope you can point me in the right direction...

I have flown a school area with the drone and did the whole reconstruction process with metashape,
so far so good.

Now the goal is, to visualize two variants of new chimneys in the model.
Those were modeled seperately and have also been textured seperately.

Question 1: Is it possible in Metashape to view more than one model at a time?
When I import another model, I can only switch to the chimney, but cannot view them together to check
if the imported model is at the right place/height.
I realized it is only possible to merge the models together, but then the textures of my chimney is destroyed.

Question 2: I want to visualize the results in Cesium using our company GIS software.
The Cesium implementation only works with tiled models (3D tiles). I tried to load my chimney model
and create a tiled model.... without success. Errormessage is: "Cannot calculate pixel size". Any hint on this?

10
General / Re: Merging two pointclouds not working
« on: August 20, 2019, 10:00:11 AM »
So, now I tried the same with the latest build (1.5.4 Build 8885) and it worked without any problem!  ;D
Seems, there was a bug in the previous builds...

11
General / Re: Merging two pointclouds not working
« on: August 20, 2019, 08:54:25 AM »
Hey Alexey, Yes I have to confirm.
Now I also tried importing the clouds in a new empty project. This way, the two pointclouds are merged,
but not correctly. The points of the smaller cloud are somehow shifted (see screenshot).
Trying to merge the two pointclouds in my project doesn't merge at all.
However, I have to admin that I am currently using Version 1.5.2 build 7838.
Do you think it's worth trying out the latest Build?

12
General / Re: Merging two pointclouds not working
« on: August 19, 2019, 09:45:00 AM »
Hello Reservoirdog,

It would be helpful, if you could share the sample dense clouds that we can use to reproduce the problem and the report file exported from the project.

Hey Alexey, see the following Link for the two pointclouds, as well as the report:
http://31.171.149.140/sharing/KoTVFf8I5

13
General / Merging two pointclouds not working
« on: August 15, 2019, 04:43:36 PM »
I have a big pointcloud from an UAV project which has two tunnels where flying the drone was not possible.
So we captured points manually with a tachymeter (classic surveying). I imported these points in a separate "dense pointcloud",
which worked fine. Now I cleaned the big pointcloud in the areas of the tunnel and want to merge the tachy-points into the big pointcloud.
When I select both dense pointclouds and select merge, it seems to do it, but afterwards I cannot see the tachypoints in the merged pointcloud.
Also the numbers of points aren't correct (I would expect number of big pointcloud + my 155 tachy-points, but the numbers stay the same).
Any hint on how to bring "manually measured points" into a dense point cloud?

see screenshots, and also the log:
2019-08-15 15:13:46 LoadProject: path = Y:/Fislisbach_Birmenstorf_K418/Agisoft/Dense_TachyPoints.psx
2019-08-15 15:13:46 Loading project...
2019-08-15 15:13:47 loaded project in 1.332 sec
2019-08-15 15:13:48 Finished processing in 1.337 sec (exit code 1)
2019-08-15 15:23:37 MergeAssets
2019-08-15 15:23:37 Merging assets...
2019-08-15 15:26:10 Dense clouds have different color format, they are merged as RGB
2019-08-15 15:26:10 Finished processing in 153.912 sec (exit code 1)

14
General / Re: Digitizing Breaklines (Polylines) in Dense Pointcloud
« on: August 06, 2019, 04:59:49 PM »
Thx a lot for your tips,
Yep, I ended up digitizing the break lines directly on the DEM which worked really well.
After creating the lines I selected them, right-click update heights.
Next question: As of now, I think Metashape doesn't use the vector data (breaklines) for mesh-creation?
Would be great to have an option "use vector layer XXX as breaklines" at the mesh creation dialog.
That way metashape would create accurate Meshs having the triangles line up perfectly at the breaklines.

sidenote: the algorithm of VS (Virtual Surveyor) wasn't very good, also my edges didn't seem to be rough enough
for the algorithm to work correctly. The automatically detected brealines broke up pretty quick or weren't detected along the edge...

15
General / Digitizing Breaklines (Polylines) in Dense Pointcloud
« on: July 29, 2019, 12:46:56 PM »
Hello Photoscan/Metashape Community!

I am trying to create/digitize breaklines in the dense PointCloud.
That way, I can later produce a precise Mesh, where the breaklines are considered.
(I need a mesh from roads where the edges are precise - no trianlges going over the edges...)
However, when I am digitizing polylines in the dense pointcloud, the vertices aren't correctly picked.
I was trying to pick points from several views/directions, but the resulting polyline/breaklines always reside in the air (many centimeters above the actual points).
Is there any possibility to correctly pick points/vertices for the polylines? A sort of "snapping" would be convenient...
I will add some screenshots later to illustrate the problem...

Also: What is the general workflow to produce breaklines in Agisoft? Is there any?
I am testing VS (Virtual Surveyor) in parallel, but I would love to achieve theses tasks directly in Metashae/Photoscan....

Regards, Chris.

Pages: [1] 2