Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - juacarri

Pages: [1]
1
General / Re: Assign RGB to a multispectral point cloud
« on: November 25, 2020, 11:21:14 AM »
Hello juacarri,

It appears that the automatic mask for the calibration panel (on image IMG_0023) is not applied properly for the Green band, therefore if there are no additional calibration images closer to the flight by time used, the improper colors do appear.

So for this project I recommend either to fix the mask for IMG_0023 manually (for Green band) or to use IMG_0034 images for the reflectance calibration instead.
Thank you Alexey for your answer.

As a positive point, I took about 10 photos of the calibration panel before and after the flight, so there is no problem in this aspect. The question I have is how to know if the automatic mask of the calibration panel is correct or not, is there any way to know it before processing the point cloud? How would the mask be solved manually (for the green band)?

2
General / Re: Assign RGB to a multispectral point cloud
« on: November 23, 2020, 01:52:39 PM »
Hello juacarri,

I have processed the subset of images that you have provided in the version 1.6.5:

- add photos (multi-camera system approach),
- calibrate reflectance (detect panels, then use panel + DLS sensor for calibration),
- align photos,
- build dense cloud,
- build DEM,
- build orthomosaic.

The attached screenshot below shows the dense cloud and orthomosaic colors (with 500% brightness applied). There does not seem to be any noticeable difference in colors.

I followed this process with the photos provided. As you said the result is correct, the small dataset provided does not trigger any type of error. For this reason I was going deeper, this means that only some photos of all the dataset are affected. I attached again a different group of photos were this issue is detected:

https://drive.google.com/file/d/1fxRft8P5yUl2IpuwhMHGL-VYAf30eDZ7/view?usp=sharing

I'm so sorry for the previous dataset which it is totally correct.

3
General / Re: Assign RGB to a multispectral point cloud
« on: November 16, 2020, 11:43:02 AM »
Do you have any idea of the reason of this strange result of the reflectance calibration?

4
General / Re: Assign RGB to a multispectral point cloud
« on: November 09, 2020, 12:08:24 PM »
Hello juacarri,

Which version of Metashape you are using and whether you have any raster transformation applied?

Dear Alexey, recently I have try to process the same photos with the version 1.5.3 build 8469 (64 bits) in order to be sure that it was not a problem related with the version and I get the same results.

Dense point cloud with the reflectance calibrated:



With no raster transformation applied:



Dense point cloud without the reflectance calibrated:



I was expecting similar results in the visualization of the RGB colours, regardless the process of calibration. I cannot explain why after the reflectance calibration the point cloud get a "blue" colour.

5
General / Re: Assign RGB to a multispectral point cloud
« on: October 23, 2020, 04:00:53 PM »
Hello juacarri,

Probably you have generated the dense cloud before performing the reflectance calibration operation?

You can use Colorize Points option from the Tools Menu -> Dense Cloud section in order to apply the orthomosaic colors to the dense point cloud.

Hello Alexey,

I tried your procedure, but I got the same result in the visualization, a point cloud with blue colours. Here you can find a small dataset with some data, including some photos with the calibration panel, only to be sure that the photos are not the problem:

https://drive.google.com/file/d/1iETsh5RvNH9g40NOmz--9z-stY9rEw6U/view?usp=sharing

6
General / Re: Assign RGB to a multispectral point cloud
« on: October 20, 2020, 01:12:48 PM »
Any idea? :(

7
General / Re: Assign RGB to a multispectral point cloud
« on: October 14, 2020, 04:06:41 PM »
I add more information. When I view the orthophoto, the correct colours can be seen, but when I switch to the point cloud they are not.




8
General / Assign RGB to a multispectral point cloud
« on: October 14, 2020, 03:44:18 PM »
Hi! I'm trying to create a point cloud from images taken with a Micasense RedEdge camera, but once I perform the radiometric calibration, the RGB colors in the point cloud are modified to a false color. Do you know how to fix this?

I don't know if it is related with this issue, but if I export the dense point cloud normalized (applying the B1/32768 and so on formulas in the raster transform), the color values for the points are very low:


        X                            Y                      Z              blue      green          red         redEdge    IR
729012.768169 4393739.324077 227.843895 0.105255 0.149109 0.048462 0.243195 0.202972
729012.612752 4393738.960428 227.977216 0.061981 0.095306 0.028412 0.182037 0.185944
729012.839116 4393738.558298 227.977531 0.063629 0.097778 0.030914 0.183228 0.170929
729012.733558 4393738.435439 227.986485 0.064087 0.092926 0.031097 0.170258 0.168488
729012.144106 4393738.849464 227.941197 0.096130 0.146027 0.049622 0.236603 0.202454
729012.082371 4393737.394998 228.054853 0.112457 0.158722 0.048279 0.233826 0.188354
729012.310966 4393737.410769 228.049419 0.111267 0.162079 0.050140 0.243866 0.201782

Point cloud exported and visualized in CloudCompare:



9
Camera Calibration / Radiometric calibration before point cloud export
« on: October 17, 2019, 11:05:50 AM »
Hello, I'm working with the images from a Micasense RedEdge and I have a question about the workflow. Currently I'm doing the radiometric calibration as first step of the process, later I align the photos and immediately I densify the point cloud.

After the densification, I export the point cloud to a .txt file. Could you let me know if the colours exported are being radiometrically corrected before the export?

Thanks!

Pages: [1]