Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - cbnewham

Pages: 1 [2] 3 4 ... 8
16
General / Thumbnails take ages to load once processed
« on: April 19, 2021, 06:30:44 PM »
Has anyone else noticed how incredibly slowly the thumbnails load once the depth maps have been generated?

What's worse is that only a small number are loaded - if you scroll down, it forces more to load and the earlier ones disappear. It doesn't behave like this when the photos are initially loaded - everything is loaded super fast and always visible. It's been like this on every version up to the one I'm using (1.7.0) and I've always assumed it was a bug.

Is there any way to switch off this behaviour?

BTW, I have 64Gb of main memory in my machine, so I don't think that's the problem - task manager shows only 15Gb in use by everything.


17
General / Re: Higher Mp photos any beneficial ?
« on: April 19, 2021, 04:07:28 PM »
I would suggest standing a lot closer and covering the object in small sections. I expect that will be more beneficial than increasing the MP count.

18
I think you'll find that is the case.

However, there may be factors I'm not aware of.


19
Very good!

20
General / Re: Stitch vertical wall in 2D
« on: April 10, 2021, 12:26:18 PM »
Yes, that can easily be done.

Use Metashape to create a 3D model of the wall, then in a 3D modelling application use an orthographic camera perpendicular to the wall model to generate an image of the wall.

Your other option is to forego Metashape and just use a stitching program to tile the images - assuming they are taken face-on to the wall and the focal length of the lens is long enough / distance from the wall is great enough to reduce perspective effects.

The first option will generate a better result.


21
General / Re: reset selected cameras removes tie points
« on: April 08, 2021, 05:16:07 PM »
Do you mean the tie points are removed for all cameras?

If so, that doesn't sound right. You should be able to reset one camera or a group of cameras. I do that all the time.


22
General / Re: Align photos - Tie points ghosting
« on: March 04, 2021, 02:50:51 PM »
I sometimes get this.

I found that the best way is to select the points of the "ghost" (or secondary object) and reset the cameras for it. Then align just those cameras in small batches. It usually works in aligning the errant pictures with the correct ones.

If you select "details" for your images after selecting and resetting the images from the "ghost" (and then removing the filter, to see all of the images again), you can then order the results by "aligned" and realign just those images. I suggest doing it in small batches, otherwise you can sometimes end up with the "ghost" again. It appears to sometimes depend on the order in which the alignment is done. Sometimes you just can't get all to align correctly, in which case just discard those images causing the problem.

There have been rare occasions where I have had several "ghosts" and a really messed up sparse cloud, but with some careful use of the above technique, managed to correct all of the problems by doing multiple manual passes of aligning sets of cameras.

I hope this helps.

23
General / Re: What am I doing wrong? coins photogrammetry
« on: January 15, 2021, 10:55:53 PM »
I've done some close range work using macro lenses of objects smaller than your coin. You need to take some pictures from shallower angles, not just face-on. Treat it as a 3D object - that can be difficult because of reduce depth of field, but with enough pictures and some masking you should be able to reproduce it very accurately.

24
General / Re: Agisoft Metashape 1.7.0 pre-release
« on: January 07, 2021, 06:27:56 PM »
It's a shame that this feature isn't present in the Standard version as I've been hoping for something like this for years.  :'(

Mak

Seconded. a defocus mask feature is highly desirable.


25
General / Re: Agisoft Metashape 1.7.0 pre-release
« on: January 04, 2021, 03:43:41 PM »
Just to say that I've run the new version on a project with 2500 photos and it had no problems creating the depth maps or the mesh at Ultra-High.

Well done to everyone at Agisoft.

26
General / Re: Image acquisition problem with thin, sharp edges
« on: December 13, 2020, 09:38:15 PM »
I'd suggest photogrammetry is not the tool for this.

If I were doing it I'd image the individual components from above, take the pictures into Blender and then make very thin meshes that are textured from images, then combine them as a 3D model in the same way as the real one.

Sounds a lot of work - but then attempting to clean up meshes from photogrammetry of very thin objects sounds horrendous too - and probably with a less satisfactory outcome.

The only other way would be to increase the thickness of the carboard components, such as backing them with blu-tac or something.

Just a thought - others might have a better solution.

27
General / Re: Plans for detailed manual?
« on: November 27, 2020, 08:11:11 PM »
It would be lovely to have an up-to-date and detailed manual.

It seems the software is making great strides, but the documentation isn't keeping up

28
General / Re: Add new images to an already aligned chunk
« on: November 20, 2020, 07:44:32 PM »
I've noticed increases of time when adding photos and also worse accuracy compared to just starting the whole thing from scratch.

29
General / Re: Reduce overlap feature
« on: October 27, 2020, 09:10:06 PM »
This sounds good. I look forward to trying it out.

 :)

30
General / Re: Add new images to an already aligned chunk
« on: October 26, 2020, 11:40:42 AM »
Just add the photos and perform "align photos", making sure the "reset current alignment" checkbox is unchecked.


Pages: 1 [2] 3 4 ... 8