Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - LFSantosgeo

Pages: 1 ... 3 4 [5]
61
General / Re: Workflow and Errors
« on: November 30, 2017, 08:46:15 PM »

Further more from the order of alignment and markers importation to the chunks presented in the last post I have another (newbie) query about the referencing with GCP in Agisoft.

What about the difference among referencing only with GCPs and referecing GCP+photos checked? That gives a really small error difference (for control and check points) after updating and optimizing but still present in the total error. As expected the small error comes with the only GCP referenced cloud.

Could someone comment on it?


62
General / Re: Optimal settings for drone aerial photos
« on: November 29, 2017, 02:07:05 PM »
It depends on what you are planning to do.

But first: your photos were taken with overlap?

63
In my image, the blue dots are optimized. As you can see, the variance in altitude is a little bit lower, but it is still quite high and there is this hanging effect. What do you mean by messing with the EXIF data? I tried using unaltered EXIF reference altitudes before. They are around 40-50 meters, which is either above ground or above home, I'm not sure. Still the exact same problem of very high altitude variance and systematic bias after alignment and optimization.

What was your workflow with your photos?

64
General / Re: Units for gradual selection values
« on: November 28, 2017, 08:12:40 PM »
There's been many forum posts on this subject in the past. Not surprising considering the relative vagueness on this matter provided by the User Manual. There's some interesting discussions going on in the below posts:

http://www.agisoft.com/forum/index.php?topic=6888.0
http://www.agisoft.com/forum/index.php?topic=5585.msg27338#msg27338
http://www.agisoft.com/forum/index.php?topic=3559.0
http://www.agisoft.com/forum/index.php?topic=6684.msg32291#msg32291
I saw those posts and read carefully each one. But I'm unable to find any standard on how to operate the gradual selection parameters. Knowing the units would be a nice implementation for the next version of Photoscan.

I must admit though that I too am still unsure what the best workflow is. Although I have performed countless iterations, each time altering different parameters, I find there's sometimes very little or no observable effect. And even if there is an affect it is unclear what is explaining these effects as certain parameters seem to work well for some products, but not so much for others.

Could you share some of your findings in more detailed way?

I made some tests and without much effort I was able to improve my model accuracy even though not knowing how. The dense cloud seem to be affected in point numbers and total accuracy. As it is expected to as you eliminate the highest errors when filtering the sparse cloud.

65
General / Workflow and Errors
« on: November 28, 2017, 07:41:18 PM »
Hello!

I just made some tests with Photoscan when generating Sparse Cloud:

Workflow 1:
1. Add chunk
2. Add photos (155 photos)
3. Convert from WGS84 to my desirable one (mine is SIRGAS2000 UTM)
4. Align with highest accuracy and standard tie and key points limit (using 80.000/8.000) = gives 153 aligned cameras.
5. Import markers (*xml Agisoft Markers) [previously done with the same photos getting the lowest error possible]
6. Uncheck cameras and check the proper markers
7. Update & Optimize
8. Read the reference pane

This gives me control points error as 0.006623 and check points error as 0.031124.

Workflow 2:
1. Add chunk
2. Add photos (the same 155 photos)
3. Convert coordinates reference
4. Add markers (import)
5. Uncheck all photos in the reference pane
6. Align with the same previously parameters (highest/80,000/8,000) = gives 151 aligned cameras.

7. Update & Optimize
8. Read the results in the reference pane

This workflow 2 gives: control points error as 0.006235 and check points error as 0.030192.

So my questions are (despite quite small differences):
A) Alignment: does it gives different alignment every time I run Align photos...?
B) Referencing: does it matters the order to put or am I doing it wrong?
C) Shouldn´t give the same numbers of aligned cameras and error even though different ordered steps workflows?

The non-aligned cameras are those acquired with high vegetation (on both workflows) that I was already expecting difficult in the alignment.

Thanks in advance!

PS. My workflow was updated on post bellow!

66
Hello lfsantosgeo,

You can do it either via Python, or by modifying the doc.xml contents in chunk.zip and frame.zip archives inside the project.files structure.

Thank you Alexey for the help. I've changed the file path through the change path... in the photography pane. Nevertheless this would be a very easy way to change it too.

67
General / Re: Units for gradual selection values
« on: November 27, 2017, 04:46:26 PM »
Hi all,

Can anyone tell me what the units are for the values used in the gradual selection tool? As in, are these values errors in pixel distances, standard deviations, etc.

Thanks

Have you found out?

68
Hi

I need to change the filenames of several photos, used for different models.
If i change the filename in the windows folder, photoscan understandably complains : can't load image: C:/path..

Can it be done in some clever, preferably easy way, without having to batch rename all photos and redo all projects?
- The name of the files (photos) needs to be changed in the folders, not just the way they are displayed in photoscan..

example of content in the windows folder:

original name:   
DSC_7360.JPG   
DSC_7361.JPG   
DSC_7364.JPG   

Needs to be renamed to:
F2113.JPG
F2114.JPG
F2115.JPG



/R

Have you progressed in any way on this matter? In my case I have to change the file path to my photos...

69
General / Re: Import Markers
« on: November 27, 2017, 04:01:54 PM »
Hello, Alexey!

I'm trying as you said: to export the markers from the Tools > Export... > Export Markers and saving as a *.xml (Agisoft) file to be able to open on another project with the same photos (names, files extensions etc) just with a bit more contrast.

As I open a new project and with the new photos already opened on the process to import the markers in the reference panel I receive the following error message: "Can't import reference data!". Already tried to import the processed phtos on another chunk (on the same project) and got the same error message.

What am I doing wrong? Have to align the photos first?

Thank for any advice!
Luiz

Ok! Just got that from another forum post. Got to go to Tool > Import,,, > Import Markers. Not in the reference pane. Solved for me!

70
General / Re: Import Markers
« on: November 27, 2017, 03:53:04 PM »
Hello, Alexey!

I'm trying as you said: to export the markers from the Tools > Export... > Export Markers and saving as a *.xml (Agisoft) file to be able to open on another project with the same photos (names, files extensions etc) just with a bit more contrast.

As I open a new project and with the new photos already opened on the process to import the markers in the reference panel I receive the following error message: "Can't import reference data!". Already tried to import the processed phtos on another chunk (on the same project) and got the same error message.

What am I doing wrong? Have to align the photos first?

Thank for any advice!
Luiz

Pages: 1 ... 3 4 [5]