Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Mariusz_M

Pages: 1 [2]
16
Feature Requests / Lock photos/jobs/console window location
« on: January 27, 2021, 06:17:02 PM »
It would  be great to have a small paddlock icon on the photos/jobs/console window which would allow me for locking the windows in place as they are, so it would be impossible to acidently move them when masking photos.

17
Bug Reports / Avi file wrong duration when exporting animation in 4K
« on: January 27, 2021, 05:54:27 PM »
There is a problem in Metashape Standard version 1.66 (and probably 1.7.1, as there is no mention in the changelog about it) with generating AVI files in 4K. In 1080 I can easily export 2-minute MJPEG videos at 60 fps, but when I switch to 4K 60 fps I end up with a 15 GB AVI video that every program sees as 1 second long and it is impossible to convert. But the correct video stream is there and it plays normally on the build in Windows 10 player. It just has wrong duration and every converter stops converting after the first second.

18
Hi.

I am workng on a relatively small project for me, less than 2000 photos (I usually process bigger). Up until yesterday, everything worked smoothly under Metashape Standard 1.6.6. Then I updated to the newes release as suggested by the software. Since then I cannot process depth maps. Every time depth map generation is in progress, Metashape closes itself. But there is no error message in the log.

2021-01-06 21:40:35 [GPU 1] Camera 1694: level #4/4 (x4 downscale: 998x561, image blowup: 1996x1121) done in 1.331 s = 33% propagation + 61% refinement + 2% filtering + 0% smoothing
2021-01-06 21:40:35 [GPU 1] group 1/1: estimating depth map for 21/39 camera 1761 (40 neighbs)...
2021-01-06 21:40:37 [GPU 1] Camera 1761 samples after final filtering: 89% = 100% - 2% (not matched) - 1% (bad matched) - 0% (no neighbors) - 2% (no cost neighbors) - 5% (inconsistent normal) - 1% (estimated bad angle) - 0% (found bad angle) - 1% (speckles filtering)
2021-01-06 21:40:37 [GPU 1] Camera 1761: level #4/4 (x4 downscale: 998x561, image blowup: 1996x1121) done in 1.159 s = 33% propagation + 60% refinement + 3% filtering + 0% smoothing
2021-01-06 21:40:37 Peak VRAM usage updated: Camera 1761 (40 neihbs): 507 MB = 160 MB gpu_tmp_hypo_ni_cost (32%) + 128 MB gpu_neighbImages (25%) + 34 MB gpu_depth_map (7%) + 34 MB gpu_cost_map (7%) + 34 MB gpu_coarse_depth_map_radius (7%) + 34 MB gpu_coarse_depth_map (7%) + 25 MB gpu_normal_map (5%) + 12 MB gpu_neighbMasks (2%) + 12 MB gpu_tmp_normal (2%) + 8 MB gpu_mipmapNeighbImage (2%)
2021-01-06 21:40:37 [GPU 1] group 1/1: estimating depth map for 22/39 camera 1762 (38 neighbs)...



Windows event log shows only a general application crash, nothing speficic. But is has something to do with: C:\WINDOWS\System32\ucrtbase.dll.



I have tried on other similar projects and the result is the same - a quiet unexpected crash.
I have just tried on a project that has 58 cameras and everything worked. So the problem might have something to do with the number of cameras.

You might need my system info:

2021-01-06 21:59:02 Agisoft Metashape Standard Version: 1.7.0 build 11736 (64 bit)
2021-01-06 21:59:02 Platform: Windows
2021-01-06 21:59:02 CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (desktop)
2021-01-06 21:59:02 CPU family: 6 model: 60 signature: 306C3h
2021-01-06 21:59:02 RAM: 32.0 GB
2021-01-06 21:59:03 OpenGL Vendor: NVIDIA Corporation
2021-01-06 21:59:03 OpenGL Renderer: GeForce GTX 980M/PCIe/SSE2
2021-01-06 21:59:03 OpenGL Version: 4.6.0 NVIDIA 460.89
2021-01-06 21:59:03 Maximum Texture Size: 16384
2021-01-06 21:59:03 Quad Buffered Stereo: not enabled
2021-01-06 21:59:03 ARB_vertex_buffer_object: supported
2021-01-06 21:59:03 ARB_texture_non_power_of_two: supported

2021-01-06 21:59:11 Found 1 GPUs in 0.095 sec (CUDA: 0.02 sec, OpenCL: 0.075 sec)
[/i]

I wish I could give you  more specific information, but there is no info whatsoever what is wrong. It just stops working while processing depth maps on bigger projects that worked with no issues for many years under previous versions.

Please fix the problem as soon as possible. For now I have downgraded Metashape to 1.6.6 until this issue is resolved. If you want me to test some tweaks on 1.7 I kept it as well. I can test some things out as long as I have clear instructions from you.

19
Bug Reports / Impossible to switch off markers in Standard Edition
« on: March 03, 2020, 04:15:29 AM »
Hi. I have a project that was initially made with the Pro eIition and now I loaded it back into Standard edition. The project has a few makers I no longer need, but they seem to be impossible to hide/remove in the Standard version. Can you please add an option to hide/remove markers under the Standard Edition?

20
Every time I want to quickly capture view I need to remember to switch off info, region, trackball and all other stuff that is needed for editing, but not always for publishing. It would be nice if show/hide switches/tickboxes were as options in the Capture View window.

21
Feature Requests / Remove duplicate camers
« on: January 06, 2020, 04:59:13 PM »
When working witch chunks and merging I often end up having duplicates of the same cameras. I would like to have a button to quickly ane easily remove duplicate cameras from the project.

So I think an option to find and compare duplicates is needed. It would display a list of photos that are used more than once within one project with their preview and info about:
1. Tie points (with preview)
2. Key points from this photo (with preview)
3. Location in 3d space with preview.

There are a few situations to consider before removing a duplicate:

1. When the duplicate camera has exactly the same key points/tie points - simple remove of the duplicate
2. When the duplicete camera has different key points/tie points  - option to choose which ones to keep or to merge key points/tie points
3. When the duplicate camera has different masks - option to choose or merge
4. When the duplicate camera is not exactly in the same place - option to chose which location to keep or to move remainging camera somewhere in between the  current duplicates are (based on some weight calculated using projection/reprojection errors) . After removing duplicates it would be recommended to run camera optimisation again.
5. Probably something else, but sorting out these 4 situations would be a good beginning.

22
When I finish my project or when I want to move it to another computer, I end up manually checking if I have all the necessary files included and if the paths are correctly saved.


 I would love to have an option to easily save the whole thing in in one folder. It would help when:
1.  I want to easily archive the project and save it onto a different drive knowing that if I ever come back to it, it will just work.
2. I want to move the whole project to another computer.



What I meen by "the whole thing" is:

1. Metashape project file and all the required files for all chunks (as it already is).
2. All photos used in the project (by copying them from their original location to a subfolder "photos". There should also be an option to remove the photos from their original locations, so there are no duplicates left).
3. All paths to the new location of the photographs.
4. All information about photo groups.
5. In case the photos are extracted from a video, there should also be an option of including the original videos.
6. Everything else that you might think would also be needed....


23
Feature Requests / Romove disabled cameras option
« on: January 06, 2020, 04:16:14 PM »
Some times I end up disabling many cameras for various reasons - too many to begin with, too blury, too little details... Anyway, when I finish processing my projects I would like an option to permanently remove all the cameras that are already disabled, because these are the cameras I do not need any more. Then I can make my archived projects so much more optimised.

24
Feature Requests / GPU processing - on/of switch in the process window
« on: January 06, 2020, 04:09:21 PM »
With every version you introduce a GPU support for more and more processes and this is great. However, sometimes they produce results different than expected. Although this is usually fixed later on with new versions, the easiest way so far to temporarily avoid problems has been manually switching off GPU in options. But is not the best solution, as it swiches off GPU for all processes, including theones that work much faster on GPU. So please please add to each GPU-accelerated process a tick box "use GPU" which would be ticked by default if GPU acceleration is switch on in options. But when I wanted to I would be able to easily switch GPU off for a specific process only. Also, please add this option for each process in batch processing, so I would be able to created a queue that is mostly GPU-accelerated with some exceptions for processes that currently work better on CPU.

25
Feature Requests / Pins to lock photos, console and jobs panels
« on: January 06, 2020, 03:56:52 PM »
Hi. Every time I mask something I end up accidently closing the bottom panels. I understand that some people may want to move them from time to time or close them. However, please introduce a pin at the bottom on each panel. When the panel is pinned, it will be impossible to close. If someone wants to close it or move it, they have to un-pin it first.

26
Just updated to the newest build 1.6. The chunks that needed 40 - 60 minutes for texture generation in the previous versions, now need over 2 hours. For some reason GPU accelerated process works slower than non-GPU before. I have Nvidia Geforce 980M and so far with every update all GPU-accelerated processes have always worked much faster than non-GPU. This time it is different. Why?

27
Hi. Sometimes I use 1000 of photos and when I see the sparse cloud I know that my model will look great and I do not need so many photos. I would probably do with 500 and it would decrese the time needed for processing.

So in that case instead of manually disabling every second photo, I would love to have a button that will open a window and let me select every second (third/forth/fifth.. etc.) photo for me, so I can disable them quickly. This would be very helpful for projects where I start with over 4000 photographs.

Pages: 1 [2]