Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bassistas

Pages: 1 [2] 3
16
Bug Reports / Re: Sketchfab upload from version 2 not working
« on: March 19, 2023, 05:46:29 PM »
Hello bassistas,

Do you mean loading to laser scans to Metashape or uploading them to Sketchfab?

Can you share the log related to the operation, including Metashape starting lines?

I mean loading laser scans to Metashape, but I finally resolved the issue. I checked the log and I had to save the project in psx format first for large laser scans.


17
Bug Reports / Re: Assertion "3478972301441" failed at line 720
« on: March 19, 2023, 05:42:03 PM »
Its not resolved, I still get the Assertion failed error in 2.0.2  :-\

18
Bug Reports / Re: Sketchfab upload from version 2 not working
« on: March 15, 2023, 12:30:59 AM »
I am using the 2.0.1.15925 version and when I'm trying to load some laser scans which are with a high density point cloud (1/2 resolution from a Faro focus scanner) I get a "not enough memory" error. I have 128GB ram and free disk space but still does the same every time i try to load the scans. I also tried  from another pc with similar specs and I still get the same exact error. Is this a bug?

19
General / Re: Agisoft Metashape 2.0.0 pre-release
« on: January 15, 2023, 06:38:19 AM »
Hello, I have imported some laser scans using the new option but as some of them don't contain colour and only intensity Metashape doesn't show any image from these (in grayscale) so I can't add any markers to improve the alignment of the photos from the camera.  Is there any solution to this?

20
Bug Reports / metashape 1.8.5. corrupt frame.zip
« on: December 22, 2022, 01:58:00 AM »
Hello!
I'm using metashape 1.8.5 and for some reason, the frame.zip suddenly got corrupted. I didn't have any power loss or blue screen, I just saved the project normally through the save button and I closed the program. When I tried to open it again I got this error message: Can't locate zip directory , Error: Can't open archive:  ....../frame.zip. I tried to open the frame.zip manually but I got an error that says it's corrupted.
Is there any way to recover my project? I have spent hundreds of hours manually placing markers on thousands of photos to be able to have a successful alignment with photos and laser scans and I also had the model ready for export with textures but now I can't access it. Is there a way to recover at least the model? thanks

21
General / Re: Agisoft Metashape 2.0.0 pre-release
« on: October 19, 2022, 06:00:05 PM »
Dear bassistas,
It would be helpful, if you can share the sample data (your E57 file).
If you are able to share the data, please send the download link to support@agisoft.com

Here is a link to a sample e57 file https://drive.google.com/file/d/1KXlUsAUTf8BV-qOzeN3-cm3G11Q7WFNA/view?usp=sharing
Please let me know if you are able to reproduce the problem.

22
General / Re: Agisoft Metashape 2.0.0 pre-release
« on: October 19, 2022, 11:28:28 AM »
Hello bassistas,

Do you use Import Depth Images or Import Point Cloud for E57 files? Also can you share the processing log related to the file import (enable Write Log to File option in the General Preferences tab and try to reproduce the issue)?


I'm using the import point cloud option for the E57 files. Here is my log file, I don't see any errors, it just crashes:

2022-10-18 18:29:52 ImportPointCloud: path = D:/Faro scene projects/arnaia scans 1-10-2022/Faro scene Gerovasiliou/e57 export/gerovasiliou_Gerovasiliou000.e57, format = PointCloudFormatE57, crs = Local Coordinates (m), shift = [0, 0, 0], precision = default, point neighbors = 28, use trajectory (origin)
2022-10-18 18:29:52 Working in temporary directory D:/temp//import_points.tmp.11
2022-10-18 18:29:52 Importing point cloud in memory. Save project in .psx format for big file import.
2022-10-18 18:29:52 Importing point cloud...
2022-10-18 18:29:53 Analyzing points...
2022-10-18 18:29:53 processing 68983239 points...
2022-10-18 18:30:45 Calculating normals...
2022-10-18 18:30:45 Required 25.9399 GB RAM for extended block
2022-10-18 18:30:45 Available: 80.6923 GB
2022-10-18 18:30:45 Using extended block
2022-10-18 18:30:45 Using 32 threads
2022-10-18 18:30:45 Expected max memory usage: 25.9399 GB
2022-10-18 18:31:17 computed normals in 32.536 sec

I just tried to export the laser scans in another format (pts) and now they are loading without any errors but it takes a lot of time to load as the files are double the size now.
So maybe there is a bug with the e57 format.
Now I'm stuck on the "reset current alignment" option which is not active (greyed out) and if I proceed with the alignment it doesn't align the photos with the scans.

23
General / Re: Agisoft Metashape 2.0.0 pre-release
« on: October 18, 2022, 06:44:07 PM »
Hello bassistas,

Do you use Import Depth Images or Import Point Cloud for E57 files? Also can you share the processing log related to the file import (enable Write Log to File option in the General Preferences tab and try to reproduce the issue)?


I'm using the import point cloud option for the E57 files. Here is my log file, I don't see any errors, it just crashes:

2022-10-18 18:29:52 ImportPointCloud: path = D:/Faro scene projects/arnaia scans 1-10-2022/Faro scene Gerovasiliou/e57 export/gerovasiliou_Gerovasiliou000.e57, format = PointCloudFormatE57, crs = Local Coordinates (m), shift = [0, 0, 0], precision = default, point neighbors = 28, use trajectory (origin)
2022-10-18 18:29:52 Working in temporary directory D:/temp//import_points.tmp.11
2022-10-18 18:29:52 Importing point cloud in memory. Save project in .psx format for big file import.
2022-10-18 18:29:52 Importing point cloud...
2022-10-18 18:29:53 Analyzing points...
2022-10-18 18:29:53 processing 68983239 points...
2022-10-18 18:30:45 Calculating normals...
2022-10-18 18:30:45 Required 25.9399 GB RAM for extended block
2022-10-18 18:30:45 Available: 80.6923 GB
2022-10-18 18:30:45 Using extended block
2022-10-18 18:30:45 Using 32 threads
2022-10-18 18:30:45 Expected max memory usage: 25.9399 GB
2022-10-18 18:31:17 computed normals in 32.536 sec

24
General / Re: Agisoft Metashape 2.0.0 pre-release
« on: October 17, 2022, 07:40:46 AM »
Hello, I just tried this pre-release version and when I try to load any e57 laser scan the program crashes and closes after some minutes of loading without any error. The e57 files are structured and they are exported from the Faro Scene.  Does anyone know why this happens?

25
General / Re: TLS Laserscans - Registration incorrect
« on: October 11, 2022, 08:25:17 PM »
You must define the tls as fixed.

To do this, click the checkboxes for position and rotation (only tls) before the camera orientation.

Where do I find these checkboxes? Also do I need to run the quicklayout script first?

26
General / Re: TLS Laserscans - Registration incorrect
« on: October 10, 2022, 09:44:02 PM »
Hello Dieter,

In 1.8.4 release (published yesterday) when you add pre-processed laser scans from TIFF files (all at once) they will be added as multi-camera system, but during the alignment the relative orientation of the sensors in the system will be preserved (just to not enable adjust rotation/location for the slave cameras in the Camera Calibration dialog).

This approach is an intermediate solution, as in future major Metashape updates the concept of the laser scans will be revised. But I hope that it could at least partially work for your needs.

I've tried this method and I get a successful alignment but the orientation of the model is wrong. How Can I keep the orientation of the laser scans? (rotation/location for the slave cameras is unchecked)

27
General / mesh generation extremely low cpu and gpu usage
« on: August 03, 2022, 05:44:24 PM »
Hi guys,
I'm trying to create a mesh from 50 laser scans and 2788 (50mpixel) photos but after the generation of the depth maps the CPU and GPU usage is dropping to almost 0-3% and only the disk usage activity hovers around 30-40mb/sec as you can see in this screenshot. If I leave it like that the estimated time starts to explode and shows 8 to 10 days or more which is extreme for such an amount of data and the hardware I use. Is this a metashape bug? I'm using the latest 1.8.4 build.

28
General / Re: overexposed textures problem
« on: May 16, 2022, 06:27:36 PM »
Also I just tried now to disable the 8bit jpeg photos and try to create textures again with just the grayscale 32bit laser scans and it still produces the "overexposed" effect. So it seems there is some kind of a bug unless there is an option to adjust this somewhere.

29
General / Re: overexposed textures problem
« on: May 16, 2022, 04:15:46 PM »
I expect just 8bit output. So is there a problem if you combine 8bit images with 32bit laser scans tiff images? Should I convert my 8bit jpegs also to 32bit in order to avoid this "overexposed" effect?

30
General / Re: overexposed textures problem
« on: May 16, 2022, 04:03:36 PM »
Hello bassistas,

What color range (bit depth) the input photos and laser scans have?

As for the blank spots, I would suggest to mask out no-data regions on the images related to the laser scans prior to the texture generation stage.

Hello, the jpegs are 8bit and the grayscale laser scans are 32bit. Could this be the problem? and what can I do?

I also tried to mask out the no-data regions from the laser scans and it solved the black hole issue but as this black area has the same height in the lower part of the image in all of my laser scans is it possible to mask out this automatically from all the scans with a script rather than doing it by hand for every single scan?

regards

Pages: 1 [2] 3