Forum

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bgreenstone

Pages: 1 [2] 3 4 ... 7
16
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 27, 2021, 04:51:31 PM »
I just ran 2 batches and both had pretty bad blobs on the underside.  One in particular had them *really* bad - it's unusable geometry, so I'll have to process both of these in 1.7.3 for now.

17
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 27, 2021, 04:34:00 PM »
The new filtering functions have certainly helped with 98% of the giant blobs of extraneous geometry that earlier versions put underneath meshes, but the new version still generates a lot of this stuff in every scan.  It's almost always tiny, disconnected blobs so they're easily removed in Blender, but still, they shouldn't be there, and in 1.7.3 and earlier you never get these. 

In this screenshot from blender you can see all of the small blobs of geometry in orange.

18
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 27, 2021, 05:32:57 AM »
I think those test photos were from an iPhone X.  Not sure if he used the 2x or normal lens.  If it’s the normal wide angle lens then 19cm is about right.

19
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 27, 2021, 04:13:40 AM »
I think most shots were maybe 2-3’ away.  Why?

20
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 27, 2021, 03:25:39 AM »
Thanks, Paul.  Actually there's no digital Zoom.  That 2x is a bug that I reported a while back.  It seems if you use any of the Zoom lenses on an iPhone it gets reported as 2x (even though my iPhone 13 is 3x).

It's interesting that it worked for you because like I said before, everything was working fine until just a few days ago.  It's like something broke that's causing this, but I don't know what.  I suppose I could delete everything and reinstall it, however, I'm not entirely sure where Metashape stores all of its settings and such.

-Brian

21
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 26, 2021, 11:46:47 PM »
Here's an example of what I'm now getting almost 100% of the time when using Generic Preselection.  I have uploaded the test files and the batch.xml here:  https://www.dropbox.com/sh/vq9871ija9we1r4/AADT5ajSgePUN1A-e5X9xpNJa?dl=0

In the screenshots you can see what looks like a flap going diagonally thru the main part of the scan.  Sometimes it's diagonal like that, while other times it's almost parallel.  If I run this exact same test through 1.7.3 with Generic Preselection it works fine, but on 1.8 it does this.  Turn off Generic Preselection and it comes out fine.

Like I said before, this just started doing it a few days ago.  I never had this happen with 1.9 using this same Batch previously.

22
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 26, 2021, 11:03:53 PM »
Another new anomaly has started happening a few days ago.  Suddenly, almost 100% of my scans have incorrect sparse clouds and meshes.  What happens is I get an "echo" of the scan in the resulting data.  Difficult to explain, and I have not been keeping the bad ones to show you, but next time it happens I'll upload a photo and samples.

After a few hours of experimenting I believe I have found the problem to be with Generic Preselection because as long as I have that OFF it works fine, but with it ON I'm getting these garbled scans almost every time.  The strange thing is that this only suddenly started happening.  I've always used Generic Preselection and it was working fine until maybe 4 days ago.  Nothing else changed here - no change in other settings, and nothing particularly different about the photos I'm scanning.

Anyway, just a head's up on that.  I'll send samples later.

-Brian

23
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 25, 2021, 04:50:51 PM »
Alexy,

It appears that *any* photo I take with an iPhone 13 with the flash *Off* causes this.  I just took several random photos of an object as a quick test and it immediately gave me the same issue.  Here are the test photos:

https://www.dropbox.com/s/rb9jiws07que2fs/iphone13.zip?dl=0

It seems that the iPhone 13 automatically embeds depth information in all JPEG's as long as the flash is turned off, and Metashape 1.9 Basic doesn't have a simple way to ignore that information.

Thanks,

-Brian

24
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 25, 2021, 02:30:00 AM »
I’m using Standard.  Sounds like this could be a bug with it since there’s no way to prevent it from doing this.

25
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 25, 2021, 01:30:42 AM »
Try following the tutorial and using Import Laser scans to import the images to the chunk... You should get the rgb images along with the depth maps which can be useful for building model, dem,....

I'm not seeing an Import Laser Scan option in the File menu as that web page says.  Looked everywhere and I don't see how to do it.  Normally, I just drag & drop the folder of JPEGs onto the Chunk.

-Brian

26
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 25, 2021, 01:04:24 AM »
Hi bgreenstonae,

is this a depth map camera? which stores depth map along with image....? Maybe look at following tutorial https://agisoft.freshdesk.com/support/solutions/articles/31000162212-smart-cameras-with-depth-sensor-data-processing to see if you can import thee special images  using Import Laser Scans .... command.


Ah, this may be the case.  I only recently got my iPhone 13 and most of my scans were from photos using the flash.  This set of JPEGs were shot without a flash, so I guess it embedded some depth info in there.

But how do I tell Metashape to ignore that data?  I didn't see a way to do anything other than import all of it and then manually delete all of the black & white depth images.

27
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 24, 2021, 11:31:12 PM »
Ok, something I've never seen happen before just happened.  I was creating a new Chunk from 64 JPEG files that I shot with my iPhone 13.  For some reason it decided that these photos were multilayer files (I didn't think JPEGs could be multilayer), so it bought up a dialog box asking if I wanted to add 128 cameras to one chunk or create 64 chunks with 2 cameras each.  Bizarre.

When I loaded them in each JPEG showed as the normal color photo along with a black and white version of it.  I have no idea what that black and white version is.

So, then I ran 1.7.3 to see if the same thing happened there and it did not.  It just loaded the JPEGs normally.

Any ideas?

-Brian

28
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 21, 2021, 08:37:02 PM »
Just did another small Batch test on a 2 Chunks and it seems to have worked correctly.  The only annoying issue I'm still seeing is that if I leave the room my Mac will go to sleep after 15 minutes and this cause the Batch to pause.  Metashape should be calling UpdateSystemActivity(OverallAct); every few seconds to prevent the Mac from going to sleep while it's working.  Otherwise, I have to keep moving the mouse to prevent the Mac from dozing off and pausing Metashape.

29
General / Re: Agisoft Metashape 1.8.0 pre-release
« on: December 21, 2021, 04:31:26 PM »
Last night I did a test with 3 chunks in a batch and it seemed to work properly.  I’ll try more today to confirm.

30
Bug Reports / Metashape stops when Mac sleeps
« on: December 18, 2021, 06:48:16 PM »
A problem I have with 1.7.3 (the version I use most of the time) is that the application doesn't prevent the Mac from going to sleep while Metashape is working.  So, if I run a Batch and leave the room I often come back to find my Mac asleep.  When I wake it I see that Metashape has stopped where it was when the Mac dozed off (usually after 15 minutes since that's what I have it set to in System Settings).  Metashape then continues once the Mac is awake. 

This can be prevented with a single like of code:

UpdateSystemActivity(OverallAct);

I don't know if the later versions of Metashape already do this, but if not, that line of code needs to be called every ~30 seconds from a NSTimer function.  This will prevent the Mac from going to sleep while Metashape is working.



Pages: 1 [2] 3 4 ... 7