Forum

Recent Posts

Pages: 1 ... 3 4 [5] 6 7 ... 10
41
Hi, you can enable show grid in MS(menu Model - Show/Hide Items) and then manually rotate and translate model somewhere near [0,0,0](two crossed lines in grid)...it does not need to be perfectly aligned with XY plane. Then export 3d model to blender, do cleaning and export back to MS.
42
Python and Java API / Re: Camera Rig configuration through Python API
« Last post by ilia on June 29, 2022, 10:38:58 PM »
After the whole day of experiments I'm still wondering how to properly to set all values.
For an example ms.Sensor.Reference.location_enable is read-only attribute.

I just can't figure out how to pass all information I have about relative camera positions in Metashape from Python API.
All I need is to set cam1, ..., camN extrinsics relative to cam0. And I just don't understand how.
All I was able to achieve is install "Adjusted Parameters".
I would like to understand several things if possible:
1. May I not optimize relative position of camera sensors? From GUI I don't see such opportunity as it switches off all reference fields if I switch off "adjust location" checkmark at slave sensor.
2. If it's not possible, I would like to install reference values with really small accuracy values to prevent them from being optimized. And again. I can't just match what I see in Python API document and GUI.

I guess I need some help.
Just in case: my goal is to load precalibrated information in Metashape to improve the quality of the reconstruction. And do it from Python script. Intrinsics were installed without any issues. But extrinsics keep giving me a headache as I can't understand how do they match to the ones I see in GUI. I see that I can install slave offsets there, but I still don't understand how I can operate on reference values as they seem as readonly.
43
Hey everyone I know a lot of people struggle with this so I'm trying to find a solution that works for people exporting their objects from MS and cleaning them up in Blender.  I usually do this, and the object from MS comes in not at the 0,0,0 with no rotation which would be soooo ideal and save a lot of time because when you want to export out that object you can just do it from the center of the coordinate system instead of trying to figure out where in 3d space the object came in as.

I usually clean up in Blender then export back into MS to bake the higher quality textures back..

I may be missing something simple in MS, but man this has annoyed me for years.  Can we get something like Blender has that snaps the object to the center etc..

What are people doing and again sorry If i missed a simple export setting to do this. 
44
Camera Calibration / Re: lens calibration improvement
« Last post by forumname on June 29, 2022, 06:40:28 PM »
Thank you Alexey, I am sending an email. I use 3-5 images of varying quality to understand the lens calibration pipeline.
45
General / Loosen up requirement for matching with manually places markers
« Last post by Tobi_Passau on June 29, 2022, 03:49:09 PM »
Hello,

the manual says: "Set markers (at least 4 per images) on these images and indicate their projections on at least two
images from the already aligned subset.".

I can't. The images were shot with too little overlap and the area I have to do is no longer accessible for me. Is there any way to it with only one already aligned image?

Greetings
46
Bug Reports / Re: Shapes are not visible on 3D model
« Last post by Alexey Pasumansky on June 29, 2022, 01:45:30 PM »
Hello Geodetec,

If you are drawing the shapes in the Model view in the project where no aligned cameras are present, make sure that Attach Markers option is disabled in Tools Menu -> Markers section.
47
Bug Reports / Re: Shapes are not visible on 3D model
« Last post by Geodetec on June 29, 2022, 09:11:24 AM »
Hello,

I created my polygons in model view while snapping directling on the dense cloud.

Best regards

48
Bug Reports / Re: VK Error when creating textures in 1.8
« Last post by ruudstelten on June 29, 2022, 06:12:47 AM »
Alexey,

Do you know when GPU-based texturing on Apple M1 will be available in Metashape? The entire process is super fast on M1, but texturing using CPU only takes a long time...

49
Bug Reports / Re: Shapes are not visible on 3D model
« Last post by Paulo on June 29, 2022, 05:59:06 AM »
Hello Geodetec,

did you create the polygons in ortho view or model view?

If the polygons are created in ortho view (without dtm) then they will be 2d and thus cannot be displayed in model view. Same applies if you import 2d polygons to your project.

Best is to dram polygons in model view (with dense cloud or mesh) and then they will be 3d....

Maybe this is the issue....
50
General / Re: Dense Point Cloud Gaps
« Last post by Jholland on June 29, 2022, 05:09:51 AM »
Hi Alexey,
I've attached images with the alignment parameters resulting point cloud after edits, the coverage of the aligned photos, and a close up of the thumbnails which seem to coincide with the gaps. 
Thanks
James   
Pages: 1 ... 3 4 [5] 6 7 ... 10