Forum

Author Topic: bad allocation  (Read 419 times)

szhu0

  • Newbie
  • *
  • Posts: 18
    • View Profile
bad allocation
« on: December 11, 2018, 08:46:51 PM »
I have version 1.4.4, running on a 64bit OS with 16 GB RAM. Built a dense point cloud with 870 drone images at ultra high quality, mild depth filtering for 2 days and 7 hours. Processing time does not matter to me, I just want high quality DEMs. I got an error for "bad allocation" which I think means "not enough RAM." How do I fix this? A few things I am going to try are below. Which might be the problem?
- I am currently running off of a 4TB external hard drive. I am moving y files to the computer and will try running agisoft from those files
- I will reduce the number of images processed (maybe I will break it up into 300 image chunks)
- I read something about changing the settings for GPU vs CPU nodes. Is this something I should do? How do I do that?

Thanks

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 9917
    • View Profile
Re: bad allocation
« Reply #1 on: December 11, 2018, 08:51:42 PM »
Hello szhu0,

To reduce the memory consumption you can enable Fine-level task distribution in the Network Preferences tab or limit the number of pairs to be considered during the dense cloud filtering in case of excessive image overlap in your project (see related tweak setting: http://www.agisoft.com/forum/index.php?topic=9294.msg43358#msg43358).

If you want to utilize the hard drive, then you should enable swapping in the OS settings. Maybe it is the best option, as 16 GB might be not sufficient for ultra quality reconstruction.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

szhu0

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: bad allocation
« Reply #2 on: December 11, 2018, 09:58:27 PM »
Hi Alexey,

Thank you for your speedy reply. What do you mean by "enable swapping in the OS settings?"
Will fine-level task distribution reduce my dense point cloud resolution/quality?
Would reducing the number of images processedd at once help? Instead of processing 900 images, I process 300 images?

Also, I have
CPU: Intel (R) Core (TM) i7-7700 @ 3.60 GHz
GPU: GeForce GTX 1050 Ti, 6 compute units, 4096 MB global memory, compute capability 6.1

With this, would I want to change my preferences to use my GPU device and uncheck "Use CPU when performing GPU accelerated processing"?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 9917
    • View Profile
Re: bad allocation
« Reply #3 on: December 16, 2018, 05:51:20 PM »
Hello szhu0,

In Windows, for example, you can enable paging file creation that can be used in case of insufficient RAM by the applications. It can be done via System Properties - > Advanced - > Virtual memory section.
Reducing the number of images would also help to reduce the memory consumption. But also I recommend to enable Fine-level task distribution option.

And as for "use CPU" flag, I suggest to disable it and enable your GTX card.
Best regards,
Alexey Pasumansky,
AgiSoft LLC