Forum

Author Topic: Linux Metashape, start fails  (Read 313 times)

Simon_

  • Newbie
  • *
  • Posts: 11
    • View Profile
Linux Metashape, start fails
« on: January 18, 2019, 01:18:10 PM »
Hello,
the following error comes up, when startin Metashape 1.5.0:
Code: [Select]
QOpenGLWidget: Failed to create context
composeAndFlush: makeCurrent() failed
composeAndFlush: makeCurrent() failed
composeAndFlush: makeCurrent() failed

System:
Ubuntu 18.04 bionic

What OpenGL Version is needed in order to run metashape?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 10302
    • View Profile
Re: Linux Metashape, start fails
« Reply #1 on: January 18, 2019, 01:23:01 PM »
Hello Simon,

Are you starting it via ./metashape.sh?

Also are you working locally or via any kind of remote connection?
Best regards,
Alexey Pasumansky,
AgiSoft LLC

Simon_

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Linux Metashape, start fails
« Reply #2 on: January 18, 2019, 03:12:15 PM »
Quote
Are you starting it via ./metashape.sh?
Yes

Quote
Also are you working locally or via any kind of remote connection?
No, sitting in front of the machine.


Interesting fact: I had the same issues with Photoscan 1.4.1.

Restarting the machine solved the issue...
I did some upgrades in that session, which I cant reproduce anymore...

Have a nice weekend!

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 10302
    • View Profile
Re: Linux Metashape, start fails
« Reply #3 on: January 18, 2019, 03:33:18 PM »
Hello Simon,

OK. If the problem will re-appear, please let me know and provide the glxinfo output and information regarding the graphic card model and method of GPU drivers installation.

Best regards,
Alexey Pasumansky,
AgiSoft LLC