Forum

Author Topic: No Depth-Map for Fisheye-Lens?  (Read 473 times)

Björn

  • Newbie
  • *
  • Posts: 3
    • View Profile
No Depth-Map for Fisheye-Lens?
« on: May 28, 2018, 08:05:33 PM »
Hello Community,

I am not sure if this is a bug or a mistake of mine. Anyway, if I try to export the depth-map of an image captured with a fisheye-lens i get an almost black image. I can see some white spots at the edges but thats all. That said, the normal-map and diffuse-map seems to be okay. Also, if i preserve the depth map from the dense-point-cloud-generation I can see a correct depth map in the photos pane.

I also noticed that if i want to export the undistorted image, the image gets even more distorted.

I use Agisoft Photoscan Standard Version 1.4.2 build 6205 (64 bit)

Thank you and best regards,
Björn

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 9899
    • View Profile
Re: No Depth-Map for Fisheye-Lens?
« Reply #1 on: July 09, 2018, 12:43:16 PM »
Hello Björn,

Can you please check if the problem persists in the version 1.4.3?

The "export depth" option is saving the depth based on the distance from the sensor plane to the reconstructed mesh surface, maybe there's something special in the mesh structure - some polygons might be too close to the sensor plane, so the distant surfaces are scaled by large factor?
Best regards,
Alexey Pasumansky,
AgiSoft LLC

Björn

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: No Depth-Map for Fisheye-Lens?
« Reply #2 on: February 11, 2019, 11:32:36 AM »
Thank you for the reply and please excuse my late reply. I think it is my calibration data that is far off. So I assume there is no bug in Photoscan/Metashape whatsoever. Thank you very much.