Forum

Author Topic: Please fix the standard installers  (Read 4286 times)

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Please fix the standard installers
« on: March 01, 2019, 08:34:47 AM »
The installers for the standard edition of Photoscan/Metashape have been borked on my system since v -1 -3 -2.
The .msi fails and reports a key in an unknown location that cannot be overwritten. There is no way I can troubleshoot an error code like that.
I suspect that the issue may be with the 1-3-2 install as Windows cannot uninstall, repair or reinstall the application and every subsequent installation has failed.
It would be nice to bring the application up to date.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Please fix the standard installers
« Reply #1 on: March 01, 2019, 02:34:54 PM »
Hello bbuxton,

Are you observing similar problems when trying to install both 1.4 and 1.5 versions of Standard and Professional edition?

It seems more like the OS issue (maybe Windows Installer is broken), then the MSI failure, according to the searching on this issue in the Internet.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Please fix the standard installers
« Reply #2 on: March 01, 2019, 04:55:03 PM »
Thank you Alexey
yes every installer since v1-3-2 has failed to install. I have not found anything about this issue that would suggest it is an OS issue. I have plenty of other applications on this system that use .msi and they install, update and uninstall just fine. This is looks like a permissions issue specific to that install. I don't know how to fix it because I do not know what the installer is trying to access that causes the issue.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Please fix the standard installers
« Reply #3 on: March 01, 2019, 05:34:31 PM »
Hello bbuxton,

We have not received any similar feeedback from other users (even if there were a few, which I might do not know about), which indicate that we do not have corrupted installer, otherwise there would be quite a lot of complains and reports from Windows users.

Anyway, can you locate the following address in the system registry (regedit.exe):
Code: [Select]
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\620139E0B929C2837B208B4B3039995E\77451E1067830394886BEA87DEC0D340Right-click on the key, select 'Permissions' from the context menu and grant full access to this folder. Then check the box to allow the same permission to be granted to this key's sub-folders (descendants). After that try to re-install PhotoScan or Metashape.

Some similar cases with other applications, according to my search for "could not open key unknown components", suggests to follow the instruction from Microsoft:
https://support.microsoft.com/en-us/help/313222/how-do-i-restore-security-settings-to-a-known-working-state

Can you please check, if any other these approaches help?

You can also try to remove the mentioned registry key (you can back-up it in advance), create a new one with the same name and try to run the installer again.

Also please check if Windows\system32\msvcr100.dll file exists, if not then you may need to install corresponding package of Microsoft Visual Studio Redistributable.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Please fix the standard installers
« Reply #4 on: March 03, 2019, 04:56:33 PM »
Thank you Alexey
I have finally managed to get Metashape to install but attempting to launch the application locks up my system during the licensing process. Task manager cannot end the processes and eventually bluescreens requiring a hard shutdown via the power button. However, I have finally managed to uninstall 1.3.2 and install v 1.4.5 so that's an improvement

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Please fix the standard installers
« Reply #5 on: March 04, 2019, 12:32:42 PM »
Hello bbuxton,

Have you noticed, which message is shown in the Blue screen before the computer reboots? Usually it contains the error message and related driver/dll which helps to identify the issue. In most cases blue screen is related to hardware/driver issues.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Please fix the standard installers
« Reply #6 on: March 04, 2019, 02:16:35 PM »
Hello bbuxton,

Have you noticed, which message is shown in the Blue screen before the computer reboots? Usually it contains the error message and related driver/dll which helps to identify the issue. In most cases blue screen is related to hardware/driver issues.

Hello Alexey
I don't get to see anything. The PC will lock up solid while the black licensing window appears. I have no way to interact with the PC other than to hold down the power button for hard shut down. Windows reports the machine did not shut down properly due to Bluescreen on booting following the crash.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Please fix the standard installers
« Reply #7 on: March 04, 2019, 04:41:16 PM »
Hello bbuxton,

Is there's anything informative in Windows Event manager dialog (see the related link here: https://www.agisoft.com/forum/index.php?topic=10507.msg47792#msg47792)?
Best regards,
Alexey Pasumansky,
Agisoft LLC

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Please fix the standard installers
« Reply #8 on: March 05, 2019, 03:23:03 PM »
Hello Alexey
The event manager just shows a critical error for the system freeze as 'improper shutdown' and before that the permissions error I fixed in regedit.
For now v1.4.5 has licensed and is working. As curious as I am about the performance improvements for Metashape, I have to stick with what is working now.
Perhaps I will try again with a future update.

Mak11

  • Sr. Member
  • ****
  • Posts: 372
    • View Profile
Re: Please fix the standard installers
« Reply #9 on: March 06, 2019, 04:55:58 AM »
Frankly your only "solution" would be to restore/format/re-install your current Window installation because, as Alexey has said, nobody else has ever reported this sort of  issue with the Photoscan/metashape installer so it definitely must be coming from your current in OS install.

Mak

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Please fix the standard installers
« Reply #10 on: April 03, 2019, 12:15:28 PM »
Thanks Mak, your expert solution is just what I need.
Look I have all kinds of 3D, CAD and design applications on my system all running perfectly fine. If there was something wrong with my system I would imagine that I would have run into issues with other applications too.  It is a little bit lazy to put the onus on the user and claim there must be something up with your system. Clearly, there is something wrong with Metashape to completely lock up my computer. I cannot quit the application or use the task manager after launching. The only way to kill the process (Metashape) is to kill the power not ideal under any circumstances.



Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14107
    • View Profile
Re: Please fix the standard installers
« Reply #11 on: April 03, 2019, 03:05:28 PM »
Hello bbuxton,

We do not have the reports from users that the only way to close PhotoScan 1.4 or Metashape 1.5 is to turn off the power. But definitely it is not a way we have assumed and suggested.

What I can suggest: deactivate PhotoScan/Metashape license, uninstall the application, remove any related records from the Windows registry, then try to install latest Metashape version again.
If there are still issues with the installation, activation, starting the program, processing, closing the program, please send the message to support@agisoft.com with the link to this thread and new information describing the error messages and observed behavior.
Best regards,
Alexey Pasumansky,
Agisoft LLC

bbuxton

  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: Please fix the standard installers
« Reply #12 on: May 20, 2019, 06:24:24 AM »
My apologies for waiting so long to reply but to finish my project I just ran Agisoft on MacOs. On switching back to Windows I uninstalled Kaspersky and the software licensed without a hitch. It seems simply turning off protection is not enough. Kaspersky is messy to uninstall too. Any advice on what to do before reinstalling Kaspersky would be very welcome.