Forum

Author Topic: Issue with markers import : loosing image coordinates  (Read 1561 times)

denis_f

  • Newbie
  • *
  • Posts: 10
    • View Profile
Issue with markers import : loosing image coordinates
« on: September 25, 2018, 03:28:59 PM »
Dear all, dear developers,

I face the following issue : I have a multi-chunk project. These chunks share some data (images) and are used to test different processing strategies.
I have markers - surveyed by GPS - that I already pointed in all images. I exported these markers.
When I import back the exported file to another chunk, markers GPS positions are imported but the image positions are lost.

Are there some explanations for this behaviour and, hopefully, solutions ?

Many thanks in advance,

Denis

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: Issue with markers import : loosing image coordinates
« Reply #1 on: September 25, 2018, 05:45:13 PM »
Hello Denis,

It seems that you are saving the markers via Reference pane. This option only exports the referencing coordinate information (source / estimated / errors), but not the markers' projections on the source photos. For such purposes you should use File Menu -> Export -> Export Marker -> XML format option.

Please specify, if you are observing the problem with the XML data import and if so, then also specify, if the camera labels in the both chunks are identical.
Best regards,
Alexey Pasumansky,
Agisoft LLC

anabento

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Issue with markers import : loosing image coordinates
« Reply #2 on: March 08, 2019, 11:02:48 PM »
Dear Sis,

In line with the procedure to export the Markers information (from the file menu), I would like to know if:


- When I import the same .xml file in a new project, with the same photographs as in the previous project, will the new dense cloud (and consequent DEM) be influenced by the other data, produced during the first project (and included on the .xml file)?

When I opened the xml file outside agisoft I noticed that there are more information besides the markers'location and values.

Thanks in advance

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13913
    • View Profile
Re: Issue with markers import : loosing image coordinates
« Reply #3 on: March 12, 2019, 06:15:53 PM »
Hello anabento,

Loading markers in XML format via File Menu should load the markers' projections on the source images and coordinate information to the Reference pane.
Best regards,
Alexey Pasumansky,
Agisoft LLC