Forum

Author Topic: CL_BUILD_PROGRAM_FAILURE (-11) at line 614  (Read 1875 times)

Geodez

  • Newbie
  • *
  • Posts: 2
    • View Profile
CL_BUILD_PROGRAM_FAILURE (-11) at line 614
« on: April 20, 2019, 06:33:33 AM »
здравствуйте. Переустановил windows на версию 10, до этого все было в порядке на версии 8.1. При попытке выровнять фотографии возникает вышеуказанная  проблема. Прошу помочь с вариантами устранения.

2019-04-20 08:16:14 Agisoft PhotoScan Professional Version: 1.4.0 build 5076 (64 bit)
2019-04-20 08:16:14 Platform: Windows
2019-04-20 08:16:14 CPU: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
2019-04-20 08:16:14 CPU family: 6 model: 58 signature: 306A9h
2019-04-20 08:16:14 RAM: 32.0 GB
2019-04-20 08:16:15 OpenGL Vendor: ATI Technologies Inc.
2019-04-20 08:16:15 OpenGL Renderer: Radeon RX 590 Series
2019-04-20 08:16:15 OpenGL Version: 4.5.13541 Compatibility Profile Context 25.20.14003.2000
2019-04-20 08:16:15 Maximum Texture Size: 16384
2019-04-20 08:16:15 Quad Buffered Stereo: not enabled
2019-04-20 08:16:15 ARB_vertex_buffer_object: supported
2019-04-20 08:16:15 ARB_texture_non_power_of_two: supported
2019-04-20 08:16:15 Using simple console. Rich console can be enabled in Preferences dialog.
2019-04-20 08:17:12 Loading photos...
2019-04-20 08:17:12 Finished processing in 0.258 sec (exit code 1)
2019-04-20 08:17:24 AlignPhotos: accuracy = High, preselection = generic, reference, keypoint limit = 40000, tiepoint limit = 4000, constrain features by mask = 0, adaptive fitting = 1
2019-04-20 08:17:24 Detecting points...
2019-04-20 08:17:25 Using device: Ellesmere, 36 compute units, 8192 MB global memory, OpenCL 2.1
2019-04-20 08:17:25   max work group size 256
2019-04-20 08:17:25   max work item sizes [1024, 1024, 1024]
2019-04-20 08:17:25   max mem alloc size 4048 MB
2019-04-20 08:17:25   wavefront width 64
2019-04-20 08:17:25 Building kernels for Ellesmere...
2019-04-20 08:17:25 Device 1
2019-04-20 08:17:25    Program build log:
2019-04-20 08:17:25 Error: HSAIL doesn't support OpenCL extension spir.
2019-04-20 08:17:25 An invalid option was specified.
2019-04-20 08:17:25 Error: BRIG code generation failed.
2019-04-20 08:17:25
2019-04-20 08:17:25
2019-04-20 08:17:26 [CPU] photo 0: 40000 points
2019-04-20 08:17:26 Finished processing in 1.425 sec (exit code 0)
2019-04-20 08:17:26 Error: CL_BUILD_PROGRAM_FAILURE (-11) at line 6

доп инфо.:
снял сейчас галочку с gpu и все заработало, только теперь, карта видимо не участвует в обработке. Скорее всего проблема в драйверах видео. Прошу помощи
« Last Edit: April 20, 2019, 06:44:10 AM by Geodez »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14014
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 614
« Reply #1 on: April 20, 2019, 02:00:45 PM »
Добрый день,

Попробуйте, пожалуйста, обновить программу до версии 1.5.2 (https://www.agisoft.com/downloads/installer/) и проверить, корректно ли работает обработка на GPU в ней.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Geodez

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: CL_BUILD_PROGRAM_FAILURE (-11) at line 614
« Reply #2 on: April 20, 2019, 03:05:01 PM »
да, после обновления все заработало. Спасибо большое