Forum

Author Topic: Reconstructing camera positions.  (Read 91 times)

Jamie

  • Newbie
  • *
  • Posts: 1
    • View Profile
Reconstructing camera positions.
« on: June 12, 2019, 06:30:35 PM »
Hi,

Many years ago now, I created heads in Image Modeler, a product subsequently bought by Autodesk then discontinued, RIP. From 8 photos I could hand place markers and relatively quickly establish the camera positions, this was then exported to a 3D program and low polygon heads were manually reconstructed from this data. Obviously, this is not a standard workflow but it was a great solution for the job and I wanted to do this again in Metashape.

Metashape is not working in the same way, I have placed far more markers than I used in Image modeler and the image reconstruction is awful. Now the reason for this is probably insufficient numbers of images but for triangulation purposes, I thought this would work. Is there some fundamental difference in the way Image Modeler and metashape work that makes this process impossible?

Here are some shots, the face is masked where I expect movement between shots (single camera).

Thank you.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 10294
    • View Profile
Re: Reconstructing camera positions.
« Reply #1 on: June 14, 2019, 09:42:16 PM »
Hello Jamie,

Can you share the problematic image set, project in PSZ format with added masks and markers, so that we could reproduce the problem and see, how it could be avoided?
Best regards,
Alexey Pasumansky,
AgiSoft LLC