Forum

Author Topic: inconsistant camera parameters exported from photoscan v1.2 and photoscan 1.4.4  (Read 1438 times)

wangyanru

  • Newbie
  • *
  • Posts: 6
    • View Profile
In photoscan v1.4.4,    when I use the xml format camera parameters exported from  from photoscan v1.2   ,the  dense cloud point can not be reconstructed correctly.


Is there any difference between  photoscan v1.4.4 and  photoscan v1.2 ?and how can i correct the camera xml file from v.1.2 to v1.4.4?
 

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13918
    • View Profile
Hello wangyanru,

Can you please provide the XML file that you are using for import (from the version 1.2)?
Best regards,
Alexey Pasumansky,
Agisoft LLC

wangyanru

  • Newbie
  • *
  • Posts: 6
    • View Profile
This is the xml exported from v1.2 , and when I use the same pictures in v1.4, and wanna import the cameras xml to build dense point cloud, it failed,reconstructed nothing

wangyanru

  • Newbie
  • *
  • Posts: 6
    • View Profile
here is the version change log,but I can not figure out what is the detailed format change, I wonder this may be the bug source?



• Changed type of format argument in Chunk.importCameras() and Chunk.exportCameras() methods to CamerasFormat

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13918
    • View Profile
Hello wangyanru,

The main changes related to the calibration format between versions 1.2 and 1.5 are the following:
f_new = fy
b1_new = fx - fy
b2_new = skew
cx_new = cx - width/2
cy_new = cy - height/2
p2_new = p1
p1_new = p2
Best regards,
Alexey Pasumansky,
Agisoft LLC

wangyanru

  • Newbie
  • *
  • Posts: 6
    • View Profile
Thank you for your reply! It is really useful !!! ;D