Forum

Author Topic: imort E57  (Read 1713 times)

Dieter

  • Full Member
  • ***
  • Posts: 111
    • View Profile
imort E57
« on: August 14, 2019, 12:36:26 PM »
When reading an e57 file from Recap, the coordinates contained in the file are ignored in agisoft.
Exporting from recap and reading in pts format works.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12944
    • View Profile
Re: imort E57
« Reply #1 on: August 14, 2019, 03:40:58 PM »
Hello Dieter,

Can you please send the examples of E57 and PTS files for the same project that show a different behavior on import? Please also specify the import parameters used in Metashape (if you are selecting non-default coordinate system option).
Best regards,
Alexey Pasumansky,
Agisoft LLC

Dieter

  • Full Member
  • ***
  • Posts: 111
    • View Profile
Re: imort E57
« Reply #2 on: August 14, 2019, 05:27:06 PM »
Here is the link for download. All Files are imported with local coordinates and original recap-exports.

In cloud-compare the coordinates are both exact.

https://www.dropbox.com/s/acss8p070v9t89d/Test_e57_and_pts.zip?dl=0

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12944
    • View Profile
Re: imort E57
« Reply #3 on: August 14, 2019, 09:37:14 PM »
Hello Dieter,

Thank you for sharing the problematic data. We were able to observe the problem on import and will try to fix it as soon as possible.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Dieter

  • Full Member
  • ***
  • Posts: 111
    • View Profile
Re: imort E57
« Reply #4 on: August 15, 2019, 10:05:33 AM »
Thank you  :D

Jonnie tgraph

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: imort E57
« Reply #5 on: December 20, 2019, 01:09:48 PM »
I also had this problem - registered point clouds / scans imported but registered coordinates ignored and original (ie scanner at origin) coords used instead.

My .e57 data contained 59 scans and was exported from Leica Cyclone.

My solution was to import the .E57 into Cloud Compare, then export it again to .E57 - this reduced the file size from about 9 GB to about 7 GB, removed all the points that had been cleaned (ie masked out but still present in the .E57 file), and set the coordinates to the correct registered ones. It now imports fine.

Hope this is helpful

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12944
    • View Profile
Re: imort E57
« Reply #6 on: December 20, 2019, 02:00:13 PM »
Hello Jonnie,

Can you please check if you are still observing the problems with the original point cloud files in the latest 1.6.0 pre-release (build 9760) - https://www.agisoft.com/forum/index.php?topic=11331.0
Best regards,
Alexey Pasumansky,
Agisoft LLC