Forum

Author Topic: Extrange behaviour when exporting a Dense Cloud to LAS  (Read 2501 times)

Isaac H. E.

  • Newbie
  • *
  • Posts: 34
    • View Profile
Extrange behaviour when exporting a Dense Cloud to LAS
« on: October 14, 2019, 03:19:16 PM »

Hi All,

I'm wandering if someone else has seen this behavior when exporting a dense cloud to LAS file format...

I have a dense cloud within a Metashape Pro v. 1.5.5.9097 containing 327 821 323 points that has been created from a normal photogrammetric workflow, in other words it's not imported in to the project from external sources...

When I export the after mentioned point cloud I end up with a LAS containing 184 445 978 points even though I have not decimatied the cloud. Because the results where estrange to me I decided to doublecheck the point count with two different softwares, CloudCompare and Quick Terrain Reader and they both agreed.

Then I have tried to export other Metashape point clouds and the result seems to be consistent, my exported LAS files contain less points than my original Metashape cloud, is this the intended behavior?

Best regards

Isaac

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14765
    • View Profile
Re: Extrange behaviour when exporting a Dense Cloud to LAS
« Reply #1 on: October 15, 2019, 05:01:39 PM »
Hello Isaac,

Is the number of points that you mention displayed in the Workspace pane? Does it help to use Update Dense Cloud option from the Wotkspace pane context menu?

Also please specify, if the point clouds have been generated in the latest Metashape version or  they are from older PhotoScan versions?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Isaac H. E.

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Extrange behaviour when exporting a Dense Cloud to LAS
« Reply #2 on: October 15, 2019, 08:12:20 PM »

Hello Alexey,

Yes, you are correct, the Metashape point count that I'm referring to is the number that appears in the bottom left corner of the Model window or the number right besides the Dense Cloud in the Workspace pane.

No, using Update Dense Cloud option from Workspace pane context menu does not help, after running it the point count in the Workspace pane does not change, still is 327 821 323

Yes, the dense point cloud that I'm working with was generated with Metashape 1.5.5.9097

Please don't ask me to share the dataset, due confidentiality reasons I can't do that.

Best regards

Isaac

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14765
    • View Profile
Re: Extrange behaviour when exporting a Dense Cloud to LAS
« Reply #3 on: October 16, 2019, 01:00:13 PM »
Hello Issac,

Does the bounding box include the complete point cloud that you are exporting?

If so, can you please check the number of points in the export log - does it correspond to the source number of points in the dense cloud?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Isaac H. E.

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Extrange behaviour when exporting a Dense Cloud to LAS
« Reply #4 on: October 16, 2019, 03:14:52 PM »

Hello Alexey,


Many thanks for your help! I seem to have found what was causing this behavior.


The reduction of points in the exported point cloud was caused because I had an "outer boundary" drawn in the DEM / Orthomosaic view which caused the exported cloud to be trimed to the extent of my area of interest.


Many thanks once more and sorry for the inconvenience.


Isaac