Forum

Author Topic: Clouds from the same dataset don't align  (Read 1536 times)

cdviana

  • Newbie
  • *
  • Posts: 1
    • View Profile
Clouds from the same dataset don't align
« on: October 23, 2019, 05:40:16 PM »
Hi!

I'm doing some testing with the latest version of Metashape Pro, and found a problem that I can't understand.

I have a set of 83 images and 6 GCPs, which were manually identified in all of them (more than 20 images per point). I generated the sparse cloud with the Lowest alignment (generic and reference preselection enabled) and the dense cloud in all categories in sequence. Then I generated a new sparse cloud, with the option to reset the alignment, to Low, and again the dense cloud in all categories. I redid this for all alignment options, always with the same settings. The dense clouds were exported in local coordinate system (because with the correct UTM projection option the generated clouds were a line of points...I didn't understand this either).

When loading clouds in CloudCompare or Meshlab, only the clouds that aligned to Lowest correspond to the actual coordinates of the control points used, the others are shifted and rotated without consistency.

I put a sample image in the attachment. The purple points are my GCPs, the best fit cloud is the Lowest alignment and the other is Medium alignment.

Can anyone help me understand what is going on? It is the first time I see this kind of problem in 5 years!! I really need this to work because it is part of my PhD  :-\

Thanks!


Update: made the same tests - dataset, GCP, options - with Pix4D and the generated dense clouds align perfectly!

redid the clouds in Metashape without the GCP and the alignment problem persists even without references
« Last Edit: October 25, 2019, 09:25:05 PM by cdviana »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14014
    • View Profile
Re: Clouds from the same dataset don't align
« Reply #1 on: October 29, 2019, 05:11:03 PM »
Hello cdviana,

Can you please share the project in PSZ format with the alignment results and placed markers with support@agisoft.com? You can include several chunks to the project if they represent the similar issues.

To reduce the file size I suggest to remove the depth maps and dense clouds from the duplicated project workspace.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14014
    • View Profile
Re: Clouds from the same dataset don't align
« Reply #2 on: October 29, 2019, 09:53:16 PM »
Seems that the problem has been resolved by applying the coordinate information to the chunk by pressing Update button on the Reference pane.

Also when exporting to MeshLab it is suggested to use XY offsets to avoid truncation of the decimals for the point coordinates.
Best regards,
Alexey Pasumansky,
Agisoft LLC