Forum

Author Topic: Textures and uv mess  (Read 106 times)

Amit

  • Newbie
  • *
  • Posts: 5
    • View Profile
Textures and uv mess
« on: November 07, 2019, 11:30:44 AM »
Hi

I scanned an ancient brick wall . images quality is good. most of them sharp and all aligned properly

the texture stage took 5 hours and the result is a serious mess in the UV (instead of the 20 min it usually takes for such quality, but that maybe make sense because so many bricks are popping out and all of them need to be 3d unwrapped)

win 10 updated
meta shape standard 1.5.4 8885 64bit
RTX 2070
120 ram
tr 2950x

the photo shows a zoom in on the wall. the rest of it is similar.

is this a known bug? is there a way to solve this?
« Last Edit: November 07, 2019, 11:32:30 AM by Amit »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 10838
    • View Profile
Re: Textures and uv mess
« Reply #1 on: November 07, 2019, 12:40:26 PM »
Hello Amit,

Can you please send the screenshots of View Mesh UVs dialog and also specify the mesh generation parameters used?
Best regards,
Alexey Pasumansky,
AgiSoft LLC

Amit

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Textures and uv mess
« Reply #2 on: November 07, 2019, 06:43:24 PM »
Hello Alexey thank you

Data attached, is this what you meant?

Amit

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Textures and uv mess
« Reply #3 on: November 07, 2019, 06:44:49 PM »
part 2
dense and mesh


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 10838
    • View Profile
Re: Textures and uv mess
« Reply #4 on: November 07, 2019, 06:52:58 PM »
Hello Amit,

You wouldn't get good texturing results when mesh is generated with the interpolation disabled. There are a lot of isolated mesh components in your model, so the number of texture atlas charts is extraordinary and their size is very small (therefore the atlas fill ratio is less than 1%).

I can suggest to use Enabled interpolation option.  Also it may be reasonable to use smaller number of polygons in the model, unless you have a possibility to operate 50M polygons.
Best regards,
Alexey Pasumansky,
AgiSoft LLC

Amit

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Textures and uv mess
« Reply #5 on: November 07, 2019, 07:19:00 PM »
Thanks for reply

I will do it again with interpolation enable. is there a way to make sure metahsape does not try to connect large areas? (like it sometimes creates an entire "round floor" under everything,  because interpolation enabled).

the high polycount is to have the best normal map possible. fewer polygons catch less details judging from some tests I made before decided what levels to use.

Maya live retopology is working smoothly with these numbers (with this pc),  until now i had no problems

Amit

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Textures and uv mess
« Reply #6 on: November 10, 2019, 03:47:51 AM »
Than you Alexey that fixed the issue and made the texture time go back to normal (17 min)
I have also changed my settings to depth maps + mild for construction