Forum

Author Topic: only integrated GPU in use  (Read 2407 times)

Magda

  • Newbie
  • *
  • Posts: 29
    • View Profile
only integrated GPU in use
« on: January 31, 2020, 07:49:15 PM »
I'm processing data in Agisoft PhotoScan 1.4.5, laptop that I'm using has two GPU:
-GeForce RTX2080 max-Q
-Intel UHD Graphics 630

For calculation Dense Cloud Agisoft  never use RTX2080, in Nvidia Control Panel i set preference graphic card to RTX but that doesn't help.

Anyone know how to force Agisoft PhotoScan to use much more powerful graphic card?


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14003
    • View Profile
Re: only integrated GPU in use
« Reply #1 on: January 31, 2020, 09:07:07 PM »
Hello Magda,

It would be helpful, if you also specify the current processing stage and provide the screenshot of the expended details section of the progress dialog to understand, whether the current stage is assumed to use GPU or not.

As for the graphs in the Windows 10 Task Monitor on the left side of the window, are you able to provide any reference links where it is clearly described, what mean the percentage for those graphs? I recommend to open the full page related to each GPU and switch one of the graphs for your NVIDIA card to "Cuda" option and check the utilization of the GPU, providing that the current stage is GPU-supported.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Magda

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: only integrated GPU in use
« Reply #2 on: February 18, 2020, 11:20:03 PM »
I'm on building dense cloud step - reconstruction depth.  My integrated GPU engine work almost at 100% while Nvidia Geforce is not used at all.

I think those percentages show the Utilization of each GPU.

" I recommend to open the full page related to each GPU and switch one of the graphs for your NVIDIA card to "Cuda" option and check the utilization of the GPU, providing that the current stage is GPU-supported." - how i can do that? can you provide some advice how to accomplish that?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14003
    • View Profile
Re: only integrated GPU in use
« Reply #3 on: February 19, 2020, 12:05:33 AM »
Hello Magda,

Click on GPU label in the left side of the Windows Task Monitor to open detailed view of NVIDIA GPU, then switch one of the shown graphs to "Cuda" option.

Actually, for optimal performance it is not recommended to enable integrated GPU and "use CPU" flag, if at least one powerful GPU is used.
Best regards,
Alexey Pasumansky,
Agisoft LLC