Author Topic: Unexpected Error on Startup  (Read 2632 times)


  • Newbie
  • *
  • Posts: 16
    • View Profile
Unexpected Error on Startup
« on: June 16, 2022, 05:34:40 PM »

When opening Metashape (this error started a couple of weeks ago), I have been getting this error:
`Unexpected error occurred.
Details: System clock has been set back (-40)
This causes Metashape to not be activated, and I cannot activate it manually either. I have done some research and found that it is an issue with License managers where a file somewhere in the filesystem is corrupted or the time of the file has been modified, however I haven't had any luck fixing this. I have tried searching for files modified in both the future and way back in the past and modifying the dates, I have also tried repairing my Ubuntu install, nothing has been successful. I have only noticed errors with Metashape. Other than reinstalling ubuntu does anyone have any suggestions on fixing this error?



Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14927
    • View Profile
Re: Unexpected Error on Startup
« Reply #1 on: June 16, 2022, 06:38:54 PM »
Hello Mitchell,

Do you observe that with the trial or permanent license? If it is a trial, please create the offline activation request file according to the following instruction and send it to

Add the reference to this forum thread in the email body, so that we could assist you with the problem.
Best regards,
Alexey Pasumansky,
Agisoft LLC