Forum

Author Topic: Export Tiled Model - Cesium  (Read 1754 times)

jmgc

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Export Tiled Model - Cesium
« on: February 26, 2020, 07:58:29 PM »
When exporting a tiled model to Cesium 3D Tile format, the options from the export window appears greyed out.
I'm unable to change the reference system.
Is this standard - and if it is, why? Or I'm missing something?
« Last Edit: February 26, 2020, 08:15:58 PM by jmgc »
José Miguel Campos
Geospatial Specialist
UAS Operations Manager

Chani

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Export Tiled Model - Cesium
« Reply #1 on: January 14, 2022, 02:19:49 PM »
I have also noticed this and can only assume it is a bug as it ruins the exported models' position. This is also still greyed out in version 1.8

I have to go back quite a few versions to get one where the 3D tiles export works correctly (1.6.6 or 1.7 maybe).

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13812
    • View Profile
Re: Export Tiled Model - Cesium
« Reply #2 on: January 14, 2022, 03:07:10 PM »
Hello,

Cesium 3D tiles can be exported only in WGS84 coordinate system.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Chani

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Export Tiled Model - Cesium
« Reply #3 on: January 14, 2022, 05:08:03 PM »
I want it to be in the correct coordinates system but when I go to export (since quite a few versions ago), it shows the coordinate system as 'Local Coordinates' and it is greyed out so we cannot change it to WGS84. It does not appear to default to that as when I export it, it is not where it should be. It has moved and when I pan, rotate or zoom in Cesium, the model vanishes.

My workflow involves importing a 3d model into a blank chunk and then converting that to 3D tiles and manually geolocating it in WGS84 with the basemap active.
As I say, this workflow used to work. Now I have to install an old version when I need to do this process.

cyrilp

  • Jr. Member
  • **
  • Posts: 57
    • View Profile
Re: Export Tiled Model - Cesium
« Reply #4 on: January 19, 2022, 02:08:51 AM »
I have the same issue, the cesium 3d tiles don't work and i don't know why. If i upload the obj to cesium, the converted 3d tiled works fine, but if i use the 3D tiled from metashape something is wrong. This is an issue as the storage is limited on cesium...

Chani

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Export Tiled Model - Cesium
« Reply #5 on: January 24, 2022, 02:46:02 PM »
I have the same issue, the cesium 3d tiles don't work and i don't know why. If i upload the obj to cesium, the converted 3d tiled works fine, but if i use the 3D tiled from metashape something is wrong. This is an issue as the storage is limited on cesium...

If you revert back to version 1.7.0 then the Cesium export works correctly since it defaults to the correct WGS 84 coordinate system and not the local coordinates that the later versions seem to default to on export.

It's a bit of a pain having to switch versions all the time but it is the only way I have found to get Cesium tiles working again.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13812
    • View Profile
Re: Export Tiled Model - Cesium
« Reply #6 on: January 26, 2022, 12:35:31 PM »
Hello Chani,

For Cesium 3D Tiles format "local coordinates" option will appear if you export tiled model from non-georeferenced projects, "WGS84" will appear when the tiled model is exported from georeferenced project. In both cases coordinate system selection cannot be changed.

If you have an example of the georeferenced project created in 1.8 version where from you cannot export Cesium tiles in WGS84 coordinates, please share that project (without source photos) to support@agisoft.com.
Best regards,
Alexey Pasumansky,
Agisoft LLC