Forum

Author Topic: UV packing in 1.6.2 is broken  (Read 2211 times)

wojtek

  • Sr. Member
  • ****
  • Posts: 275
    • View Profile
UV packing in 1.6.2 is broken
« on: March 03, 2020, 02:03:44 PM »
Here is a comparision between UVs coming from 1.6.2 and 1.6.1.

The packing is way too sparse in 1.6.2 - it gets fill ratio of 43% vs 67% on the same mesh in 1.6.1.

I appreciate all the recent development but you guys change things that catch us by surprise during production (this was not mentioned in the change log)


Can we Please have any control over how the packing is done at least via tweak value?

Marcel

  • Sr. Member
  • ****
  • Posts: 309
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #1 on: March 03, 2020, 03:03:35 PM »
I want to voice my support for a parameter or version setting so we can control the UV packing, that would be very useful.

Mak11

  • Sr. Member
  • ****
  • Posts: 368
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #2 on: March 05, 2020, 01:17:02 AM »
I skipped v1.6.1 so I can't really compare against 1.6.2 but the drop in packing % I'm seeing between 1.6 & 1.6.2 ( roughly 10%) isn't a drastic as what wojtek is seing (and I usually tweak it afterwards in RyzomUV if necessary anyway). Having more control over UV parametrization (& also over baking parameters) would be a plus.

Mak

wojtek

  • Sr. Member
  • ****
  • Posts: 275
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #3 on: March 05, 2020, 03:07:00 PM »
I skipped v1.6.1 so I can't really compare against 1.6.2 but the drop in packing % I'm seeing between 1.6 & 1.6.2 ( roughly 10%) isn't a drastic as what wojtek is seing (and I usually tweak it afterwards in RyzomUV if necessary anyway). Having more control over UV parametrization (& also over baking parameters) would be a plus.

Mak

The denser the mesh the smaller fill rate I'm getting on 1.6.2

What kind of polycount did you UV yourself?

Mak11

  • Sr. Member
  • ****
  • Posts: 368
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #4 on: March 05, 2020, 04:33:41 PM »
The test I did was on a 36M polys mesh.
 Packing seems to be relatively normal on lower polycount meshes AFAIK see.

Cheers

Mak

wojtek

  • Sr. Member
  • ****
  • Posts: 275
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #5 on: March 05, 2020, 04:39:27 PM »
The test I did was on a 36M polys mesh.
 Packing seems to be relatively normal on lower polycount meshes AFAIK see.

Cheers

Mak

Yes, I should've noted in the original post. <40 mil seems to be ok though could still get tighter packing especially if we use high resolution maps.

It gets weird above that (50M+) in my case. I'm sure topology also play a factor.



off-topic: Is RyzomUV able to process geometry that dense?

Mak11

  • Sr. Member
  • ****
  • Posts: 368
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #6 on: March 05, 2020, 05:06:32 PM »
Never tried to load such dense mesh in Ryzom given that my usual final output mesh is around 10k-250K on which I bake the super dense mesh on. My guess is that it will probably crash.. Will try it later today & let you know.

Chees

Mak

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13908
    • View Profile
Re: UV packing in 1.6.2 is broken
« Reply #7 on: March 11, 2020, 07:03:00 PM »
The utilization of the atlas space will be improved in the next version update.
Best regards,
Alexey Pasumansky,
Agisoft LLC