Forum

Author Topic: Building Mesh from Depth Maps became TOO slow! Why?  (Read 2680 times)

3D_Scan_Fan

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Building Mesh from Depth Maps became TOO slow! Why?
« on: March 28, 2020, 04:01:03 AM »
Hi everyone,

I've encountered a very strange problem. I have a bunch of chunks that are all relatively identical to each other (120 photos) of a model sitting down posing difference facial expressions.

I have previously processed the chunks in relative time, meshes taking 1-1.5H (still think that's a bit long) however when I went back to re-build the first chunk, it was to my enormous surprise that the progress bar stayed stuck at 74% for around 20-30mins before it added more processing time which I can see from the log started typing away, resulting 3 hours!

I have been trying different things rebuilding it (also doing it through scripts) even though I've changed nothing to begin with! I've even disabled CPU processing just to see if it can rely on my GPUs (I have two RX 580 8GB cards).

I've tried another chunk which took a little bit longer than its original but nowhere near as this one.

This doesn't make sense at all, why has this Metashape (1.6.1.) decide to bring down the performance to a grinding halt??? :(

Mak11

  • Sr. Member
  • ****
  • Posts: 368
    • View Profile
Re: Building Mesh from Depth Maps became TOO slow! Why?
« Reply #1 on: March 28, 2020, 10:39:25 AM »
You shouldn't be using 1.6.1.
1.6.2 already fixed this issue a month ago.

Mak

3D_Scan_Fan

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Re: Building Mesh from Depth Maps became TOO slow! Why?
« Reply #2 on: March 28, 2020, 05:04:56 PM »
It still doesn't make any sense as to how the performance decreased.

Also, in the change log between versions there's no indication that this was fixed in 1.6.2.

Mak11

  • Sr. Member
  • ****
  • Posts: 368
    • View Profile
Re: Building Mesh from Depth Maps became TOO slow! Why?
« Reply #3 on: March 28, 2020, 05:16:14 PM »
There was a "bug" which has been fixed in 1.6.2.
https://www.agisoft.com/forum/index.php?topic=11755.0

Mak

3D_Scan_Fan

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Re: Building Mesh from Depth Maps became TOO slow! Why?
« Reply #4 on: March 28, 2020, 05:44:35 PM »
Yes i did come across your old topic on the matter, but you were still claiming that it was taking longer than it should on the preview build??

Mak11

  • Sr. Member
  • ****
  • Posts: 368
    • View Profile
Re: Building Mesh from Depth Maps became TOO slow! Why?
« Reply #5 on: March 28, 2020, 07:19:36 PM »
This was with a beta version of 1.6.2. It has since been fixed in the final release on March 1. :)

Mak