Forum

Author Topic: Metashape 1.6.1 not using GPU for texture blending  (Read 3249 times)

danderson4

  • Newbie
  • *
  • Posts: 13
    • View Profile
Metashape 1.6.1 not using GPU for texture blending
« on: February 10, 2020, 07:02:59 PM »
When creating a texture for my model, I am getting the following in the details section:

Found device GeForce GTX 1070 driver version 1640382464, API version: 1.0.65, location 4294967295::4294967295
Found device Intel(R) UHD Graphics 630 driver version 1645260, API version: 1.1.103, location 4294967295::4294967295
Only NVIDIA and AMD devices are currently supported
Cannot use GPU. Reason: Cannot find suitable device
Performing blending on CPU...

Why is it not using the GPU when I have an NVIDIA GeForece GTX 1070 installed and enabled?  It uses it for all the other GPU functions?


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13190
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #1 on: February 10, 2020, 07:58:41 PM »
Hello danderson4,

Which OS you are using and which NVIDIA driver version you have installed?
Best regards,
Alexey Pasumansky,
Agisoft LLC

danderson4

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #2 on: February 19, 2020, 01:45:31 AM »
Windows 10 Professional 64-bit.
NVIDIA GeForce GTX 1070 with driver version: 23.21.13.9125

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13190
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #3 on: February 19, 2020, 11:03:43 AM »
Hello danderson4,

Thank you for providing the additional information.

Metashape  supports  texture  blending  on  GPU  using  Vulkan  technology, which requires driver versions (for NVIDIA cards) from 435.xx. However, according you info you have driver 391.25 installed.
Please check the latest compatible driver for your system, for example: https://www.nvidia.com/Download/driverResults.aspx/156781/en-us
Best regards,
Alexey Pasumansky,
Agisoft LLC

546f6d6d79

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #4 on: June 21, 2020, 01:15:10 PM »
Not sure if I should've made a new thread for this, but I seem to be having the same issue in 1.6.3 using Nvidia driver: 446.14

Code: [Select]
Agisoft Metashape Professional Version: 1.6.3 build 10732 (64 bit)
Platform: Windows
CPU: Intel(R) Xeon(R) CPU E3-1270 V2 @ 3.50GHz
CPU family: 6 model: 58 signature: 306A9h
RAM: 32.0 GB
OpenGL Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 760/PCIe/SSE2
OpenGL Version: 4.6.0 NVIDIA 446.14

Found 1 GPUs in 0.072 sec (CUDA: 0.044 sec, OpenCL: 0.028 sec)
Using device: GeForce GTX 760, 6 compute units, free memory: 3280/4096 MB, compute capability 3.0
driver/runtime CUDA: 11000/8000
max work group size 1024
max work item sizes [1024, 1024, 64]
Initializing context...
Extension VK_EXT_shader_viewport_index_layer is missing on device
Cannot use GPU. Reason: Cannot find suitable device
Performing blending on CPU...

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13190
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #5 on: June 25, 2020, 02:14:00 AM »
Hello 546f6d6d79,

Can you please check if the most recent NVIDIA driver installation solves the problem?
Version 451.48 seems to be just released.
Best regards,
Alexey Pasumansky,
Agisoft LLC

546f6d6d79

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #6 on: June 25, 2020, 11:44:26 AM »
Hi Alexey,
Same problem with 451.48

Code: [Select]
2020-06-25 09:38:15 Agisoft Metashape Professional Version: 1.6.3 build 10732 (64 bit)
2020-06-25 09:38:15 Platform: Windows
2020-06-25 09:38:15 CPU: Intel(R) Xeon(R) CPU E3-1270 V2 @ 3.50GHz
2020-06-25 09:38:15 CPU family: 6 model: 58 signature: 306A9h
2020-06-25 09:38:15 RAM: 32.0 GB
2020-06-25 09:38:16 OpenGL Vendor: NVIDIA Corporation
2020-06-25 09:38:16 OpenGL Renderer: GeForce GTX 760/PCIe/SSE2
2020-06-25 09:38:16 OpenGL Version: 4.6.0 NVIDIA 451.48
2020-06-25 09:38:16 Maximum Texture Size: 16384
2020-06-25 09:38:16 Quad Buffered Stereo: not enabled
2020-06-25 09:38:16 ARB_vertex_buffer_object: supported
2020-06-25 09:38:16 ARB_texture_non_power_of_two: supported
2020-06-25 09:38:16 Using simple console. Rich console can be enabled in Preferences dialog.
2020-06-25 09:38:20 LoadProject: path = D:/photogrammetry/pgWaistCoat/pgWaistCoatv03v17.psx
2020-06-25 09:38:20 Loading project...
2020-06-25 09:38:20 loaded project in 0.366 sec
2020-06-25 09:38:20 Finished processing in 0.369 sec (exit code 1)
2020-06-25 09:38:41 BuildTexture: mapping mode = Keep uv, page count = 1, texture size = 8192, texture type = Diffuse map, source data = Images, blending mode = Mosaic, fill holes = 1, ghosting filter = 1, enable_gpu = 1, relaxed_precision = 1
2020-06-25 09:38:41 Blending textures...
2020-06-25 09:38:45 Found 1 GPUs in 1.077 sec (CUDA: 0.427 sec, OpenCL: 0.65 sec)
2020-06-25 09:38:45 Using device: GeForce GTX 760, 6 compute units, free memory: 2912/4096 MB, compute capability 3.0
2020-06-25 09:38:45   driver/runtime CUDA: 11000/8000
2020-06-25 09:38:45   max work group size 1024
2020-06-25 09:38:45   max work item sizes [1024, 1024, 64]
2020-06-25 09:38:45   got device properties in 0.001 sec, free memory in 0.508 sec
2020-06-25 09:38:46 Initializing context...
2020-06-25 09:38:46 Extension VK_EXT_shader_viewport_index_layer is missing on device
2020-06-25 09:38:46 Cannot use GPU. Reason: Cannot find suitable device
2020-06-25 09:38:46 Performing blending on CPU...

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13190
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #7 on: June 25, 2020, 11:41:30 PM »
Hello 546f6d6d79,

Seems like GPU based blending wouldn't work on 7xx series of GeForce GTX. We will check, if it could be enabled in future updates, however, it might not be in our top priority list.
Best regards,
Alexey Pasumansky,
Agisoft LLC

546f6d6d79

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #8 on: June 26, 2020, 03:27:25 PM »
Quote
it might not be in our top priority list.

My 7yr old, budget GPU, that I'm using during a free trial doesn't get priority support!  :o ;D

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13190
    • View Profile
Re: Metashape 1.6.1 not using GPU for texture blending
« Reply #9 on: June 27, 2020, 02:07:45 AM »
Hello 546f6d6d79,

Other GPU-supported operations should work properly on GeForce GTX 7xx, but the texture blending will be performed on CPU without GPU acceleration.
Best regards,
Alexey Pasumansky,
Agisoft LLC