Forum

Author Topic: Errors alignment images Mavic 2 PRO (mission planning: parallel to main path)  (Read 4870 times)

LSR

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hi all,
I have problems with alignment of images acquired with Mavic 2 PRO. After alignment process the images appear tilted and shifted (see IMM.1).
Mission has been planned with GS PRO (DJI) with settings (parallel to main path), see IMM.2 .
The images alignment was processed with Metashape v. 1.6.0 and the following settings (see IMM.3):
-Accuracy: HIGH
-Generic preselection: YES
-Reference preselection: SOURCE
-Key point limit: 50000
-Tie point limit: 5000
-Guided image matching: NO
-Adaptive camera model fitting: YES

The rolling shutter option has been unchecked, because the result was worse (see IMM.4).

Can someone help me to solve the images alignment problem?

Best regards,
LSR

Dieter

  • Full Member
  • ***
  • Posts: 213
    • View Profile
Do you have unchecked the GPS coordinates in the Referenz-pane?

And then try  with Key-Poin limit 100000 and tie-Point limit 40000.

Dieter

LSR

  • Newbie
  • *
  • Posts: 6
    • View Profile
I have unchecked the GPS coordinates in the Reference-pane and changed the Key and Tie Point as you suggested, but it didn't work. The alignement failed.
I think that the problem is the type of flight I have done, parallel to main path. This means that camera had always the same orientation in global space, regardless of the flight direction.
Thanks in advance.
LSR

Dieter

  • Full Member
  • ***
  • Posts: 213
    • View Profile
Can you upload the Photos on a cloud server, then i can look about it.

Dieter

LSR

  • Newbie
  • *
  • Posts: 6
    • View Profile
Yes , sure.
You can download the photo set from this link: https://we.tl/t-oFZXBrckau .
Thanks in advance.
LSR

Dieter

  • Full Member
  • ***
  • Posts: 213
    • View Profile

I saw the photos, what can I say, they are not that good ......

I also have the Mavic 2 Pro.

You have to try to keep the exposure time fixed with a maximum of 1/250, better is 1/500 or even 1/1000.
You can set the aperture on the Mavic to 2.8 and leave it that way. I fly with ISO Auto, the less light, the higher the ISO number. I set the focus to fixed, I made a table with different distances. You have to try a little bit, then you will get better photos and better results. Now I'll have a look at the overlaps and whether I can somehow calculate the project ......

But that can take until Monday, I'll be on my way tomorrow.

Dieter

LSR

  • Newbie
  • *
  • Posts: 6
    • View Profile
Thanks a lot for your support, let me know if you can process the images.
Thanks thanks thanks
LSR

Dieter

  • Full Member
  • ***
  • Posts: 213
    • View Profile
look here:

https://www.dropbox.com/s/ex4h4xvd4fp3kd4/test.zip?dl=0

It is the Project without Photos.. But i dont know about the accuracy.

Do you have GCP's?


Dieter

Paulo

  • Hero Member
  • *****
  • Posts: 1346
    • View Profile
Hi LSR,

the fly parallel to path is a problem as it introduces high correlation between camera positions and camera focal and principal point coordinates (f,cx,cy). So I would definitely not fly with this pattern in future and best practice would be to add a few obliques at different heights to regular nadir lawn mower flight pattern....

I will look at your data set to see what can be done...
Best Regards,
Paul Pelletier,
Surveyor

Paulo

  • Hero Member
  • *****
  • Posts: 1346
    • View Profile
I was able to get a good alignment fixing f, cx, cy in initial alignment and using rolling shutter compensation. Then I did a gradual selection and did a optimization of f, cx, cy, k1,k2,k3 and p1, p2....

Point Cloud
Points   168,067 of 360,010
Point colors   3 bands, uint8
Key points   No
RMS reprojection error   0.104133 (0.247948 pix)
Max reprojection error   0.376012 (1.04111 pix)
Mean key point size   2.35744 pix
Average tie point multiplicity   5.48424
Alignment parameters   
Accuracy   High
Generic preselection   Yes
Reference preselection   Source
Key point limit   50,000
Tie point limit   10,000
Guided image matching   No
Adaptive camera model fitting   Yes
Matching time   16 minutes 22 seconds
Matching memory usage   860.29 MB
Alignment time   54 minutes 0 seconds
Alignment memory usage   238.92 MB
Optimization parameters   
Parameters   f, cx, cy, k1-k3, p1, p2
Fit additional corrections   Yes
Adaptive camera model fitting   No
Optimization time   16 minutes 1 seconds

Software version   1.6.4.10928
File size   50.07

However, I have 2 images with orientation angles way off gimbal supplied values... see screen capture
« Last Edit: August 22, 2020, 12:30:35 AM by Paulo »
Best Regards,
Paul Pelletier,
Surveyor

Paulo

  • Hero Member
  • *****
  • Posts: 1346
    • View Profile
Dense cloud produced with Medium Quality and Aggressive Filtering...
« Last Edit: August 22, 2020, 12:33:50 AM by Paulo »
Best Regards,
Paul Pelletier,
Surveyor

LSR

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hi Paulo,
thanks for your support and cooperation.
I didn't answer earlier because I did some tests following your suggestions and it took a long time.
The dataset you processed was successful but I have applied the same processing  parameters  to other datasets and I have had other problems (alignment, placing GCPs, optimization, camera calibration), that I am trying to solve using your suggestions.
I don't understand if the problem is the images acquired with Mavic2 or the Metashape 1.6.4 settings.
If I don't solve the problem I will ask for your support again...if possible.
Thanks in advance
LSR

Paulo

  • Hero Member
  • *****
  • Posts: 1346
    • View Profile
Ok LSR,

please keep me informed if I can give  a hand on other data sets....

definitively acquiring images with parallel to path method  does introduce problems... also version 1.6.4 does have issues with Show Image... as it distorts the image projection on model as in following capture... also slow exposure times introduce quite a lot of rolling shtter effect...

« Last Edit: August 25, 2020, 12:11:56 PM by Paulo »
Best Regards,
Paul Pelletier,
Surveyor

LSR

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hi  Dieter,
thanks for your support and cooperation.
Yes I have GCPs and the model seems to work pretty well.
I'm just having trouble understanding some Metashape settings and I'm doing other tests on different datasets.
I will ask for some more suggestions and I will pay more attention in the acquiring images.
Thanks in advance
LSR