Forum

Author Topic: Sketchfab Upload: "OpenSSL Library Not Found"  (Read 6039 times)

matt07lx

  • Newbie
  • *
  • Posts: 25
    • View Profile
Sketchfab Upload: "OpenSSL Library Not Found"
« on: July 22, 2019, 07:41:10 PM »
I get the following message when I try to upload to Sketchfab directly from Metashape: "OpenSSL Library Not Found: Please Install OpenSSL 1.0 for Data". I've installed several versions of OpenSSL (64 and 32 bit), restarted Metashape and my computer, and nothing seems to work. Any ideas? I've never had this issue before.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Sketchfab Upload: "OpenSSL Library Not Found"
« Reply #1 on: July 22, 2019, 07:57:41 PM »
Hello matt07lx,

Have you installed OpenSSL version 1.0.x?
Best regards,
Alexey Pasumansky,
Agisoft LLC

matt07lx

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: Sketchfab Upload: "OpenSSL Library Not Found"
« Reply #2 on: July 22, 2019, 08:11:26 PM »
Yes, I've tried 1.0.2.s, which is the only 1.0.x version currently available: https://slproweb.com/products/Win32OpenSSL.html


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Sketchfab Upload: "OpenSSL Library Not Found"
« Reply #3 on: July 22, 2019, 08:55:13 PM »
Hello matt07lx,

Similar problem has been discussed on Sketchfab forums: https://forum.sketchfab.com/t/agisoft-photoscan-direct-upload-issue-error-creating-ssl/14040/22
Installing OpenSSL_Light-1_0_2L solves the problem for most users.

Do you also see OpenSSL related lines in the black OS console when starting the application?
Best regards,
Alexey Pasumansky,
Agisoft LLC

leostalin91

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Sketchfab Upload: "OpenSSL Library Not Found"
« Reply #4 on: September 03, 2020, 10:30:03 AM »
You can download and Install the OpenSLL library from https://mega.nz/file/mXQ11KxR#6lqh5CKPALzQs2YjMxd9tOTUZwFdj7KAa0gMouNJYbE