Author Topic: Update- solved- import csv dialog will not open- unable to load reference  (Read 2490 times)


  • Newbie
  • *
  • Posts: 7
    • View Profile
I am running Agisoft Metashap Version 1.6.4 build 10928 (64bit).

I have DSLR images and associated PPK image reference file (.csv format). When I import photos into a chunk I am unable to import the csv to assign location information to those images. When under the reference tab I choose the 'import refrence' button I am able to select the csv with but then nothing happens. The import csv dialog will not open. The console log reports:

2020-09-21 12:02:16 ImportReference: format = ReferenceFormatMavinci, path = C:/Users/NAD(83)-6318.csv
2020-09-21 12:02:16 Finished processing in 0.001 sec (exit code 1)

I assume the problem is that it is looking for a file formatted for Mavinci. I am not aware of a place to change this setting or how this would have been set (I have never used the Mavinci software or loaded any Mavinci files on this computer or any other). Why is this happening and how can I change this so that I am able to load a standard csv?

I have a second computer running the demo version of Agisoft Metashape 1.6.0 build 9925 (64bit). In the reference tab, when I click on 'import reference' the import csv dialog comes up and I am able to successfully reference the images. On this version the console reports:

2020-09-21 12:39:09 ImportReference: path = C:/Users/NAD(83)-6318.csv
2020-09-21 12:39:09 Finished processing in 0.004 sec (exit code 1)
« Last Edit: September 22, 2020, 08:47:43 AM by ak »


  • Newbie
  • *
  • Posts: 7
    • View Profile
Update: turns out when asking clicking on 'import reference' there is an option to choose the csv file type. For some reason this computer was using the Mavinci csv as the default file type. Changed this to character delimited csv and all went forward as it should.

Apologies for the false alarm- unsure of how this became the default- good use for the console to see what was happening- lots of little menu items to check took awhile to figure out where that option came from.


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14890
    • View Profile
Re: Update- solved- import csv dialog will not open- unable to load reference
« Reply #2 on: September 22, 2020, 12:14:51 PM »
Hello ak,

The default file type in the import reference dialog is the last used file type for import. Probably Mavinci.csv format has been accidentally used once on the machine.
Best regards,
Alexey Pasumansky,
Agisoft LLC