Forum

Author Topic: crashing when aligning images  (Read 791 times)

j.senn

  • Newbie
  • *
  • Posts: 8
    • View Profile
crashing when aligning images
« on: October 01, 2020, 10:57:34 AM »
Hi All,
Metashape keeps crashing when trying to align photos. It finishes detecting points and crashes at about 75% of estimating camera locations. The dataset consists of 917 thermal images (tif) 640 x 512 pixels resolution.

I've managed to align them on high quality before and later refined the selection of photos. I've also updated Metashape. Now it would only run on low quality but crash on medium, high or highest.

please find a crash report attached and an example image behind the link (file too large).
Any ideas?

Johannes

https://newcastle-my.sharepoint.com/:i:/g/personal/b8045831_newcastle_ac_uk/EbwZnY5fMYpFisC8AhyCynsBU-YHuSEuKF6i107Nu_k7oQ?e=HfMA3T

j.senn

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: crashing when aligning images
« Reply #1 on: October 02, 2020, 09:49:19 AM »
Might be related or not:

I am remoting onto the workstation from home, using the remote desktop with the NVIDIA patch that allows running things on my GPU. However, every other day Metashape opens as a black window, which is apparently related to remoting in. I can get back to "normal" by changing the display mode to stereo, but the marker flags remain black boxes and text is not readable, but it works. After re-booting the workstation the interface looks fine again.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12851
    • View Profile
Re: crashing when aligning images
« Reply #2 on: October 02, 2020, 12:31:34 PM »
Hello Johannes,

Do you have any markers in your project added before the alignment has been started? If so, please check, whether the latest 1.6.5 release version works properly without any crashes.

As for the remote display issue, I can suggest to install the latest NVIDIA drivers on the remote machine and reboot it.
Best regards,
Alexey Pasumansky,
Agisoft LLC

landing.st@gmail.com

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: crashing when aligning images
« Reply #3 on: October 13, 2020, 08:49:54 AM »
having same issue...log file of last few minutes is attached....

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12851
    • View Profile
Re: crashing when aligning images
« Reply #4 on: October 13, 2020, 10:35:02 AM »
Hello landing.st,

Which version is this log from? Is it 1.6.4 and whether you have markers in the project? If so, then I can suggest to check the latest 1.6.5 release version.
Best regards,
Alexey Pasumansky,
Agisoft LLC

j.senn

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: crashing when aligning images
« Reply #5 on: October 13, 2020, 10:39:04 AM »
Hello Alexey and landing.st,
for me updating the drivers instantly solved the problems. Sorry, that was an embarrassingly simple solution.

However, I still sometimes get a black screen, which I can get rid of it by changing to stereo view (and back). But some graphics remain funny: markers would still appear as black boxes and the overlay number of points is not readable. This can be fixed by re-booting, so no big deal, just fyi.