Forum

Author Topic: Fresh install - Missing OpenSSL  (Read 1121 times)

Snikkern

  • Newbie
  • *
  • Posts: 3
    • View Profile
Fresh install - Missing OpenSSL
« on: October 04, 2020, 01:47:11 PM »
Hi. I have tried to install 1.0.2u both 32bit and 64bit according to information i have found in this forum. Still i get the error message stating im missing OpenSSL when trying to use cloud. I have rebooted computer multiple times, uninstalled and reinstalled. Nothing seems to work.

Isnt there any way i can manually take som files, put in a given folder and i force it to work ?


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Fresh install - Missing OpenSSL
« Reply #1 on: October 04, 2020, 02:18:49 PM »
Hello Snikkern,

There are some different sources of OpenSSL 1.0.2 libraries, see the following links:
https://wiki.openssl.org/index.php/Binaries
http://wiki.overbyte.eu/wiki/index.php/ICS_Download#Download_OpenSSL_Binaries_.28required_for_SSL-enabled_components.29

Can you please also specify, which output do you get, when inputting the following lines one by one to the Console pane of Metashape:
Code: [Select]
import ssl
ssl.OPENSSL_VERSION
Best regards,
Alexey Pasumansky,
Agisoft LLC

Snikkern

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Fresh install - Missing OpenSSL
« Reply #2 on: October 04, 2020, 05:42:26 PM »
The error message is the following:


When typing the code i get the following:

xabierr

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
Re: Fresh install - Missing OpenSSL
« Reply #3 on: October 07, 2020, 05:01:11 AM »
Im getting the same error and message after installing ver 1.1.1


 

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13729
    • View Profile
Re: Fresh install - Missing OpenSSL
« Reply #4 on: October 07, 2020, 07:05:23 PM »
Hello,

Please try to download OpenSSL Binaries Win-64 v1.0.2u binaries from the following page:
http://wiki.overbyte.eu/wiki/index.php/ICS_Download#Download_OpenSSL_Binaries_.28required_for_SSL-enabled_components.29

Unpack the archive and put its contents to Metashape Pro installation directory, then re-start the application.
Best regards,
Alexey Pasumansky,
Agisoft LLC

xabierr

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
Re: Fresh install - Missing OpenSSL
« Reply #5 on: October 08, 2020, 11:15:34 AM »
Thanks Alexey. That worked