Forum

Author Topic: Agisoft Metashape 1.7.0 pre-release  (Read 66276 times)

andyroo

  • Sr. Member
  • ****
  • Posts: 401
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #60 on: November 24, 2020, 04:44:48 AM »
I have used the banchmarking dataset in the versions 1.6.5 and 1.7.0 and got comparable timing for image matching

Is it possible to install 1.6.5 and 1.7.0 preview on the same machine for testing/benchmarking? I haven't tried since before licensing methods changed, and it involved copying the install dir to a new location before installing the next/test version...

Andy

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #61 on: November 24, 2020, 12:47:13 PM »
Hello Andy,

Yes, you can have both versions installed on the same machine. On Windows OS you should install version 1.6.5 first, then copy/move installation directory to some custom location, where it will be run from, and then install version 1.7.0 by the default path.
If version 1.6.5 has been activated, then with the installation directory you will also copy the .lic file and would not require to perform any additional actions - both versions will work under the same license.
Best regards,
Alexey Pasumansky,
Agisoft LLC

mcstieg

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #62 on: November 24, 2020, 04:31:07 PM »
Hello Alexey!

Have been able to download the photos from dropbox (had a ticket 6.11. 147228) to verify a depth maps problem with 1.7 I didn't have with 1.6x? (Medium quality if fine, both higher ones lead to holes in the model).

Thank you!  :D

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #63 on: December 01, 2020, 02:52:54 PM »
Have been able to download the photos from dropbox (had a ticket 6.11. 147228) to verify a depth maps problem with 1.7 I didn't have with 1.6x? (Medium quality if fine, both higher ones lead to holes in the model).
Hello mcstieg,

Pre-release has been just updated, hopefully you will no longer observe those holes in the mesh. At least I haven't observed any problems when re-processing your project in the recent pre-release version.
Best regards,
Alexey Pasumansky,
Agisoft LLC

BjFaeTorphins

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #64 on: December 01, 2020, 09:02:05 PM »
What's changed in the latest pre-release build 11539?  The change log does not look to have been updated.

Also, What are "connected components"?

There is a new "Components" level on the Workspace tree structure but there are no right click commands or other functions that seem to relate to "component" objects.  What is that all about?

Paulo

  • Hero Member
  • *****
  • Posts: 971
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #65 on: December 01, 2020, 10:59:18 PM »
In latest release, I still get error in Blending Textures part  of Build Textures....

Code: [Select]
2020-12-01 13:55:15 Blending textures...
2020-12-01 13:55:15 Found 1 GPUs in 0.002 sec (CUDA: 0.001 sec, OpenCL: 0.001 sec)
2020-12-01 13:55:15 Using device: GeForce GTX 670MX, 5 compute units, free memory: 2474/3072 MB, compute capability 3.0
2020-12-01 13:55:15   driver/runtime CUDA: 10010/8000
2020-12-01 13:55:15   max work group size 1024
2020-12-01 13:55:15   max work item sizes [1024, 1024, 64]
2020-12-01 13:55:15 All cameras are fine
2020-12-01 13:55:15 Initializing context...
2020-12-01 13:55:16 Extension VK_EXT_shader_viewport_index_layer is missing on device
2020-12-01 13:55:16 Finished processing in 2318.81 sec (exit code 0)
2020-12-01 13:55:16 Error: Cannot find suitable device
   

Note that in version 1.6, this problem with older GPUs is avoided by continuing processing with CPU...       
Best Regards,

Paul Pelletier,
Surveyor

Paulo

  • Hero Member
  • *****
  • Posts: 971
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #66 on: December 02, 2020, 03:19:39 AM »
I no longer experience crashes when aligning 20 MP images... Good work!

Attached file compares  version 1.6.5 and 1.7 alignment of  a set of 188 Phantom4pro images on following system

OS Windows 64 bit
RAM 15.95 GB
CPU Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
GPU(s) GeForce GTX 670MX
with Use CPU when performing GPU accelerated processing checked in GPU preferences in both cases.

Alignment time for v1.7 is 34 min 12 sec while for v1.6 it is 35 min 46 sec....
« Last Edit: December 02, 2020, 07:36:22 AM by Paulo »
Best Regards,

Paul Pelletier,
Surveyor

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #67 on: December 02, 2020, 03:24:39 AM »
Cuda enabled GPU's are not recognized yet in the MacOS version, under MacOS High Sierra (1 december beta). Version 1.6.5 recognize them without any problem. Seems to be a regression from version 1.6.5 here.
Best Regards

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #68 on: December 02, 2020, 11:43:31 AM »
Cuda enabled GPU's are not recognized yet in the MacOS version, under MacOS High Sierra (1 december beta). Version 1.6.5 recognize them without any problem. Seems to be a regression from version 1.6.5 here.

Hello Renato,

We are working on the issue with NVIDIA cards recognition on older macOS version.
Best regards,
Alexey Pasumansky,
Agisoft LLC

mcstieg

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #69 on: December 02, 2020, 12:22:50 PM »
Have been able to download the photos from dropbox (had a ticket 6.11. 147228) to verify a depth maps problem with 1.7 I didn't have with 1.6x? (Medium quality if fine, both higher ones lead to holes in the model).
Hello mcstieg,

Pre-release has been just updated, hopefully you will no longer observe those holes in the mesh. At least I haven't observed any problems when re-processing your project in the recent pre-release version.

Hello Alexey,

just sent you an E-Mail this morning. Unfortunately, the holes are still there with the new release - with and without gradual selection and optimization. Medium works. High and ultra look terrible.
Thank you for your work! Hopefully this can be found and fixed.  :)

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #70 on: December 02, 2020, 01:35:21 PM »
Hello mcstieg,

Thank you for the project and the images, we will re-process it on different hardware configurations, as the issue could be related to particular hardware or driver issue.
Best regards,
Alexey Pasumansky,
Agisoft LLC

mcstieg

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #71 on: December 02, 2020, 06:25:21 PM »
Driver update did the job! It works.  :D

kcm

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #72 on: December 02, 2020, 09:37:40 PM »
FYI your 1.7 Python API doc still says "Python 3.5" on page 3 even though the 1.7 changelog states: "• Updated Python to version 3.8." (thank goodness ;-).

macsurveyr

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #73 on: December 04, 2020, 01:37:50 AM »
1.7.0 11539

I built a mesh on a project with 371 photos and only had 10 depth maps produced. I then tried a smaller project with only 10 photos and ended up with only 1 depth map.

I reran the 10 photo project using 1.6.5 just to be sure, and have 10 good depth maps. I tried 1.7.0 on medium and on high with the same result - 1 depth map.

My computer

macOS  11.0.1
iMac (Retina 5K, 27-inch, 2017)
4.2 GHz Quad-Core Intel Core i7
64 GB 2400 MHz DDR4
Radeon Pro 580 8 GB

Tom

Exorbitart

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #74 on: December 04, 2020, 09:16:40 AM »
 version 1.7.0 build 11539.

got some inaccurate results in depthmaps generation. not sure if results from to less image overlap or something else.
Input: 57x  16bit tif files from 61mp raws. 24mm g-master lens.