Forum

Author Topic: Agisoft Metashape 1.7.0 pre-release  (Read 66255 times)

Paulo

  • Hero Member
  • *****
  • Posts: 971
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #105 on: December 18, 2020, 04:34:29 AM »
With latest pre release, I tried regenerating depth maps for 8 spherical 50 Mpixel images with High quality and Mild filtering....on following system

OS Windows 64 bit
RAM 15.95 GB
CPU Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz
GPU(s) GeForce GTX 670MX

The processing time is a huge 1 hour 27 min compared to less than 10 min for version 1.6.2

Depth Maps Generation on 8 spherical images (50 Mpix) using CPU in GPU processing

                                         1.6.2.10247         1.7.0.11637
Depth Maps Parameters   
 Quality                          High                    High
 Filtering mode         Mild                       Mild
 Processing time      9 minutes 56 seconds         1 hour 27 minutes
 Memory usage         1.76 GB                2.72 GB
File size                         85.01 MB             109.86 MB

Attached is processing log....

 clearly such long processing times are not feasible on such system..

Update: I regenerated the depth maps but this time unchecking Use CPU in GPU processing and it finished in 31 min 55 sec but still considerably higher than 1.6.2... Funny because in previous versions, I found that all GPU processing runs faster with use CPU checked for this relatively low performance GPU type (GTX 670MX).
« Last Edit: December 19, 2020, 03:26:00 PM by Paulo »
Best Regards,

Paul Pelletier,
Surveyor

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #106 on: December 18, 2020, 11:30:30 AM »
1.7.0 11539

I built a mesh on a project with 371 photos and only had 10 depth maps produced. I then tried a smaller project with only 10 photos and ended up with only 1 depth map.

I reran the 10 photo project using 1.6.5 just to be sure, and have 10 good depth maps. I tried 1.7.0 on medium and on high with the same result - 1 depth map.

My computer

macOS  11.0.1
iMac (Retina 5K, 27-inch, 2017)
4.2 GHz Quad-Core Intel Core i7
64 GB 2400 MHz DDR4
Radeon Pro 580 8 GB

Hello Tom,

Please check build 11637 (published yesterday), hopefully it will fix the reported problem.
Best regards,
Alexey Pasumansky,
Agisoft LLC

RHenriques

  • Full Member
  • ***
  • Posts: 208
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #107 on: December 18, 2020, 05:08:08 PM »
Cuda enabled GPU's are not recognized yet in the MacOS version, under MacOS High Sierra (1 december beta). Version 1.6.5 recognize them without any problem. Seems to be a regression from version 1.6.5 here.

Hello Renato,

We are working on the issue with NVIDIA cards recognition on older macOS version.



Hi Alexey

All the GPU's are now perfectly recognized again (latest beta from 17th December). Nice work!
Best Regards

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #108 on: December 18, 2020, 05:21:22 PM »
Hello Renato,

These are very good news! Thank you for posting.
Best regards,
Alexey Pasumansky,
Agisoft LLC

macsurveyr

  • Jr. Member
  • **
  • Posts: 65
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #109 on: December 18, 2020, 06:47:09 PM »
Hello Alexey,

I ran a couple of tests on smaller projects and the results are very good with build 11637. The resulting mesh is superior to any I have seen in previous versions.

It is interesting that the depth maps look very different than previous versions but when I choose Export depth, the exported images look basically identical. Not sure what that means, just curious.

I am running a much more complex project now will report any issues, but I am not expecting any.

Excellent progress!

Tom

Paulo

  • Hero Member
  • *****
  • Posts: 971
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release Color shapes
« Reply #110 on: December 19, 2020, 12:54:29 PM »
I notice that now in latest pre release, all shapes appear with same color ( HTML #c0c0c0 which seems to be color of 1st shape group) regardless of their original color. Also dashed black line symbol for outer boundary no longer appears...

Please see attached...
« Last Edit: December 19, 2020, 01:06:30 PM by Paulo »
Best Regards,

Paul Pelletier,
Surveyor

wojtek

  • Sr. Member
  • ****
  • Posts: 273
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #111 on: December 19, 2020, 04:27:30 PM »
Hello Renato,

These are very good news! Thank you for posting.

Hey Alexey, can you explain what Generate Defocus Masks is?

Mohammed

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #112 on: December 20, 2020, 02:55:04 AM »
Dear Agisoft team,

I tried o run some laserscanning data saved as E57 format but every time i import the data the sw keep says "Error: Empty file list", dose any have an idea about that error?

Thanks
« Last Edit: December 20, 2020, 02:57:16 AM by Mohammed »

Paulo

  • Hero Member
  • *****
  • Posts: 971
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #113 on: December 22, 2020, 10:13:31 AM »
Hello all.

Ive noticed that in latest pre release, Model View now has 3 more buttons : DEM, OrthoMosaic  and Show BaseMap. So that in model view you can now display a Base Map (Satellite or Open Street Map) as a backdrop to your mdel.

See attached screen copy..

However if you try to use first 2 buttons (DEM or OrthoMosaic) then application crashes...
« Last Edit: December 22, 2020, 10:17:06 AM by Paulo »
Best Regards,

Paul Pelletier,
Surveyor

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #114 on: December 22, 2020, 02:44:19 PM »
Ive noticed that in latest pre release, Model View now has 3 more buttons : DEM, OrthoMosaic  and Show BaseMap. So that in model view you can now display a Base Map (Satellite or Open Street Map) as a backdrop to your mdel.

See attached screen copy..

However if you try to use first 2 buttons (DEM or OrthoMosaic) then application crashes...
Hello Paul,

Does it happen for any project? In which coordinate system DEM and orthomosaic are referenced in the crashed projects?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #115 on: December 22, 2020, 02:45:15 PM »
I tried o run some laserscanning data saved as E57 format but every time i import the data the sw keep says "Error: Empty file list", dose any have an idea about that error?

Hello Mohammed,

It seems that you are trying to load point cloud instead of individual laser scans (with depth data) via Import Laser Scans command.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mohammed

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #116 on: December 22, 2020, 02:48:09 PM »
I tried o run some laserscanning data saved as E57 format but every time i import the data the sw keep says "Error: Empty file list", dose any have an idea about that error?

Hello Mohammed,

It seems that you are trying to load point cloud instead of individual laser scans (with depth data) via Import Laser Scans command.

Dear Alexey,

I used the commend File---Import---Import LaserScanner and the sw keep gives me the error!
Do you want me to send you the E57 file?

Best
Mohamed

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13735
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #117 on: December 22, 2020, 03:08:08 PM »
Hello Mohamed,

Import Laser Scans command assumes that you are loading individual scans - per scanner location, which contain the depth data, intensity and, optionally, spherical panorama.

You can send the E57 to support@agisoft.com, but according to the message it seems that the input data is not in the required format and is merged point cloud instead.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mohammed

  • Full Member
  • ***
  • Posts: 191
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #118 on: December 22, 2020, 04:19:19 PM »
Hello Mohamed,

Import Laser Scans command assumes that you are loading individual scans - per scanner location, which contain the depth data, intensity and, optionally, spherical panorama.

You can send the E57 to support@agisoft.com, but according to the message it seems that the input data is not in the required format and is merged point cloud instead.

Thanks Alexey i already send it.

Paulo

  • Hero Member
  • *****
  • Posts: 971
    • View Profile
Re: Agisoft Metashape 1.7.0 pre-release
« Reply #119 on: December 22, 2020, 08:11:36 PM »
Hi Alexey,

the crash (which actually is the sw just exiting without any Crash message) seems to happen just with projects referenced in following CRS: WGS 84 / UTM zone 14N + GGM2010 height. or any Compound CRS using GGM2010 geoid...

I tried using DEM or OrthoMosaic button in Model view in other projects with different CRS`s without any problem.

Update: got same crash or impeteous exit from sw using following CRS : COMPD_CS["NZGD2000 / New Zealand Transverse Mercator 2000 + NZVD2016 height"....
« Last Edit: December 23, 2020, 01:02:29 AM by Paulo »
Best Regards,

Paul Pelletier,
Surveyor