Forum

Author Topic: Metashape v. 1.7.X unsupported GPUs / dense cloud error  (Read 2146 times)

mlbrack@desert.com

  • Newbie
  • *
  • Posts: 6
    • View Profile
Metashape v. 1.7.X unsupported GPUs / dense cloud error
« on: January 28, 2021, 06:30:36 PM »
Installed v. 1.7. Apparently my NVIDIA Quadro 6000 display adapter/GPU is no longer supported.

Dense cloud generation fails and returns:

create_cu_texture_code
unknown error (30) at line 323

Tested with NVIDIA Telsa K20C and Quadro K2000. Runs fine. No errors.

« Last Edit: January 28, 2021, 08:52:22 PM by mlbrack@desert.com »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: Metashape v. 1.17.X unsupported GPUs / dense cloud error
« Reply #1 on: January 28, 2021, 07:01:51 PM »
Hello mlbrack,

Please provide the complete log from the Console pane related to the failed operation and specify the OS version used and NVIDIA driver version.
Best regards,
Alexey Pasumansky,
Agisoft LLC

mlbrack@desert.com

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Metashape v. 1.17.X unsupported GPUs / dense cloud error
« Reply #2 on: January 28, 2021, 08:51:36 PM »
Win 10 Pro-2004 build 19047.746

Nvidia Quadro 6000 current at 377.83 as of yesterday (2018 release)

mlbrack@desert.com

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Metashape v. 1.7.X unsupported GPUs / dense cloud error
« Reply #3 on: January 28, 2021, 09:26:42 PM »
Actually, Nvidia has a new driver current 2021.1.26. I'll test with new driver for K6000 when I can swap out GPUs again.

mlbrack@desert.com

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Metashape v. 1.7.X unsupported GPUs / dense cloud error
« Reply #4 on: January 28, 2021, 10:04:20 PM »
I was wrong Quadro 6000 driver is current at 2018.1.18

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14004
    • View Profile
Re: Metashape v. 1.7.X unsupported GPUs / dense cloud error
« Reply #5 on: January 28, 2021, 10:31:56 PM »
Hello mlbrack,

It seems that the driver is too old to use all instructions properly, unfortunately, so the alternatives are:
- use the pm_enable tweak (roll back to the older version depth maps),
- disable GPU when building the depth maps (without using the tweak).
Best regards,
Alexey Pasumansky,
Agisoft LLC

mlbrack@desert.com

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Metashape v. 1.7.X unsupported GPUs / dense cloud error
« Reply #6 on: January 29, 2021, 05:45:19 PM »
That's exactly what it looks like. Out of all the Nvidia drivers I checked, the Quado 6000 is the only one that hasn't had a 1/21 driver release. Maybe it's coming.

It doesn't matter. Ebay is already sending me a bigger, meaner Tesla.

Thanks for the fast response, sir.

« Last Edit: January 29, 2021, 05:51:27 PM by mlbrack@desert.com »