Forum

Author Topic: New 1.7 Cylindrical DEM/Ortho Issues  (Read 1401 times)

JRMertes

  • Newbie
  • *
  • Posts: 5
    • View Profile
New 1.7 Cylindrical DEM/Ortho Issues
« on: January 12, 2021, 03:25:56 AM »
I was wondering if anyone could clarify the correct processing steps to generate a cylindrical "unwrapped" DEM and corresponding ortho. I have gotten the DEM sorted, as far as I can tell just from looking at it. I did notice that the scale is not correct and that if the bounding box is big, the DEM will have extrapolated area. So, some adjustments of the bounding box solved this issue. My cylinder is sitting vertical, I define the vertical axis to be Z. I've added some GCP markers around the cylinder that all have X,Y,Z values and Z is 0. So, the model is pretty straight up and down. I generated the DEM and used the cylinder projection with the orientation being Z. Comparing the "unwarpped" dem to the photos, everything seems to be in place (again, not taking into consideration the scale issue).

However, no matter what selection of Ortho generation I choose, nothing works. It always ends up a mishmash of colors. First try was using the same settings as DEM generation. Z axis was the orientation. Alas, that didn't work. Nor did any other choice.

Anyone have some clues or ideas I could try out. I've been looking online but no mention of this issue.

Cheers


Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 13912
    • View Profile
Re: New 1.7 Cylindrical DEM/Ortho Issues
« Reply #1 on: January 13, 2021, 01:12:34 AM »
Hello JRMertes,

For cylindrical orthomosaic generation you should also select the mesh source, as it currently doesn't work for DEM source option in this mode.

Have you checked the related article already?
https://agisoft.freshdesk.com/support/solutions/articles/31000153736-orthomosaic-generation-cylindrical-projection-
Best regards,
Alexey Pasumansky,
Agisoft LLC

JRMertes

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: New 1.7 Cylindrical DEM/Ortho Issues
« Reply #2 on: January 13, 2021, 01:20:25 PM »
I have read that walk through yes. It didn't specify that one needs to use the mesh. Yes. It does work now. I have placed the GCPs around the bottom plane that the cylinder is on so I am able to use the Z axis successfully. However, since the cylinder isn't centered (ie cylinder axis is not on X=0 Y=0) the output DEM has a sinusoidal trend added to it. But, I can see that's because the radius of the basic cylinder shape (not including the the objects glues to it) varies in distance, rather than being constant.

I find the placement of markers approach to be difficult. Placing the markers where there is no mesh, or even just adding markers, unchecked, seems to cause the automarker adjust thing to kick in and new blue flags for different markers appear. I've tried shutting this of but I don't see the option anymore in the advanced tab.

One other thing, the shape and scale of the output DEM is not right. Is there some sort of exaggeration? I can calculate the surface area of the cylinder and if unrolled into a plane it should be a rectangle.
« Last Edit: January 13, 2021, 04:24:06 PM by JRMertes »

JMR

  • Sr. Member
  • ****
  • Posts: 447
    • View Profile
Re: New 1.7 Cylindrical DEM/Ortho Issues
« Reply #3 on: January 18, 2021, 04:17:25 PM »
Hello JRMertes,

For cylindrical orthomosaic generation you should also select the mesh source, as it currently doesn't work for DEM source option in this mode.


Hello, Alexey
I have reported this option not working more than a year ago. You also answered "currently..." and that made me think it was a temporary issue... I have seen quite a number of updates and fixes since, but this inability remains unsolved. Why? I remember it worked well once, so I wonder what it takes so long this fix to come. IN the meantime the option should be disabled to warn user to not waste time.
Best regards.