Forum

Author Topic: Error when creating dense cloud in Metashape 1.7.0  (Read 7261 times)

Erik Holmlund

  • Newbie
  • *
  • Posts: 37
    • View Profile
Error when creating dense cloud in Metashape 1.7.0
« on: January 07, 2021, 01:58:59 PM »
Hi,
As of Metashape 1.7.0, I can no longer generate a dense cloud for a specific project. It fails with the error:

Code: [Select]
Error: Assertion 23910910009 failed at line 54!
Dense cloud generation works well on other projects but this one. I have tried remaking the project on the images, with no other result. Could it be the images?

I use four fiducial marks to align them. All images have the same image height, but the width varies with two pixels, if that is maybe relevant. Another project with fiducials has differing resolutions but work well, however. The only thing differing the two is that the failing one has near-horizontal looking images, while the working one is at nadir angles.

Thank you in advance.

Kind regards,
Erik

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14753
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #1 on: January 08, 2021, 04:13:12 PM »
Hello Erik,

It seems that the current Metashape version fails during the depth maps generation for the scanned images with fiducial marks.

As a workaround, you can switch off new depth maps by setting "main/depth_pm_enable" tweak value to False via Advanced Preferences tab.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Erik Holmlund

  • Newbie
  • *
  • Posts: 37
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #2 on: January 13, 2021, 05:56:37 PM »
Hi Alexey,
Thank you for the reply! Looking forward to seeing it working!

Best,
Erik

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14753
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #3 on: January 23, 2021, 09:10:20 PM »
Hello Erik,

We have published version 1.7.1 where the depth maps generation for scanned images with fiducial marks.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Iluvathar

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #4 on: January 28, 2021, 12:18:36 PM »
hello i have the same issue with the last updates !
failed #3 BuildDepthMaps.initialize (1/1): Assertion 23910910127 failed at line 314!
i havent used yet my markers
and the tweak is not working it's telling me that this parameter is not found (main/depth_pm_enable)
« Last Edit: January 28, 2021, 12:20:50 PM by Iluvathar »

Paulo

  • Hero Member
  • *****
  • Posts: 1273
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #5 on: January 28, 2021, 02:05:01 PM »
Helllo lluvathar,

it seems that for latest version 1.7.1, the tweak has changed to
Code: [Select]
BuildDepthMaps/pm_enable
Best Regards,
Paul Pelletier,
Surveyor

Iluvathar

  • Newbie
  • *
  • Posts: 29
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #6 on: January 28, 2021, 03:52:12 PM »
working !
Does this tweak means that we are using the "old way (1.6 way ?)" depht map generation meanwhile whaiting for the bug to be corrected ?(
Is there a database for tweaks or did you found it by yourself ?
Thanks a lot !
 

Paulo

  • Hero Member
  • *****
  • Posts: 1273
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #7 on: January 28, 2021, 05:37:16 PM »
Yes with this tweak set to false then the Depth Maps generation will use the old method^(1.6)....

I found out about this by noticing that since latest installation, the original tweak "main/depth_pm_enable" had changed to  "BuildDepthMaps/.... "

But I do agree that more documentation on the nebelous Tweaks would be welcome!
Best Regards,
Paul Pelletier,
Surveyor

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14753
    • View Profile
Re: Error when creating dense cloud in Metashape 1.7.0
« Reply #8 on: January 28, 2021, 06:19:48 PM »
hello i have the same issue with the last updates !
failed #3 BuildDepthMaps.initialize (1/1): Assertion 23910910127 failed at line 314!
i havent used yet my markers
and the tweak is not working it's telling me that this parameter is not found (main/depth_pm_enable)
Hello Iluvathar,

Can you please share a couple of images (with the related project with assigned fiducials) to support@agisoft.com, so that we could check the issue on our side?
Also please send the processing log from the Console pane related to the failed operation (without using the tweak).
Best regards,
Alexey Pasumansky,
Agisoft LLC