Forum

Author Topic: Avi file wrong duration when exporting animation in 4K  (Read 1951 times)

Mariusz_M

  • Newbie
  • *
  • Posts: 34
    • View Profile
Avi file wrong duration when exporting animation in 4K
« on: January 27, 2021, 05:54:27 PM »
There is a problem in Metashape Standard version 1.66 (and probably 1.7.1, as there is no mention in the changelog about it) with generating AVI files in 4K. In 1080 I can easily export 2-minute MJPEG videos at 60 fps, but when I switch to 4K 60 fps I end up with a 15 GB AVI video that every program sees as 1 second long and it is impossible to convert. But the correct video stream is there and it plays normally on the build in Windows 10 player. It just has wrong duration and every converter stops converting after the first second.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14104
    • View Profile
Re: Avi file wrong duration when exporting animation in 4K
« Reply #1 on: January 27, 2021, 06:33:39 PM »
Hello Mariusz,

Does it happen with any rendered video with the duration longer than 1 second?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mariusz_M

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Avi file wrong duration when exporting animation in 4K
« Reply #2 on: January 27, 2021, 08:22:24 PM »
Update.

It looks like it does not work in Full HD either. When I render at 60 FPS, I get 15-second videos that play correctly under Windows built in player but every other program sees them as 15-second videos. When I render Full HD at 30 frames, my video shows as 30-sec-long. I've tried now with 1.7.1 and the result is the same.

I used to be able to export animations as videos in Full HD.

I keep trying with a 2-minute long animation  and each time the result is different, but it does depend on resolution and framerate. It shows  as 1- to 30- sec long, but the actual content of each file when played underwindows is always 2 min, as it should and the stream looks good. But since only this one player sees the actual length of the stream, I cannot work with the video or convert it.

When played under VLC Player, it shows some kind of index error and goes into a loop of fixing it. All I see is progress bar there and once it gets to 100%, it restarts the process, so I never actually see the video there.
« Last Edit: January 27, 2021, 08:30:01 PM by Mariusz_M »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14104
    • View Profile
Re: Avi file wrong duration when exporting animation in 4K
« Reply #3 on: January 27, 2021, 10:24:55 PM »
What is the size of the video files that behave as described?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Mariusz_M

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Avi file wrong duration when exporting animation in 4K
« Reply #4 on: January 28, 2021, 06:16:32 PM »
All of them are from a 2-minute animation and are 2 minutes long when played under windows built in player.

1. Full HD 60fps is 4.6 GB (seen as 2 sec long)
2. Full HD 30fps is 2.3 GB (seen as 16 sec long)
3. 4K 60ps is 15.2 GB (seen as 1 sec long)

I have run several tests and the display length of the videos is always the same.

I have also noticed that if I now render a FULL HD video on my 4k system, eaach frame is poorly downscaled, so I get weird noise on my full HD videos. Rendering in 4k gives much better result, but some small noise is still there, like there was incorrect anti-aliasing setting.

I rendered the same video a year ago in Full HD 60fps and there was no problem with it. The displayed length is 2 minutes and the file size is 3.39 GB. There is no noise on the old video, only on the new ones.
« Last Edit: January 28, 2021, 07:20:12 PM by Mariusz_M »

Mariusz_M

  • Newbie
  • *
  • Posts: 34
    • View Profile
Re: Avi file wrong duration when exporting animation in 4K
« Reply #5 on: January 28, 2021, 08:56:38 PM »
Update

The noise only happens when I process some models, only those with many detailed 4096px textures, like buildings. When the camera comes closer to one section of a model and the texture becomes bigger, the noise disappears.

I have now ticked "Enable mipmap generation" under Advanced preferences and there is no more noise in Full HD video, but everything seems less detailed. In 4K also no more noise (there actually was some small noise before) and also everything bit less detailed, but acceptable.