Forum

Author Topic: Fails to import pointclouds from ReCap  (Read 774 times)

Möller

  • Newbie
  • *
  • Posts: 1
    • View Profile
Fails to import pointclouds from ReCap
« on: February 03, 2021, 03:59:16 PM »
I want to combine a point cloud from aerial photography with one scanned with a terrestrial laser scanner.

From Autodesk ReCap, I can export .e57 and .pts files. I've tried both formats with a couple of different clouds.

With .e57, Agisoft Metashape immediately crashes.

With .pts, I get a progress bar and after a while the import is finished. I get a dense cloud in Agisoft, but the cloud contains 0 points.

What am I missing?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12742
    • View Profile
Re: Fails to import pointclouds from ReCap
« Reply #1 on: February 05, 2021, 12:14:58 AM »
Hello Möller,

If possible please send E57 that crashes the application to support@agisoft.com (as a download link, if the file is large), so that we could check it on our side.

As for the PTS file, I assume that the first line of the file doesn't contain the number of points to be imported, as expected by Metashape importer.

Please also make sure that you are using latest Metashape Pro release version.
Best regards,
Alexey Pasumansky,
Agisoft LLC

toxicmag

  • Jr. Member
  • **
  • Posts: 87
    • View Profile
Re: Fails to import pointclouds from ReCap
« Reply #2 on: March 26, 2021, 07:05:26 PM »
Any news on that? 

Having the same issue with LAS (and LAZ) coming from Cloudcompare. Tried exports of standard LAS/LAZ format in CloudCompare and also version 1.3 / 1.4.
Metashape 1.7.2 (12070) 64bit version is crashing instantly not even showing the import dialogue (choose CRS etc.). It happens also in version 1.7.0 build 11637.

Checked on two devices (Desktop 32 core AMD Ryzen; 128GB RAM; Notebook i7 with 64GB RAM) and always the same crashes.

BTW: E57 of exactly the same pointcloud works fine.

Would be great to get this done.

« Last Edit: March 26, 2021, 07:39:44 PM by toxicmag »
#multirotor #VTOL #Trinity #Quantum-Systems #a6000 #a7R #RedEdge #ALTUM #RX1II

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 12742
    • View Profile
Re: Fails to import pointclouds from ReCap
« Reply #3 on: March 27, 2021, 02:24:09 PM »
Having the same issue with LAS (and LAZ) coming from Cloudcompare. Tried exports of standard LAS/LAZ format in CloudCompare and also version 1.3 / 1.4.
Metashape 1.7.2 (12070) 64bit version is crashing instantly not even showing the import dialogue (choose CRS etc.). It happens also in version 1.7.0 build 11637.

Hello Alex,

Can you send any example of LAS or LAZ file that crashes Metashape on import to support@agisoft.com?
Best regards,
Alexey Pasumansky,
Agisoft LLC