Forum

Author Topic: Remote Access and Metashape  (Read 2940 times)

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Remote Access and Metashape
« on: January 27, 2021, 06:40:42 AM »
Hello,

I have installed Metashape 1.7.1 Pro on a workstation with the following specs:
- CPU: Intel i9-9940X.
- RAM: 128GB.
- GPU: 2x NVidia Quadro RTX4000.

I am trying to work remotely on the workstation from an HP laptop that has the following specs:
- CPU: Intel i5-6440HQ.
- RAM: 16GB.
- GPU: Intel HD530.

I have tried to run remotely both from TeamViewer and AnyDesk. In both Metashape opens as in the attached screenshot. I've tried adding the --opengl angle argument per some earlier posts found in the forum, but that didn't work either. What am I doing wrong?

Thank you for any reply.

All best

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Remote Access and Metashape
« Reply #1 on: January 27, 2021, 12:04:13 PM »
Hello Cyberworld,

Do you know, which NVIDIA driver version is installed on the remote machine?

Do other OpenGL applications work fine via such connection (for example, Google Earth switched to OpenGL mode in preferences)?
Best regards,
Alexey Pasumansky,
Agisoft LLC

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Remote Access and Metashape
« Reply #2 on: January 27, 2021, 08:12:59 PM »
The drivers for the Quadro RTX4000 were version 430.86, which seemed outdated. I've since installed version 461.40 (latest for this card according to Nvidia) performing a clean install to remove any settings and profiles used in the past.

This has not changed anything. Also, all OpenGL programs don't work. Tested with Google Earth and Blender. The Nvidia Control Panel also seems to be missing all the options I used to have!

Any ideas as to what needs to be done to fix this?

Side note: From my desktop PC (CPU: Intel i7 2800K, RAM: 32GB, GPU: Nvidia GeForce 560Ti), which has a dedicated Nvidia card, I was able to connect to the workstation and everything worked normally.
« Last Edit: January 27, 2021, 08:14:57 PM by Cyberworld »

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Remote Access and Metashape
« Reply #3 on: January 27, 2021, 10:20:45 PM »
Hello Cyberworld,

At the moment I can only suggest to update Intel graphics drivers on the local laptop, just for case. And check, if the issue persists both for Remote Desktop and TeamViewer connection.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Remote Access and Metashape
« Reply #4 on: February 11, 2021, 01:13:07 AM »
Hello Cyberworld,

At the moment I can only suggest to update Intel graphics drivers on the local laptop, just for case. And check, if the issue persists both for Remote Desktop and TeamViewer connection.

Hello, I brought my desktop PC and it works fine on both Anydesk and TeamViewer. Apparently it is an OpenCL issue with Intel drivers, but I was not able to figure out what. I tried solutions via Group Policy and Registry hacks, but nothing worked. Anyway, the update is on informational grounds.

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Remote Access and Metashape
« Reply #5 on: February 11, 2021, 06:17:50 PM »
Hello Cyberworld,

You can also try to install the latest compatible Intel driver from their web-site directly:
https://downloadcenter.intel.com/en/download/30195/Intel-Graphics-Driver-Windows-15-45-
Best regards,
Alexey Pasumansky,
Agisoft LLC

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Remote Access and Metashape
« Reply #6 on: February 11, 2021, 06:36:02 PM »
Hello Cyberworld,

You can also try to install the latest compatible Intel driver from their web-site directly:
https://downloadcenter.intel.com/en/download/30195/Intel-Graphics-Driver-Windows-15-45-

I had tried, but it was already updated to the most recent version and unfortunately it didn't work either.