Forum

Author Topic: Null Image error during Mesh Refinement  (Read 2145 times)

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Null Image error during Mesh Refinement
« on: February 11, 2021, 01:19:58 AM »
I've been trying to refine a rather large mesh (20 mil. - this is necessary, it is a woodcarved artefact with lots of detail) on a suitably equipped workstation (128GB RAM, two Quadro RTX4000, Intel i9-9940X). The project has aligned successfully 594 cameras, produced both sparse and dense clouds, and a mesh from the dense cloud. In the past refine mesh worked for meshes up to 14-18mil polygons. Is this one failing due to larger polygon count or something else?

I attach the log data:
Code: [Select]
2021-02-10 11:27:29 RefineMesh: quality = Ultra high, iterations = 4, smoothness = 0.3
2021-02-10 11:27:29 Initializing...
2021-02-10 11:27:31 Found 2 GPUs in 0 sec (CUDA: 0 sec, OpenCL: 0 sec)
2021-02-10 11:27:31 Using device: Quadro RTX 4000, 36 compute units, free memory: 6723/8192 MB, compute capability 7.5
2021-02-10 11:27:31   driver/runtime CUDA: 11020/8000
2021-02-10 11:27:31   max work group size 1024
2021-02-10 11:27:31   max work item sizes [1024, 1024, 64]
2021-02-10 11:27:31 Using device: Quadro RTX 4000, 36 compute units, free memory: 6503/8192 MB, compute capability 7.5
2021-02-10 11:27:31   driver/runtime CUDA: 11020/8000
2021-02-10 11:27:31   max work group size 1024
2021-02-10 11:27:31   max work item sizes [1024, 1024, 64]
2021-02-10 11:27:31 Device 'Quadro RTX 4000' has 6631 Mb of free memory
2021-02-10 11:27:32 Device 'Quadro RTX 4000' has 6411 Mb of free memory
2021-02-10 11:27:32 Analyzing mesh...
2021-02-10 11:27:33 Faces: 20000000, Vertices: 10004718
2021-02-10 11:27:33 Memory required on each device: 2507 Mb + 4196 Mb = 6703 Mb
2021-02-10 11:27:33 Using device 'Quadro RTX 4000' with out of core 1x0x2 subdivision
2021-02-10 11:27:33 Using device 'Quadro RTX 4000' with out of core 1x0x2 subdivision
2021-02-10 11:49:13 Images quality=UltraHigh is too low (1.92356 pixels per triangle)...
2021-02-10 11:49:13 Target quality=UltraHigh is too low for model detalization. Processing with quality=UNKNOWN instead...
2021-02-10 11:49:13 Stage #1 out of 1
2021-02-10 11:49:14 Faces: 20000000, Vertices: 10004718
2021-02-10 11:49:14 Memory required on each device: 0 Mb + 4196 Mb = 4196 Mb
2021-02-10 11:49:15 Subdividing mesh...
2021-02-10 11:49:22 Faces: 20000000, Vertices: 10004718
2021-02-10 11:49:22 Memory required on each device: 0 Mb + 4196 Mb = 4196 Mb
2021-02-10 11:49:22 Loading photos...
2021-02-10 11:49:23 Finished processing in 1314.39 sec (exit code 0)
2021-02-10 11:49:24 Error: Null image

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Null Image error during Mesh Refinement
« Reply #1 on: February 11, 2021, 06:20:03 PM »
Hello Cyberworld,

Do other image-related operations work for the same project (like depth maps generation or texture blending)?

Please also specify the dimensions of the images used in this project.
Best regards,
Alexey Pasumansky,
Agisoft LLC

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Null Image error during Mesh Refinement
« Reply #2 on: February 11, 2021, 06:33:45 PM »
Hello Cyberworld,

Do other image-related operations work for the same project (like depth maps generation or texture blending)?

Please also specify the dimensions of the images used in this project.

Yes I can confirm that depth maps and textures are produced as expected. The images are 50MP (8688x5792) RAW pictures taken with Canon EOS 5DS R using the sRGB colour profile, converted into DNG then corrected in Photoshop Camera Raw and exported to 16-bit TIFFs with the ProPhoto RGB colour profile. The latter corrected/processed images are the ones used in Metashape.

Cyberworld

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: Null Image error during Mesh Refinement
« Reply #3 on: February 11, 2021, 06:40:00 PM »
PS: I noticed in the log that it says the Ultra High quality selected is too low. But there is no higher option or custom option to select. Does that affect the operation?

Alexey Pasumansky

  • Agisoft Technical Support
  • Hero Member
  • *****
  • Posts: 14099
    • View Profile
Re: Null Image error during Mesh Refinement
« Reply #4 on: February 15, 2021, 06:53:57 PM »
Hello Cyberworld,

Please check pre-release of 1.7.2, whether you are able to get mesh refinement operation working on the same project:

http://download.agisoft.com/metashape-pro_1_7_2_x64.msi                    - Windows 64 bit
http://download.agisoft.com/metashape-pro_1_7_2.dmg                          - Mac OS
http://download.agisoft.com/metashape-pro_1_7_2_amd64.tar.gz           - Linux 64 bit

http://download.agisoft.com/metashape_1_7_2_x64.msi                        - Windows 64 bit
http://download.agisoft.com/metashape_1_7_2.dmg                               - macOS
http://download.agisoft.com/metashape_1_7_2_amd64.tar.gz                - Linux 64 bit

However, I would also suggest to check, if using depth maps based mesh generation in High/Ultra quality allows to get the result that meets your expectations related to the level of detail, without a need to run Refine Mesh operation.
Best regards,
Alexey Pasumansky,
Agisoft LLC